cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

523
Views
0
Helpful
2
Replies
Highlighted
Beginner

Help with PPPoE configuration

Hello,

I want to connect my Cisco 1905 router to a DSL modem (modem in fully bridged mode) and configure PPPoE to get the IP parameters from ISP. Currently we are using a Linksys home router as the internet gateway. Below can see the screenshot of PPPoE configuartion in my Linksys router and this is working fine.

waaan.jpg

Now I want to replace it with 1905 router. I configured my router like below but it is not working, means I cannot connect with Internet. Please can someone guide me with this. What I am doing wrong here?

interface GigabitEthernet0/0

description LAN_INTERFACE

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

interface Ethernet0/1

description ADSL_WAN_INTERFACE

no ip address           

pppoe enable         

pppoe-client dial-pool-number 1

interface Dialer1

description WAN_DIALLER_INTERFACE

ip address negotiated          

ip nat outside            

ip mtu 1492           

encapsulation ppp       

no ip mroute-cache

dialer pool 1                            

ppp authentication pap                       

ppp pap sent-username xxxxxx password xxxxxx  

dialer-list 1 protocol ip permit  

ip nat inside source list 10 interface Dialer0 overload

ip route 0.0.0.0 0.0.0.0 Dialer0

access-list 10 permit 192.168.1.0 0.0.0.255 log

Regards,
Tony

       

Regards, Tony http://yadhutony.blogspot.com
Everyone's tags (1)
2 REPLIES 2
Highlighted
Hall of Fame Master

Re: Help with PPPoE configuration

Take "debug ppp neg" and "debug ppp auth" with "term mon".

If no output, leave modem off for few hours to clear anypossuble MAC lock.

Highlighted
Beginner

Help with PPPoE configuration

Hi Paolo,

Thank you for your reply.

I took the debug output. Please have a look at it.

Jun 17 13:18:45.299: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to down

Jun 17 13:18:46.299: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state to down

Jun 17 13:18:52.067: %SEC-6-IPACCESSLOGNP: list 10 permitted 0 192.168.1.27 -> 0.0.0.0, 9 packets

Jun 17 13:18:52.067: %SEC-6-IPACCESSLOGNP: list 10 permitted 0 192.168.1.241 -> 0.0.0.0, 169 packets

Jun 17 13:18:52.067: %SEC-6-IPACCESSLOGNP: list 10 permitted 0 192.168.1.55 -> 0.0.0.0, 22 packets

Jun 17 13:19:36.299: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state to up

Jun 17 13:19:37.299: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up

Jun 17 13:19:42.299: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to down

Jun 17 13:19:43.307: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state to down

Jun 17 13:19:46.299: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state to up

Jun 17 13:19:47.299: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up

Jun 17 13:19:52.067: %SEC-6-IPACCESSLOGNP: list 10 permitted 0 192.168.1.100 -> 0.0.0.0, 17 packets

Jun 17 13:19:52.067: %SEC-6-IPACCESSLOGNP: list 10 permitted 0 192.168.1.44 -> 0.0.0.0, 151 packets

Jun 17 13:19:52.067: %SEC-6-IPACCESSLOGNP: list 10 permitted 0 192.168.1.31 -> 0.0.0.0, 130 packets

Jun 17 13:21:40.687: %DIALER-6-BIND: Interface Vi3 bound to profile Di0

Jun 17 13:21:40.691: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to up

Jun 17 13:21:40.691: Vi3 PPP: Sending cstate UP notification

Jun 17 13:21:40.691: Vi3 PPP: Processing CstateUp message

Jun 17 13:21:40.691: PPP: Alloc Context [289F43D4]

Jun 17 13:21:40.691: ppp4 PPP: Phase is ESTABLISHING

Jun 17 13:21:40.691: Vi3 PPP: Using dialer call direction

Jun 17 13:21:40.691: Vi3 PPP: Treating connection as a callout

Jun 17 13:21:40.691: Vi3 PPP: Session handle[B5000004] Session id[4]

Jun 17 13:21:40.691: Vi3 LCP: Event[OPEN] State[Initial to Starting]

Jun 17 13:21:40.691: Vi3 LCP: O CONFREQ [Starting] id 1 len 14

Jun 17 13:21:40.691: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.691: Vi3 LCP:    MagicNumber 0x57B079A3 (0x050657B079A3)

Jun 17 13:21:40.691: Vi3 LCP: Event[UP] State[Starting to REQsent]

Jun 17 13:21:40.787: Vi3 LCP: I CONFREQ [REQsent] id 57 len 18

Jun 17 13:21:40.787: Vi3 LCP:    MRU 1492 (0x010405D4)

Jun 17 13:21:40.787: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.787: Vi3 LCP:    MagicNumber 0x00D9D2AE (0x050600D9D2AE)

Jun 17 13:21:40.787: Vi3 LCP: O CONFNAK [REQsent] id 57 len 8

Jun 17 13:21:40.787: Vi3 LCP:    MRU 1500 (0x010405DC)

Jun 17 13:21:40.787: Vi3 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]

Jun 17 13:21:40.787: Vi3 LCP: I CONFREJ [REQsent] id 1 len 8

Jun 17 13:21:40.787: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.787: Vi3 LCP: O CONFREQ [REQsent] id 2 len 14

Jun 17 13:21:40.787: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.787: Vi3 LCP:    MagicNumber 0x57B079A3 (0x050657B079A3)

Jun 17 13:21:40.787: Vi3 LCP: Event[Receive ConfNak/Rej] State[REQsent to REQsent]

Jun 17 13:21:40.811: Vi3 LCP: I CONFREQ [REQsent] id 58 len 18

Jun 17 13:21:40.811: Vi3 LCP:    MRU 1492 (0x010405D4)

Jun 17 13:21:40.811: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.811: Vi3 LCP:    MagicNumber 0x00D9D2AE (0x050600D9D2AE)

Jun 17 13:21:40.811: Vi3 LCP: O CONFNAK [REQsent] id 58 len 8

Jun 17 13:21:40.811: Vi3 LCP:    MRU 1500 (0x010405DC)

Jun 17 13:21:40.811: Vi3 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]

Jun 17 13:21:40.811: Vi3 LCP: I CONFREJ [REQsent] id 2 len 8

Jun 17 13:21:40.811: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.811: Vi3 LCP: O CONFREQ [REQsent] id 3 len 14

Jun 17 13:21:40.811: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.811: Vi3 LCP:    MagicNumber 0x57B079A3 (0x050657B079A3)

Jun 17 13:21:40.811: Vi3 LCP: Event[Receive ConfNak/Rej] State[REQsent to REQsent]

Jun 17 13:21:40.839: Vi3 LCP: I CONFREQ [REQsent] id 59 len 18

Jun 17 13:21:40.839: Vi3 LCP:    MRU 1492 (0x010405D4)

Jun 17 13:21:40.839: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.839: Vi3 LCP:    MagicNumber 0x00D9D2AE (0x050600D9D2AE)

Jun 17 13:21:40.839: Vi3 LCP: O CONFNAK [REQsent] id 59 len 8

Jun 17 13:21:40.839: Vi3 LCP:    MRU 1500 (0x010405DC)

Jun 17 13:21:40.839: Vi3 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]

Jun 17 13:21:40.839: Vi3 LCP: I CONFREJ [REQsent] id 3 len 8

Jun 17 13:21:40.839: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.839: Vi3 LCP: O CONFREQ [REQsent] id 4 len 14

Jun 17 13:21:40.839: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.839: Vi3 LCP:    MagicNumber 0x57B079A3 (0x050657B079A3)

Jun 17 13:21:40.839: Vi3 LCP: Event[Receive ConfNak/Rej] State[REQsent to REQsent]

Jun 17 13:21:40.867: Vi3 LCP: I CONFREQ [REQsent] id 60 len 18

Jun 17 13:21:40.867: Vi3 LCP:    MRU 1492 (0x010405D4)

Jun 17 13:21:40.867: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.867: Vi3 LCP:    MagicNumber 0x00D9D2AE (0x050600D9D2AE)

Jun 17 13:21:40.867: Vi3 LCP: O CONFNAK [REQsent] id 60 len 8

Jun 17 13:21:40.867: Vi3 LCP:    MRU 1500 (0x010405DC)

Jun 17 13:21:40.867: Vi3 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]

Jun 17 13:21:40.867: Vi3 LCP: I CONFREJ [REQsent] id 4 len 8

Jun 17 13:21:40.867: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.867: Vi3 LCP: O CONFREQ [REQsent] id 5 len 14

Jun 17 13:21:40.867: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.867: Vi3 LCP:    MagicNumber 0x57B079A3 (0x050657B079A3)

Jun 17 13:21:40.867: Vi3 LCP: Event[Receive ConfNak/Rej] State[REQsent to REQsent]

Jun 17 13:21:40.891: Vi3 LCP: I CONFREQ [REQsent] id 61 len 18

Jun 17 13:21:40.891: Vi3 LCP:    MRU 1492 (0x010405D4)

Jun 17 13:21:40.891: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.891: Vi3 LCP:    MagicNumber 0x00D9D2AE (0x050600D9D2AE)

Jun 17 13:21:40.891: Vi3 LCP: O CONFNAK [REQsent] id 61 len 8

Jun 17 13:21:40.891: Vi3 LCP:    MRU 1500 (0x010405DC)

Jun 17 13:21:40.891: Vi3 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]

Jun 17 13:21:40.895: Vi3 LCP: I CONFREJ [REQsent] id 5 len 8

Jun 17 13:21:40.895: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.895: Vi3 LCP: O CONFREQ [REQsent] id 6 len 14

Jun 17 13:21:40.895: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.895: Vi3 LCP:    MagicNumber 0x57B079A3 (0x050657B079A3)

Jun 17 13:21:40.895: Vi3 LCP: Event[Receive ConfNak/Rej] State[REQsent to REQsent]

Jun 17 13:21:40.919: Vi3 LCP: I CONFREQ [REQsent] id 62 len 18

Jun 17 13:21:40.919: Vi3 LCP:    MRU 1492 (0x010405D4)

Jun 17 13:21:40.919: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.919: Vi3 LCP:    MagicNumber 0x00D9D2AE (0x050600D9D2AE)

Jun 17 13:21:40.919: Vi3 LCP: Sent too many CONFNAKs.  Switch to CONFREJ

Jun 17 13:21:40.919: Vi3 LCP: O CONFREJ [REQsent] id 62 len 8

Jun 17 13:21:40.919: Vi3 LCP:    MRU 1492 (0x010405D4)

Jun 17 13:21:40.919: Vi3 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]

Jun 17 13:21:40.919: Vi3 LCP: I CONFREJ [REQsent] id 6 len 8

Jun 17 13:21:40.919: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.919: Vi3 LCP: O CONFREQ [REQsent] id 7 len 14

Jun 17 13:21:40.919: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.919: Vi3 LCP:    MagicNumber 0x57B079A3 (0x050657B079A3)

Jun 17 13:21:40.919: Vi3 LCP: Event[Receive ConfNak/Rej] State[REQsent to REQsent]

Jun 17 13:21:40.947: Vi3 LCP: I CONFREQ [REQsent] id 63 len 14

Jun 17 13:21:40.947: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.947: Vi3 LCP:    MagicNumber 0x00D9D2AE (0x050600D9D2AE)

Jun 17 13:21:40.947: Vi3 LCP: O CONFACK [REQsent] id 63 len 14

Jun 17 13:21:40.947: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.947: Vi3 LCP:    MagicNumber 0x00D9D2AE (0x050600D9D2AE)

Jun 17 13:21:40.947: Vi3 LCP: Event[Receive ConfReq+] State[REQsent to ACKsent]

Jun 17 13:21:40.947: Vi3 LCP: I CONFREJ [ACKsent] id 7 len 8

Jun 17 13:21:40.947: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.947: Vi3 LCP: O CONFREQ [ACKsent] id 8 len 14

Jun 17 13:21:40.947: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.947: Vi3 LCP:    MagicNumber 0x57B079A3 (0x050657B079A3)

Jun 17 13:21:40.947: Vi3 LCP: Event[Receive ConfNak/Rej] State[ACKsent to ACKsent]

Jun 17 13:21:40.975: Vi3 LCP: I CONFREJ [ACKsent] id 8 len 8

Jun 17 13:21:40.975: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.975: Vi3 LCP: O CONFREQ [ACKsent] id 9 len 14

Jun 17 13:21:40.975: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.975: Vi3 LCP:    MagicNumber 0x57B079A3 (0x050657B079A3)

Jun 17 13:21:40.975: Vi3 LCP: Event[Receive ConfNak/Rej] State[ACKsent to ACKsent]

Jun 17 13:21:40.999: Vi3 LCP: I CONFREJ [ACKsent] id 9 len 8

Jun 17 13:21:40.999: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.999: Vi3 LCP: O CONFREQ [ACKsent] id 10 len 14

Jun 17 13:21:40.999: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:40.999: Vi3 LCP:    MagicNumber 0x57B079A3 (0x050657B079A3)

Jun 17 13:21:40.999: Vi3 LCP: Event[Receive ConfNak/Rej] State[ACKsent to ACKsent]

Jun 17 13:21:41.027: Vi3 LCP: I CONFREJ [ACKsent] id 10 len 8

Jun 17 13:21:41.027: Vi3 LCP:    AuthProto PAP (0x0304C023)

Jun 17 13:21:41.027: Vi3 LCP: Received too many CONFREJs.  Closing CP

Jun 17 13:21:41.027: Vi3 PPP DISC: LCP failed to negotiate

Jun 17 13:21:41.027: Vi3 PPP: Sending Acct Event[Down] id[10]

Jun 17 13:21:41.027: PPP: NET STOP send to AAA.

Jun 17 13:21:41.027: Vi3 LCP: O TERMREQ [ACKsent] id 11 len 4

Jun 17 13:21:41.027: Vi3 LCP: Event[CLOSE] State[ACKsent to Closing]

Jun 17 13:21:41.051: Vi3 LCP: I TERMACK [Closing] id 11 len 4

Jun 17 13:21:41.055: Vi3 LCP: Event[Receive TermAck] State[Closing to Closed]

Jun 17 13:21:41.055: Vi3 LCP: Event[DOWN] State[Closed to Initial]

Jun 17 13:21:41.055: Vi3 PPP: Phase is DOWN

Jun 17 13:21:41.055: %DIALER-6-UNBIND: Interface Vi3 unbound from profile Di0

Jun 17 13:21:41.059: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to down

Kindly help me with this.

Regards,
Tony

Regards, Tony http://yadhutony.blogspot.com