cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1143
Views
5
Helpful
11
Replies

How do I use IP SLA source-interface as Loopback 0

Lei.LIM
Level 1
Level 1

TT.png

 

 

 

HI all.

I want to use IP SLA source-interface as Loopback 0

 

R1's config

 

ip sla 1
icmp-echo 2.2.2.2 source-interface loopback 0 
!
ip sla schedule 1 life forever start now
!
track 1 ip sla 1 reachability 
!
ip route 2.2.2.2 255.255.255.255 192.168.1.2 track 1

 

I set it up like this
2.2.2.2 is not visible in the routing table
The link is not connected at the time of sh ip sla sum.

Is there anything wrong with me?

 

11 Replies 11

in R2 
ip route 1.1.1.1 255.255.255.255 192.168.2.x <<- this for return back traffic

Note:-
in router w/o NAT and w/0 default route 
do command show ip route 
you must see ALL ALL route in your network 

Of course, return routing exists in R2.

But I didn't apply SLA to R2 and I'm testing it.

Only static routing is applied.

Ping R1 at R2 is normal, but there is no routing of R2 due to SLA operation in R1.

Can't source-interface be applied as Loopback 0?

Thank you in advance.

share config of both, and Yes you can use LO as source.

R1

ip sla 1
icmp-echo 2.2.2.2 source-interface loopback 0 
!
ip sla schedule 1 life forever start now
!
track 1 ip sla 1 reachability 
!
ip route 2.2.2.2 255.255.255.255 192.168.1.2 track 1

 

R2

ip route 1.1.1.1 255.255.255.255 192.168.1.1

 

thats all

 

is there something wrong? 

Yes but where is 
interface Loopback 0
ip add 1.1.1.1 255.255.255.255 OR ip add 2.2.2.2 255.255.255.255 ??

Yes both routers IP

 

R1 1.1.1.1 255.255.255.255

R2 2.2.2.2 255.255.255.255

share all config 
share show ip interface brief 

you need to enter the Loopback interface with 
in R1 
interface Loopback 0

ip add 1.1.1.1 255.255.255.255

 

in R2 
interface loopback 0
ip add 2.2.2.2 255.255.255.255

R1#sh run
Building configuration...

Current configuration : 3305 bytes
!
! Last configuration change at 09:33:23 UTC Tue Aug 2 2022
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$bCYO$QNN8UW6sM7BpZrszboGNT0
enable password a
!
no aaa new-model
ethernet lmi ce
!
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
redundancy
!
!
track 1 ip sla 1 reachability
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
ip address 192.168.3.1 255.255.255.0
duplex auto
speed auto
media-type rj45
bfd interval 500 min_rx 500 multiplier 5
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/3
no ip address
duplex auto
speed auto
media-type rj45
no mop enabled
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 2.2.2.2 255.255.255.255 192.168.1.2 track 1
!
ip sla 1
icmp-echo 2.2.2.2 source-interface Loopback0
ip sla schedule 1 life forever start-time now
!
!
!
control-plane
!
banner exec ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS *
* education. IOSv is provided as-is and is not supported by Cisco's *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any *
* purposes is expressly prohibited except as otherwise authorized by *
* Cisco in writing. *
**************************************************************************^C
banner incoming ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS *
* education. IOSv is provided as-is and is not supported by Cisco's *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any *
* purposes is expressly prohibited except as otherwise authorized by *
* Cisco in writing. *
**************************************************************************^C
banner login ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS *
* education. IOSv is provided as-is and is not supported by Cisco's *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any *
* purposes is expressly prohibited except as otherwise authorized by *
* Cisco in writing. *
**************************************************************************^C
!
line con 0
line aux 0
line vty 0 4
password a
login
transport input none
!
no scheduler allocate
!
end

R1#

R1#sh ip int br
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 192.168.1.1 YES NVRAM up up
GigabitEthernet0/1 unassigned YES manual administratively down down
GigabitEthernet0/2 unassigned YES NVRAM up up
GigabitEthernet0/3 unassigned YES NVRAM up up
Loopback0 1.1.1.1 YES NVRAM up up
R1#

R2#sh run
Building configuration...

Current configuration : 3132 bytes
!
! Last configuration change at 09:33:48 UTC Tue Aug 2 2022
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$vD0N$Qlg/3cOsgyJ5uyvte1WMl.
enable password a
!
no aaa new-model
ethernet lmi ce
!
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/3
no ip address
duplex auto
speed auto
media-type rj45
no mop enabled
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 1.1.1.1 255.255.255.255 192.168.1.1
!
!
!
!
control-plane
!
banner exec ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS *
* education. IOSv is provided as-is and is not supported by Cisco's *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any *
* purposes is expressly prohibited except as otherwise authorized by *
* Cisco in writing. *
**************************************************************************^C
banner incoming ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS *
* education. IOSv is provided as-is and is not supported by Cisco's *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any *
* purposes is expressly prohibited except as otherwise authorized by *
* Cisco in writing. *
**************************************************************************^C
banner login ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS *
* education. IOSv is provided as-is and is not supported by Cisco's *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any *
* purposes is expressly prohibited except as otherwise authorized by *
* Cisco in writing. *
**************************************************************************^C
!
line con 0
line aux 0
line vty 0 4
password a
login
transport input none
!
no scheduler allocate
!
end

R2#

R2#sh ip int br
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 192.168.1.2 YES NVRAM up up
GigabitEthernet0/1 192.168.2.1 YES NVRAM up up
GigabitEthernet0/2 unassigned YES NVRAM administratively down down
GigabitEthernet0/3 unassigned YES NVRAM up up
Loopback0 2.2.2.2 YES NVRAM up up
R2#

 

can  you test in your lab?

 

Your config is correct, but unfortunately IP SLA not work when source-interface or source-ip is LOOPBACK.
I check this point. 
and I do lab also there is no ICMP packet from R1 toward R2.
sorry you need to change the source.

Since there is no any mention in Cisco about this point I do small lab but with new idea,
and it work using IP SLA with LO is work only if the track is not use for static route of IP SLA destination.
THIS WORKAOUND I NOT RECOMMEND.

nbnbvnvbnvbnvbn.pngbvnvbnbnvbn.png

Maxizman
Level 1
Level 1

Try to specify the frequency in SLA config.

Review Cisco Networking for a $25 gift card