cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3735
Views
0
Helpful
1
Replies

How to always keep 3G connection up as backup?

dennis_range
Level 1
Level 1

I have many HWIC-3G-HSPA cards as backup connections and I need to keep them up for monitoring purposes. Being a backup connection they get little interesting traffic for them to spring into life but they are the source interface for a tunnel interface (we use DMVPN). The interface still insists on going down. I have even added static routes to the DMVPN hubs over the cellular interface and they still go down. What command do I enter to always keep them up? I had originally used 'dialer idle-timeout 0' and then removed it altogether which the same results. Below is what I have now.

interface Cellular0/1/0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer in-band
dialer string gsmscript
dialer-group 1
async mode interactive
ppp chap hostname //username//
ppp chap password //password//

ppp ipcp dns request

access-list 1 permit any
dialer-list 1 protocol ip list 1

line 0/1/0
exec-timeout 0 0
script dialer gsmscript
modem InOut
no exec
transport input all
transport output all
rxspeed 7200000
txspeed 5760000

1 Reply 1

Matteo Comisso
Level 1
Level 1

Hi Dennis,

I had the same problem and, thanks to uncle Google, I've found the solution

This is the final config:

Router#sh run    

Building configuration...

Current configuration : 2120 bytes

!

! Last configuration change at 12:04:38 UTC Mon Nov 14 2011

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

!

dot11 syslog

ip source-route

!

!

!

!

!        

ip cef

ip name-server 208.67.222.222

ip name-server 208.67.220.220

ip ddns update method ddns

HTTP

  add http://username:password@members.dyndns.org/nic/update?hostname=password@members.dyndns.org/nic/update?hostname=&myip=

  remove http://username:password@members.dyndns.org/nic/update?hostname=password@members.dyndns.org/nic/update?hostname=&myip=

interval maximum 0 1 0 0

!

!

multilink bundle-name authenticated

!

chat-script gsm "" "ATDT*99#" TIMEOUT 60 "CONNECT"

crypto pki token default removal timeout 0

!

!

!

!

license udi pid CISCO2801 sn FCZ102213BX

!

redundancy

!        

!

controller Cellular 0/1

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Cellular0/1/0

no ip address

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer in-band

dialer pool-member 1

async mode interactive

ppp chap hostname

ppp chap password 0

ppp ipcp dns request

!

interface Cellular0/1/1

no ip address

encapsulation ppp

!

interface Dialer1

ip ddns update hostname myhostname.dyndns.org

ip ddns update ddns

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

dialer idle-timeout 0

dialer string gsm

dialer persistent

no cdp enable

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

ip nat inside source list 10 interface Dialer1 overload

ip route 0.0.0.0 0.0.0.0 Dialer1

!

access-list 1 permit any

dialer-list 1 protocol ip list 1

!

!

!

!

!

control-plane

!

!

!

line con 0

line aux 0

line 0/1/0

exec-timeout 0 0

script dialer gsm

login

modem InOut

no exec

rxspeed 7200000

txspeed 2000000

line 0/1/1

no exec

rxspeed 7200000

txspeed 2000000

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

end

Thanks to the "dialer persistent" parameter, that has to be put into the dialer interface, the cellular line is always up!

Regards,

Matteo