cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2189
Views
5
Helpful
5
Replies
Highlighted
Beginner

How to change source ip in ip nat translation? Please help

Hi guys,

Some network pros have setup our Cisco 3620 many years back during implementation.

I've just added a new server, with new ip, wanted to change the ip of ip nat translation in this router. Anyone can help?

I did a show run, the config is this;

interface FastEthernet0/0

ip address 57.31.132.116 255.255.255.240

no ip redirects

ip nat outside

no ip route-cache cef

no ip route-cache

no ip mroute-cache

speed 100

full-duplex

standby 222 ip 57.31.132.115

standby 222 priority 105

standby 222 preempt

standby 222 authentication cisco222

standby 222 name hsrp-122

!

interface FastEthernet0/1

description SITA External services NAT Trunk

no ip address

no ip route-cache cef

no ip route-cache

no ip mroute-cache

speed 100

full-duplex

!

interface FastEthernet0/1.170

description AODB inside

encapsulation dot1Q 170

ip address 10.110.10.101 255.255.128.0

no ip redirects

ip nat inside

no ip route-cache

no ip mroute-cache

standby 170 ip 10.110.10.100

standby 170 priority 105

standby 170 preempt

standby 170 authentication cisco170

standby 170 name aodb

standby 170 track FastEthernet0/0

!

interface FastEthernet0/1.171

description BHS

encapsulation dot1Q 171

ip address 10.10.10.101 255.255.0.0

no ip redirects

ip nat inside

no ip route-cache

no ip mroute-cache

standby 171 ip 10.10.10.100

standby 171 priority 105

standby 171 preempt

standby 171 authentication cisco171

standby 171 name bhs

standby 171 track FastEthernet0/0

!

ip nat Stateful id 1

     redundancy hsrp-122

         mapping-id 10

ip nat inside source static 10.110.10.33 57.31.132.121 redundancy hsrp-122

ip nat inside source static 10.10.10.50 57.31.132.122 redundancy hsrp-122

ip nat inside source static 10.110.10.7 57.31.132.119 redundancy hsrp-122

ip nat inside source static 10.10.10.51 57.31.132.123 redundancy hsrp-122

ip nat inside source static 10.110.10.4 57.31.132.120 redundancy hsrp-122

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 57.31.132.113

!

My cisco knowledge is very basic. I would like to change this line

ip nat inside source static 10.110.10.33 57.31.132.121 redundancy hsrp-122

or if can, add another line...

My new ip is 10.110.10.123

but i don't have control over 57.31.132.0 network. 10.110.10.0 belongs to us.

so, either change to 10.110.10.123 57.31.132.121 or add another new line like 10.110.10.123 57.31.132.124 ?

Not sure it will impact that network.

Appreciate if anyone could help. thanks.

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Enthusiast

How to change source ip in ip nat translation? Please help

Added in

Config Mode

route (config)# ip nat inside source static (local IP) (Public IP)

Make Sure Local IP that you give its gateway must be Router Inside Interface IP

**Please Rate All Helpful Posts**

Jawad

View solution in original post

5 REPLIES 5
Highlighted
Hall of Fame Master

How to change source ip in ip nat translation? Please help

Hello,

>> add another new line like 10.110.10.123 57.31.132.124

This is lilkely the best option as it would have no impact on existing NAT rules

Hope to help

Giuseppe


Highlighted
Beginner

How to change source ip in ip nat translation? Please help

Thanks for the suggestion.

The next step is.. how can I do it...

Can I copy out the running-config to tftp and edit the text file - add that new line, and reupload to the router? copy tftp to running-config?

or do I have to issue those commands in command line? is so, may i know the steps?

thank you

Highlighted
Hall of Fame Master

How to change source ip in ip nat translation? Please help

Hello,

the new line can be added to the configuration file on the fly if you know the enable password

connect to the router either by telnet or SSH or via console

at router prompt type enable followed by enter

router> enable:

at new prompt enter the enable password

when prompt changes to

router#

configure terminal

router(config)#

!at this point you can insert the line of the new NAT statement

! after that you exit from configuratiion mode

router(config)# exit

! last operation is to save the running configuration

router# wr mem

Hope to help

Giuseppe

Highlighted
Enthusiast

How to change source ip in ip nat translation? Please help

Added in

Config Mode

route (config)# ip nat inside source static (local IP) (Public IP)

Make Sure Local IP that you give its gateway must be Router Inside Interface IP

**Please Rate All Helpful Posts**

Jawad

View solution in original post

Highlighted
Beginner

How to change source ip in ip nat translation? Please help

THANK YOU!!