cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
784
Views
0
Helpful
13
Replies
David Grimm
Beginner

HTTP/HTTPS Protocol errors with IOS 12.4 (16 - 25f)

Does anyone know if there are any issues with IOS 12.4(16) through 12.4(25f) with HTTP/HTTPS protocols running on a 3825 router? I have a remote site that accesses a corporate application over an MPLS, sometimes it works fine, other times it will hang for hours. No errors on circuits, interfaces, ethernet interfaces, etc. Response times are averaging 50ms even when the application freezes. The only thing I can think of is that it could be an issue with the IOS version.

Sent from Cisco Technical Support iPad App

13 REPLIES 13
Konstantin Dunaev
Enthusiast

do you connect to HTTP/HTTPS service on the router?

As you mentioned MPLS and HTTPS - I'd say you should check MTU issues.

I do not connect to the router via HTTP/HTTPS. could you go into a little more detail on MTU issues causing certain applications to intermittently hang?

what kind of application do you mean?

There is a quite common and known  issue with MTU is case of traffic with "Dont-Fragment" bit ( eg. HTTPS)  and smaller "path" MTU size.

It's an HTTP application that accesses a Database Server at my HQ location.

Sent from Cisco Technical Support iPad App

try following - change the local MTU size to 1400  on your server where you are running application, and check if you still see any connection problems.

Here is part of the interface config:

MTU 4470 bytes, sub MTU 4470, BW 1536 Kbit/sec, DLY 20000 usec

Should it be adjusted on my end from 4470 to 1400 to test?

no, what I mean is the MTU directly on a server, just to see if it's really  an MTU issue.

I could probably get my HQ office to make the change for testing. However, The application works great from any other site but this one in particular.

is you Database server is running in HQ? Where do you start the client application from? Can you change the MTU size on the PC/Laptop with a client application?

Sorry for misunderstanding.

Database server is running at HQ, and HTTP application is accessing that from a remote branch office.

I checked the MTU on a client and is set to 1500.

I meant to add this to the last post... I changed the MTU on a client to 1400 and it still hangs on loading.

do you see any problem if you connect from branche office to a normal Web services, HTTP and HTTPS?

Other HTTP/HTTPS services hang up as well. At times, I can click stop, and refresh and it loads up fine. Ive tested with IE and Firefox, same results.