05-22-2022 09:07 PM - last edited on 05-24-2022 02:34 AM by Translator
I need a static route to be able to ping Loopback0 on R2 from R1. I do not want a default route but something more specific pointting to the loopback address or subnet. I want to save the default route for something else. I dont wan't this by injecting OSPF into R2. I am asking if theres a possibility to reach Loopback0 from R1 using static routes that are not default
R1
R1 Config
Current configuration : 1446 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 64.100.10.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.0.1.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 10.2.0.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
area 2 stub no-summary
network 10.0.1.0 0.0.0.255 area 0
network 10.2.0.0 0.0.0.255 area 2
default-information originate always
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
banner motd ^C This is R1, Trouble Ticket 8.1.2.1 ^C
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
R2 Config
Current configuration : 1386 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 10.2.1.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 10.2.0.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 10.2.0.0 0.0.0.255 area 2
network 10.2.1.0 0.0.0.255 area 2
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.2.0.1
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
Solved! Go to Solution.
05-23-2022 05:39 AM - last edited on 05-24-2022 02:49 AM by Translator
Hello,
the most 'restrictive' static route would be a host route on R1:
R1
ip route 10.2.1.1 255.255.255.255 10.2.0.1
05-22-2022 11:40 PM - last edited on 05-24-2022 02:49 AM by Translator
Hello
R2
router ospf 1
no network 10.2.1.0 0.0.0.255 area 2
R1
ip route 10.2.1.0 255.255.255.0 fa0/1 10.2.0.2
05-23-2022 05:39 AM - last edited on 05-24-2022 02:49 AM by Translator
Hello,
the most 'restrictive' static route would be a host route on R1:
R1
ip route 10.2.1.1 255.255.255.255 10.2.0.1
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide