02-07-2023 11:36 AM - last edited on 02-08-2023 09:43 PM by Translator
Hi,
New to the community, read a lot of posts for help in the past but I'm now really stuck with this one.
I have a homelab which I am starting out to gain more knowledge. I have set it all up but I cannot get internet connectivity to the laptop on the network. I have this coming off a
BT hub -> Cisco 1841 Router -> Cisco 2960 Switch -> Laptop.
I can ping the BT hub in cli and I can ping the laptop in the cli as it's been allocated an IP address of 192.168.10.11.
But for some reason I cannot get it to access the internet.
Below is the configuration on the router, I have spent hours searching the internet but I cannot see what I am doing wrong to bridge that gap from the internet coming into fe0/0 and the Lan going out of fe0/1.
Any help would be greatly appreciated.
hostname R1
!
boot-start-marker
boot-end-marker
!
!
card type t1 0 0
card type t1 0 1
enable secret XXXXXXX
enable password XXXXXXX
!
no aaa new-model
ip source-route
!
!
!
ip dhcp excluded-address 192.168.10.1 192.168.10.9
!
ip dhcp pool internalh
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 8.8.8.8
domain-name myxx.com
lease 3
!
!
ip cef
multilink bundle-name authenticated
!
!
license udi pid CISCOxx sn FHKxxx
!
!
controller T1 0/0/0
cablelength short 110
channel-group 1 timeslots 1-24
!
controller T1 0/1/0
cablelength long 0db
!
!
!
!
!
interface FastEthernet0/0
description incoming connection
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface FastEthernet0/1
description Connected to S1
ip address 192.168.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Serial0/0/0:1
no ip address
!
ip default-gateway 192.168.10.1
ip forward-protocol nd
!
!
no ip http server
ip nat inside source list 1 interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 dhcp
!
access-list 1 permit 192.168.0.0 0.0.0.255
!
!
control-plane
Solved! Go to Solution.
02-08-2023 06:20 AM - last edited on 02-08-2023 09:44 PM by Translator
Hello,
make the changes marked in bold:
hostname R1
!
boot-start-marker
boot-end-marker
!
card type t1 0 0
card type t1 0 1
enable secret XXXXXXX
enable password XXXXXXX
!
no aaa new-model
ip source-route
!
ip dhcp excluded-address 192.168.10.1 192.168.10.9
!
ip dhcp pool internalh
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 8.8.8.8
domain-name myxx.com
lease 3
!
ip cef
multilink bundle-name authenticated
!
license udi pid CISCOxx sn FHKxxx
!
controller T1 0/0/0
cablelength short 110
channel-group 1 timeslots 1-24
!
controller T1 0/1/0
cablelength long 0db
!
interface FastEthernet0/0
description incoming connection
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface FastEthernet0/1
description Connected to S1
ip address 192.168.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Serial0/0/0:1
no ip address
!
--> no ip default-gateway 192.168.10.1
ip forward-protocol nd
!
no ip http server
ip nat inside source list 1 interface FastEthernet0/0 overload
--> ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
--> access-list 1 permit 192.168.10.0 0.0.0.255
!
control-plane
02-08-2023 10:22 AM - last edited on 02-08-2023 09:48 PM by Translator
I agree that the major issue was the mistake in acl 1 and the revised version of acl 1 should solve the problem. Having
ip default-gateway
in the config does not create a problem, but it is not used (since ip routing is enabled) and removing the statement is good housekeeping. I do not like the suggestion to change the default route from dhcp to fastethernet0/0. For one thing it forces the router to arp for every remote destination and requires that the upstream device to support proxy arp (and some providers do not support it because of the security implications). And even if it does work it forces the router to work harder than it would if the default route specified dhcp. Perhaps a compromise might use
ip route 0.0.0.0 0.0.0.0 fastethernet0/0 dhcp?
02-08-2023 06:20 AM - last edited on 02-08-2023 09:44 PM by Translator
Hello,
make the changes marked in bold:
hostname R1
!
boot-start-marker
boot-end-marker
!
card type t1 0 0
card type t1 0 1
enable secret XXXXXXX
enable password XXXXXXX
!
no aaa new-model
ip source-route
!
ip dhcp excluded-address 192.168.10.1 192.168.10.9
!
ip dhcp pool internalh
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 8.8.8.8
domain-name myxx.com
lease 3
!
ip cef
multilink bundle-name authenticated
!
license udi pid CISCOxx sn FHKxxx
!
controller T1 0/0/0
cablelength short 110
channel-group 1 timeslots 1-24
!
controller T1 0/1/0
cablelength long 0db
!
interface FastEthernet0/0
description incoming connection
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface FastEthernet0/1
description Connected to S1
ip address 192.168.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Serial0/0/0:1
no ip address
!
--> no ip default-gateway 192.168.10.1
ip forward-protocol nd
!
no ip http server
ip nat inside source list 1 interface FastEthernet0/0 overload
--> ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
--> access-list 1 permit 192.168.10.0 0.0.0.255
!
control-plane
02-08-2023 10:22 AM - last edited on 02-08-2023 09:48 PM by Translator
I agree that the major issue was the mistake in acl 1 and the revised version of acl 1 should solve the problem. Having
ip default-gateway
in the config does not create a problem, but it is not used (since ip routing is enabled) and removing the statement is good housekeeping. I do not like the suggestion to change the default route from dhcp to fastethernet0/0. For one thing it forces the router to arp for every remote destination and requires that the upstream device to support proxy arp (and some providers do not support it because of the security implications). And even if it does work it forces the router to work harder than it would if the default route specified dhcp. Perhaps a compromise might use
ip route 0.0.0.0 0.0.0.0 fastethernet0/0 dhcp?
02-08-2023 12:06 PM
I made the adjustments but still didn't come online, but when I added the dhcp on the end of ip route it then bridged the internet connection.
Thank you very much both for your help.
02-09-2023 06:28 AM
You are welcome. I am glad that our suggestions have been helpful. Thank you for marking this question as solved. This will help other participants in the community to identify discussions which have helpful information. This community is an excellent place to ask questions and to learn about networking. I hope to see you continue to be active in the community.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide