cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2288
Views
0
Helpful
4
Replies

internet failover sample configuration

godwinagaba
Level 1
Level 1

Hi Guys,

I need help on a sample configuration for internet failover . i  have 2 ISPs with one coming in thought a serial cable and another thorugh internet and would wish one take over after the other has failed .The router is Cisco 1921 .

1 Accepted Solution

Accepted Solutions

cadet alain
VIP Alumni
VIP Alumni

Hi,

I suppose you're natting traffic so first you must do this for NAT:

1) create 2 route-maps

route-map SERIAL

match ip add 1

match interface serialx/x

route-map DSL

match ip address 1

match interface dialerx


2) create the ACL 1

   access-list 1 permit x.x.x.x y.y.y.y  where x.x.x.x is the subnet you want to be natted and y.y.y.y is wildcard mask

3) create 2 dynamic nat entries

ip nat inside source route-map SERIAL interface serialx/x overload

ip nat inside source route-map DSL interface dialerx overload

Now for failover you must use reliable static default route with ip sla:

1) create the ip sla action

ip sla 1

  icmp-echo x.x.x.x.x where x.x.x.x is the next-hop on serial link

  timeout xxx    how many time without a response so ip sla fails and tracked object is down

  frequency xxx  how often you send the ping

  exit

ip sla schedule 1 start-time now life forever  start the ip sla action

2) create the tracking object:

track 1 rtr 1 reachability

3) create 2 default routes, the backup one has an AD higher than primary and you gonna track the primary

I suppose primary is Serial:

ip route 0.0.0.0 0.0.0.0 serialx/x track 1

ip route 0.0.0.0 0.0.0.0 dialer x 100

Regards.

Alain.

Don't forget to rate helpful posts.

View solution in original post

4 Replies 4

cadet alain
VIP Alumni
VIP Alumni

Hi,

I suppose you're natting traffic so first you must do this for NAT:

1) create 2 route-maps

route-map SERIAL

match ip add 1

match interface serialx/x

route-map DSL

match ip address 1

match interface dialerx


2) create the ACL 1

   access-list 1 permit x.x.x.x y.y.y.y  where x.x.x.x is the subnet you want to be natted and y.y.y.y is wildcard mask

3) create 2 dynamic nat entries

ip nat inside source route-map SERIAL interface serialx/x overload

ip nat inside source route-map DSL interface dialerx overload

Now for failover you must use reliable static default route with ip sla:

1) create the ip sla action

ip sla 1

  icmp-echo x.x.x.x.x where x.x.x.x is the next-hop on serial link

  timeout xxx    how many time without a response so ip sla fails and tracked object is down

  frequency xxx  how often you send the ping

  exit

ip sla schedule 1 start-time now life forever  start the ip sla action

2) create the tracking object:

track 1 rtr 1 reachability

3) create 2 default routes, the backup one has an AD higher than primary and you gonna track the primary

I suppose primary is Serial:

ip route 0.0.0.0 0.0.0.0 serialx/x track 1

ip route 0.0.0.0 0.0.0.0 dialer x 100

Regards.

Alain.

Don't forget to rate helpful posts.

godwinagaba
Level 1
Level 1

Thanks

cadet alain

I will use the config and let you know . i believe it will work.

Hi Alain,

Is the time below in Mili seconds ?

timeout  xxx    how many time without a response so ip sla fails and tracked object is down

frequency xxx  how often you send the ping

Thanks

Hi,

I never remember the units but a question mark will tell you.

Regards.

Alain.

Don't forget to rate helpful posts.
Review Cisco Networking for a $25 gift card