cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
174
Views
0
Helpful
1
Replies
Highlighted
Beginner

IOS-XR EIGRP to BGP redistribution doesn't work

Hi all

i'm trying to redistribute routes within vrf from eigrp to bgp but I failed

 

RP/0/RP0/CPU0:api-lab-xrv4#sh ip route vrf SZ6
Wed Jun 10 22:41:41.085 UTC

Codes: C - connected, S - static, R - RIP, B - BGP, (>) - Diversion path
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - ISIS, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, su - IS-IS summary null, * - candidate default
U - per-user static route, o - ODR, L - local, G - DAGR, l - LISP
A - access/subscriber, a - Application route
M - mobile route, r - RPL, t - Traffic Engineering, (!) - FRR Backup path

Gateway of last resort is not set

C 10.5.41.0/24 is directly connected, 04:52:42, GigabitEthernet0/0/0/5.41
L 10.5.41.4/32 is directly connected, 04:52:42, GigabitEthernet0/0/0/5.41
C 10.254.2.0/24 is directly connected, 04:53:13, Loopback61
L 10.254.2.1/32 is directly connected, 04:53:13, Loopback61
D EX 10.254.11.0/24 [201/2570240] via 10.5.41.1, 00:28:53, GigabitEthernet0/0/0/5.41 <- i want to redistribute this one
B 10.254.66.0/24 [200/0] via 10.0.0.3 (nexthop in vrf default), 04:51:54

 

RP/0/RP0/CPU0:api-lab-xrv4#sh run router bgp 65000 vrf SZ6
Wed Jun 10 22:42:01.967 UTC
router bgp 65000
vrf SZ6
rd 10.0.0.4:60
address-family ipv4 unicast
redistribute connected route-policy pass_all
redistribute eigrp EDGE route-policy eigrp_to_bgp
!
!
!

route-policy eigrp_to_bgp
if destination in (10.254.11.0/24) then
set community (65000:20290)
endif
end-policy
!

router bgp and route-policy seem to be configured properly

 

RP/0/RP0/CPU0:api-lab-xrv4#show ip bgp vrf SZ6

*> 10.5.41.0/24 0.0.0.0 0 32768 ?
* i                      10.0.0.3 0 100 0 ?
*> 10.254.2.0/24 0.0.0.0 0 32768 ?
*>i10.254.66.0/24 10.0.0.3 0 100 0 ?

 

but no records in bgp table

 

RP/0/RP0/CPU0:api-lab-xrv4#sh ip route vrf SZ6 10.254.11.0/24
Wed Jun 10 22:45:55.802 UTC

Routing entry for 10.254.11.0/24
Known via "eigrp 10", distance 201, metric 2570240, type external
Installed Jun 10 22:12:47.989 for 00:33:08
Routing Descriptor Blocks
10.5.41.1, from 10.5.41.1, via GigabitEthernet0/0/0/5.41
Route metric is 2570240
No advertising protos. <- it isn't redistributed

 

I ran bgp debug, i saw connected redistributin process, but no eigrp. I'll appreciate any help

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

Solved!!!

Problem was in eigrp process name.

Originnaly i've named router eigrp as "EDGE" 

 

router eigrp EDGE   <-!!!!!!!!!!!!!!!!!!!!!!!!!
address-family ipv4
distance 90 201
!
vrf SZ6
address-family ipv4
distance 90 201
autonomous-system 10
redistribute bgp 65000 route-policy bgp_to_eigrp
interface GigabitEthernet0/0/0/5.41

So i decided i have to use this name. But in output of "show ip route" i suddenly see eigrp 10

 

RP/0/RP0/CPU0:api-lab-xrv4#sh ip route vrf SZ6 10.254.11.0/24
Wed Jun 10 22:45:55.802 UTC

Routing entry for 10.254.11.0/24
Known via "eigrp 10", distance 201, metric 2570240, type external <- I didn't pay attention to it
Installed Jun 10 22:12:47.989 for 00:33:08
Routing Descriptor Blocks
10.5.41.1, from 10.5.41.1, via GigabitEthernet0/0/0/5.41
Route metric is 2570240
No advertising protos.

 

Now I've changed name of eigrp in redistribute command and everithig is ok now.

 

RP/0/RP0/CPU0:api-lab-xrv4#sh run router bgp 65000 vrf SZ6
Thu Jun 11 11:36:59.203 UTC
router bgp 65000
vrf SZ6
rd 10.0.0.4:60
address-family ipv4 unicast
redistribute connected route-policy pass_all
redistribute eigrp 10 route-policy eigrp_to_bgp

=============================================

RP/0/RP0/CPU0:api-lab-xrv4#sh ip bgp vrf SZ6
Route Distinguisher: 10.0.0.4:60 (default for vrf SZ6)
*> 10.5.41.0/24 0.0.0.0 0 32768 ?
* i                        10.0.0.3 0 100 0 ?
*> 10.254.2.0/24 0.0.0.0 0 32768 ?
*> 10.254.11.0/24 10.5.41.1 2570240 32000 ? <- so it is here now
*>i10.254.66.0/24 10.0.0.3 0 100 0 ?

 

Hope this help someone.

View solution in original post

1 REPLY 1
Highlighted
Beginner

Solved!!!

Problem was in eigrp process name.

Originnaly i've named router eigrp as "EDGE" 

 

router eigrp EDGE   <-!!!!!!!!!!!!!!!!!!!!!!!!!
address-family ipv4
distance 90 201
!
vrf SZ6
address-family ipv4
distance 90 201
autonomous-system 10
redistribute bgp 65000 route-policy bgp_to_eigrp
interface GigabitEthernet0/0/0/5.41

So i decided i have to use this name. But in output of "show ip route" i suddenly see eigrp 10

 

RP/0/RP0/CPU0:api-lab-xrv4#sh ip route vrf SZ6 10.254.11.0/24
Wed Jun 10 22:45:55.802 UTC

Routing entry for 10.254.11.0/24
Known via "eigrp 10", distance 201, metric 2570240, type external <- I didn't pay attention to it
Installed Jun 10 22:12:47.989 for 00:33:08
Routing Descriptor Blocks
10.5.41.1, from 10.5.41.1, via GigabitEthernet0/0/0/5.41
Route metric is 2570240
No advertising protos.

 

Now I've changed name of eigrp in redistribute command and everithig is ok now.

 

RP/0/RP0/CPU0:api-lab-xrv4#sh run router bgp 65000 vrf SZ6
Thu Jun 11 11:36:59.203 UTC
router bgp 65000
vrf SZ6
rd 10.0.0.4:60
address-family ipv4 unicast
redistribute connected route-policy pass_all
redistribute eigrp 10 route-policy eigrp_to_bgp

=============================================

RP/0/RP0/CPU0:api-lab-xrv4#sh ip bgp vrf SZ6
Route Distinguisher: 10.0.0.4:60 (default for vrf SZ6)
*> 10.5.41.0/24 0.0.0.0 0 32768 ?
* i                        10.0.0.3 0 100 0 ?
*> 10.254.2.0/24 0.0.0.0 0 32768 ?
*> 10.254.11.0/24 10.5.41.1 2570240 32000 ? <- so it is here now
*>i10.254.66.0/24 10.0.0.3 0 100 0 ?

 

Hope this help someone.

View solution in original post