02-18-2019 07:50 AM - edited 02-20-2019 02:17 PM
Hi Guys,
Scenerio is
(XRv) (C7200 - virtual) (XRv)
R1----------R2------------------R3
I'm testing L3VPN in EVE-NG.
I've created a very simple topology and configuration, MPLS, OSPF and BGP is working normally, but when I'm trying to redistribute connected or ospf 2 route-s to my vrf (hanssolo), I can't see the redistributed routes (neither OSPF, neither connected) in vrf routing table.
Do you have an idea or solution for this problem?
Is my configuration ok or I missed something? Or some XRv bug?
Config:
hostname R1
logging console debugging
vrf hanssolo
address-family ipv4 unicast
import route-target
1:4
!
export route-target
1:4
!
!
!
alias exec wrnet copy run harddisk:running-config
interface Loopback0
ipv4 address 1.1.1.1 255.255.255.255
!
interface MgmtEth0/0/CPU0/0
shutdown
!
interface GigabitEthernet0/0/0/0
description R2_fele
ipv4 address 10.0.0.1 255.255.255.0
!
interface GigabitEthernet0/0/0/1
description R4_fele
vrf hanssolo
ipv4 address 192.168.1.1 255.255.255.0
!
interface GigabitEthernet0/0/0/2
shutdown
!
router ospf 1
router-id 1.1.1.1
area 0
mpls ldp auto-config
interface Loopback0
passive disable
!
interface GigabitEthernet0/0/0/0
passive disable
!
!
!
router ospf 2
router-id 1.1.1.1
vrf hanssolo
redistribute bgp 1
area 2
interface GigabitEthernet0/0/0/1
passive disable
!
!
!
!
router bgp 1
address-family ipv4 unicast
!
address-family vpnv4 unicast
!
neighbor 3.3.3.3
remote-as 1
update-source Loopback0
address-family ipv4 unicast
!
!
vrf hanssolo
rd 1:4
address-family ipv4 unicast
redistribute connected
!
!
!
mpls ldp
!
end
---------------------------------
---------------------------------
hostname R3
domain lookup disable
vrf hanssolo
address-family ipv4 unicast
import route-target
1:4
!
export route-target
1:4
!
!
!
alias exec wrnet copy run harddisk:running-config
interface Loopback0
ipv4 address 3.3.3.3 255.255.255.255
!
interface Loopback100
description teszt
ipv4 address 172.16.1.1 255.255.255.0
!
interface MgmtEth0/0/CPU0/0
shutdown
!
interface GigabitEthernet0/0/0/0
ipv4 address 10.0.1.3 255.255.255.0
!
interface GigabitEthernet0/0/0/1
description R6_fele
vrf hanssolo
ipv4 address 192.168.2.3 255.255.255.0
!
interface GigabitEthernet0/0/0/2
shutdown
!
router ospf 1
router-id 3.3.3.3
area 0
mpls ldp auto-config
interface Loopback0
passive disable
!
interface GigabitEthernet0/0/0/0
passive disable
!
!
!
router ospf 2
router-id 3.3.3.3
vrf hanssolo
redistribute bgp 1
area 2
interface GigabitEthernet0/0/0/1
passive disable
!
!
!
!
router bgp 1
address-family ipv4 unicast
!
address-family vpnv4 unicast
!
neighbor 1.1.1.1
remote-as 1
update-source Loopback0
address-family ipv4 unicast
!
!
vrf hanssolo
rd 1:4
address-family ipv4 unicast
redistribute connected
!
!
!
mpls ldp
!
end
Thank you!
02-18-2019 07:58 AM
I wonder about having both OSPF processes use the same router ID. I would suggest making each router ID unique. Also I suggest under router ospf add to the redistribute command the parameter subnets.
HTH
Rick
02-20-2019 02:07 PM
Hi Rick,
Thanks for your answer. I made some change in configuration, for example R1:
router bgp 1
address-family ipv4 unicast
!
address-family vpnv4 unicast
!
neighbor 3.3.3.3
remote-as 1
update-source Loopback0
address-family ipv4 unicast
!
!
vrf hanssolo
rd 1:4
address-family ipv4 unicast
redistribute ospf 2
!
!
router ospf 2
vrf hanssolo
router-id 192.168.1.1
redistribute bgp 1
area 0
interface GigabitEthernet0/0/0/1
passive disable
R3 config is similar, but situation is not mutch better. I dont understand exactly what did you mean 'redistribute command the parameter subnets', because in XRv there aren't network command in ospf process (i can just change network type).
ps. Just for testing, I made this configuration with IOS and IOS-XE, and here redistributing working perfectly. So I think, I've missed someting from bgp or ospf configuration on XRv, or there are some kind of bug, and the redistribution will not work anyway.
Best regards,
neo
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide