cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
340
Views
0
Helpful
3
Replies
sir_ulrick
Beginner

It is possible to repeat source ip in GRE tunnel?

Hi everybody, 

I have a question about GRE tunnels. I have the follow topology connected using dinamic routing (whichever)

and I would like create a GRE tunnel between each router (must be point to point GRE tunnel, to avoid different problems with the topology, I can't use DMVPN) so I need define a GRE tunnel between router 0 -> router 1, router 0 -> router 2, router 0 -> router 3, router 1 -> router 2, .... etc.  My question is, can I use same ip to define tunnel betwen different interfaces? I mean, GRE tunnel between router 0 -> 1 will have ip 1.1.1.1 (router 0) and 1.1.1.2 (router1). Can I define same ip between router 0 and router 3 or it's necessary to add new ip?

 


Captura.PNG

Tunnel between router 0 and router 1:

interface tunnel 5
tunnel mode gre ip
ip address 1.1.1.1 255.255.255.0
ip mtu 1400 
tunnel source gi0/0/0 // 10.10.10.1
tunnel destination 10.10.10.2

 

Tunnel between router 0 and router 3:

interface tunnel 6
tunnel mode gre ip
ip address 1.1.1.1
ip mtu 1400
tunnel source gi0/1/0
tunnel destination 10.10.20.2
 
I thought to use loopback interface as source address, but I read that doing this causes routing problems
1 ACCEPTED SOLUTION

Accepted Solutions
Giuseppe Larosa
Hall of Fame Master

Hello @sir_ulrick ,

you can have multiple tunnels using the same source interface.

You can multiplex / demultiplex using the command tunnel key <number>

 

However, the IP address assigned to the GRE Tunnel must be different in each tunnel (the internal address). Each p2p GRE tunnel will need a different IP subnet for internal addresses.

 

Hope to help

Giuseppe

 

View solution in original post

3 REPLIES 3
Giuseppe Larosa
Hall of Fame Master

Hello @sir_ulrick ,

you can have multiple tunnels using the same source interface.

You can multiplex / demultiplex using the command tunnel key <number>

 

However, the IP address assigned to the GRE Tunnel must be different in each tunnel (the internal address). Each p2p GRE tunnel will need a different IP subnet for internal addresses.

 

Hope to help

Giuseppe

 

View solution in original post

Thanks a lot for your reply Giuseppe Larosa! I think that tunnel key it's what I need!!

BTW, on some platforms (like 6500s I recall), reusing the same source-IP inhibits performance.