12-25-2019 11:39 PM
Hi CsicoCommunity
I’ve been tasked to provide Laptop with internet connectivity via x4 cascaded routers.
I can use only static IP address and Static IP routes. For simulation I will use Cisco IOSv routers in GNS3
Graphical picture is added:
ISP Modem
|
R1
|
R2
|
R3
|
R4
|
Connected Laptop
Broadband modem with
IP: 87.110.156.22 MASK 255.255.252.0
Default GATEWAY: 87.110.156.1
DNS: 8.8.8.8
NAT: Masquerade
Local IP: 192.168.100.1 MASK 255.255.255.0
route add 192.168.100.0 MASK 255.255.252.0 192.168.100.254
I guess I am asking community advice on which routing technology should I use to solve this.
Should I use L2TPv3 tunnel between inside routers and NAT translation?. I will appreciate any comments.
Solved! Go to Solution.
12-26-2019 01:06 AM
Hello,
if what you want to accomplish is provide Internet connectivity for your laptop, all you need to do is add the network of the laptop to the access list used for NAT, on the top router (the one directly connected to the ISP modem...
12-26-2019 01:36 AM - edited 12-26-2019 01:38 AM
Hello
You could just use a simple dynamic routing protocol such as RIPv2 to connect the 4 routers and append a simple Dynamic PAT on router 1
Example:
Rtr1
int gig0/1
description Modem
ip address 87.110.156.22 255.255.252.0
ip nat outside
int gig0/0
description rtr2
ip address 10.1.12.1 255.255.255.252
ip nat inside
router rip
ver2
no auto
network 10.0.0.0
default-information originate
access-list 1 permit 192.168.1.0 0.0.0.255
ip nat inside source list 1 interface gig0/1
ip route 0.0.0.0 0.0.0.0 gig0/1 87.110.156.1
rtr2
int gig0/0
description rtr1
ip address 10.1.12.2 255.255.255.252
int gig0/1
description rtr3
ip address 10.1.23.1 255.255.255.252
router rip
ver2
no auto
network 10.0.0.0
rtr3
int gig0/0
description rtr2
ip address 10.1.23.2 255.255.255.252
int gig0/1
description rtr4
ip address 10.1.34.1 255.255.255.252
router rip
ver2
no auto
network 10.0.0.0
rtr4
int gig0/0
description rtr3
ip address 10.1.34.2 255.255.255.252
int gig0/1
description LAN
ip address 192.168.1.254 255.255.255.0
router rip
ver2
no auto
network 10.0.0.0
network 192.168.1.0
ip dhcp pool LAN
network 192.168.1.0 255.255.255.0
default-router 192.168.1.254
dns-server 8.8.8.8 8.8.8.4
lease 0 8
12-26-2019 01:06 AM
Hello,
if what you want to accomplish is provide Internet connectivity for your laptop, all you need to do is add the network of the laptop to the access list used for NAT, on the top router (the one directly connected to the ISP modem...
12-26-2019 01:36 AM - edited 12-26-2019 01:38 AM
Hello
You could just use a simple dynamic routing protocol such as RIPv2 to connect the 4 routers and append a simple Dynamic PAT on router 1
Example:
Rtr1
int gig0/1
description Modem
ip address 87.110.156.22 255.255.252.0
ip nat outside
int gig0/0
description rtr2
ip address 10.1.12.1 255.255.255.252
ip nat inside
router rip
ver2
no auto
network 10.0.0.0
default-information originate
access-list 1 permit 192.168.1.0 0.0.0.255
ip nat inside source list 1 interface gig0/1
ip route 0.0.0.0 0.0.0.0 gig0/1 87.110.156.1
rtr2
int gig0/0
description rtr1
ip address 10.1.12.2 255.255.255.252
int gig0/1
description rtr3
ip address 10.1.23.1 255.255.255.252
router rip
ver2
no auto
network 10.0.0.0
rtr3
int gig0/0
description rtr2
ip address 10.1.23.2 255.255.255.252
int gig0/1
description rtr4
ip address 10.1.34.1 255.255.255.252
router rip
ver2
no auto
network 10.0.0.0
rtr4
int gig0/0
description rtr3
ip address 10.1.34.2 255.255.255.252
int gig0/1
description LAN
ip address 192.168.1.254 255.255.255.0
router rip
ver2
no auto
network 10.0.0.0
network 192.168.1.0
ip dhcp pool LAN
network 192.168.1.0 255.255.255.0
default-router 192.168.1.254
dns-server 8.8.8.8 8.8.8.4
lease 0 8
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide