cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
297
Views
0
Helpful
1
Replies

Load balancing and redundancy problem

nelsonlin
Level 1
Level 1

I've implemented load balancing for a router with two ADSL links. One fix ip and one dynamic ip. The related configuration is like this:

####################################################

interface ATM0/0/0

no ip address

no ip route-cache

no ip mroute-cache

no atm ilmi-keepalive

dsl operating-mode auto

pvc 1/33

encapsulation aal5snap

pppoe-client dial-pool-number 1

!

!

interface ATM0/1/0

ip address A.B.C.D 255.255.255.252 secondary

ip address D.E.F.G 255.255.255.252

ip nat outside

no ip route-cache

no ip mroute-cache

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/35

protocol ip A.B.C.k

encapsulation aal5snap

!

!

interface Dialer0

ip address negotiated

ip mtu 1452

ip nat outside

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp pap sent-username testUser password testPassword

!

ip classless

ip route 0.0.0.0 0.0.0.0 A.B.C.k

ip route 0.0.0.0 0.0.0.0 Dialer0

ip nat inside source route-map BusinessBB interface ATM0/1/0 overload

ip nat inside source route-map DynamicBB interface Dialer0 overload

route-map BusinessBB permit 10

match ip address 100

match interface ATM0/1/0

!

route-map DynamicBB permit 10

match ip address 100

match interface Dialer0

####################################################

The load balancing is alright now. However, the load balancing still works when the dynamic link is down, causing the loss of some packets. The loss is due to the Dialer interface's forever "up up" status.

The IOS of the router is only IPBase.

Any body can tell me the solution of this problem?

1 Reply 1

rais.ahmad
Level 1
Level 1

When you negotiate an IP with the remote, is it possible to point the default route to something on the remote network?

We can also run dynamic routing, learn a default route and set perferences for the two default route to the same value.

Hope this helps.

Review Cisco Networking for a $25 gift card