cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
867
Views
5
Helpful
6
Replies
Robert_Gorajski
Beginner

Manual reservation of one IP address on the DHCP server - does not work

Hello

 

My goal is to reserve an IP address for one host. Unfortunately it doesn't work. After setting up an IP reservation:

 

KRGR#clear ip dhcp binding *
KRGR#show ip dhcp binding
Bindings from all pools not associated with VRF:
IP address      Client-ID/              Lease expiration        Type       State      Interface
                Hardware address/
                User name
10.100.102.239  4491.602b.f6c5          Infinite                Manual     Selecting  Unknown

Then I physically shut down the host whose IP address is to be reserved and turned it back on.

KRGR#show ip dhcp binding
Bindings from all pools not associated with VRF:
IP address      Client-ID/              Lease expiration        Type       State      Interface
                Hardware address/
                User name
10.100.102.7    4491.602b.f6c5          Jul 23 2021 08:16 PM    Automatic  Active     Vlan102
10.100.102.239  4491.602b.f6c5          Infinite                Manual     Selecting  Unknown

What am I doing wrong ? Of course, Ping answers 10.100.102.7

Thanks in advance for any help.

 

Below is my entire configuration on C1111-8P

 

KRGR#show configuration
Using 3868 out of 33554432 bytes
!
! Last configuration change at 19:56:36 CEST Fri Jul 16 2021 by frampt
! NVRAM config last updated at 20:17:52 CEST Fri Jul 16 2021 by frampt
!
version 16.9
service timestamps debug datetime msec
service timestamps log datetime msec
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname KRGR
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone CEST 2 0
!
ip name-server 1.1.1.1 1.0.0.1
ip domain name robert.name
ip dhcp excluded-address 10.100.100.101 10.100.100.254
ip dhcp excluded-address 10.100.101.101 10.100.101.254
ip dhcp excluded-address 10.100.102.240
ip dhcp excluded-address 10.100.102.254
!
ip dhcp pool vlan1_dhcp_pool
 network 10.100.100.0 255.255.255.0
 default-router 10.100.100.254
 dns-server 10.100.100.254
 lease 7
!
ip dhcp pool vlan101_dhcp_pool
 network 10.100.101.0 255.255.255.0
 default-router 10.100.101.254
 dns-server 10.100.101.254
 lease 7
!
ip dhcp pool vlan102_dhcp_pool
 network 10.100.102.0 255.255.255.0
 default-router 10.100.102.254
 dns-server 10.100.102.254
 lease 7
!
ip dhcp pool ikea
 host 10.100.102.239 255.255.255.0
 client-identifier 4491.602b.f6c5
 client-name ikea_hub
!
!
!
login on-success log
!
!
!
!
!
!
!
subscriber templating
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
crypto pki trustpoint TP-self-signed-2831065596
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2831065596
 revocation-check none
 rsakeypair TP-self-signed-2831065596
!
!
crypto pki certificate chain TP-self-signed-2831065596
 certificate self-signed 01 nvram:IOS-Self-Sig#9.cer
!
license udi pid C1111-8P sn XXX
license boot level securityk9_npe
no license smart enable
!
diagnostic bootup level minimal
!
spanning-tree extend system-id
!
!
username XXX privilege 15 secret 9 XXX
!
redundancy
 mode none
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0/0
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet0/0/1
 description internet
 no ip address
 speed 1000
 no negotiation auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface GigabitEthernet0/1/0
 description robert_pc
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet0/1/1
 description sw_multimedia
 switchport access vlan 101
 speed 1000
 duplex full
!
interface GigabitEthernet0/1/2
 description sw_iot
 switchport access vlan 102
 speed 1000
 duplex full
!
interface GigabitEthernet0/1/3
!
interface GigabitEthernet0/1/4
!
interface GigabitEthernet0/1/5
!
interface GigabitEthernet0/1/6
!
interface GigabitEthernet0/1/7
!
interface Vlan1
 ip address 10.100.100.254 255.255.255.0
 ip nat inside
 ip tcp adjust-mss 1452
!
interface Vlan101
 ip address 10.100.101.254 255.255.255.0
 ip nat inside
 ip tcp adjust-mss 1452
!
interface Vlan102
 ip address 10.100.102.254 255.255.255.0
 ip nat inside
 ip tcp adjust-mss 1452
!
interface Dialer1
 description matrix
 mtu 1480
 ip address negotiated
 ip nat outside
 encapsulation ppp
 ip tcp adjust-mss 1400
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication pap chap ms-chap ms-chap-v2 callin
 ppp pap sent-username XXX password 0 XXX
 ppp ipcp route default
!
ip forward-protocol nd
no ip http server
ip http authentication local
no ip http secure-server
ip dns server
ip nat inside source list 101 interface Dialer1 overload
ip ssh version 2
!
!
ip access-list extended 101
 deny   tcp any any eq 22
 permit ip 10.100.100.0 0.0.0.255 any
 permit ip 10.100.101.0 0.0.0.255 any
 permit ip 10.100.102.0 0.0.0.255 any
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 60 0
 login local
 transport input none
 stopbits 1
line vty 0 5
 login local
 transport input ssh
!
ntp server tempus1.gum.gov.pl
!
!
!
!
!
end

KRGR#

 

 

6 REPLIES 6
paul driver
VIP Mentor

Hello

Try changing the client id to include 01
client-identifier 0144.9160.2bf6.c5

on a side note -
int giig0/0/1
ip tcp adjust-mss 1452

Int dialer 1
ip mtu 1492

ip route 0.0.0.0 0.0.0.0 dialer 1



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Georg Pauwen
VIP Expert

Hello,

 

I think the syntax is wrong. Try:

 

--> ip dhcp excluded-address 10.100.102.239

!

ip dhcp pool ikea
host 10.100.102.239 255.255.255.0
--> hardware-address 4491.602b.f6c5
client-name ikea_hub

Robert_Gorajski
Beginner

Thank you @Georg Pauwen "hardware-address 4491.602b.f6c5"- it's OK. 

 

However, I wanted to configure further to the default situation. I disconnected the IKEA device from the LAN port and turned on the unmanaged TP-Link switch in its place. I turned on IKEA in the TP-Link switch. Everything is OK in this configuration. Unfortunately, I connected a second device to TP-Link to the second LAN port. I configured the DHCP pool in the same way. Unfortunately, the second device does not get the correct IP, only the first free one from the DHCP server pool.

 

Part of my configuration after the changes:

 

!
ip dhcp pool ikea
 host 10.100.102.239 255.255.255.0
 hardware-address 4491.602b.f6c5
 client-name ikea_hub
!
ip dhcp pool smart_home_controller
 host 10.100.102.240 255.255.255.0
 hardware-address 01dc.a632.0451.8a
 client-name homeassistant_openhab
!
!
interface GigabitEthernet0/1/2
 description sw_iot
 switchport access vlan 102
 switchport mode access
 speed 1000
 duplex full
!
  
Bindings from all pools not associated with VRF:
IP address      Client-ID/              Lease expiration        Type       State      Interface
                Hardware address/
                User name
10.100.100.2    01fe.c37c.4546.18       Jul 24 2021 02:19 PM    Automatic  Active     Vlan1
10.100.100.3    01ce.5722.ac81.37       Jul 24 2021 02:22 PM    Automatic  Active     Vlan1
10.100.102.8    01dc.a632.0451.8a       Jul 24 2021 01:04 PM    Automatic  Active     Vlan102
10.100.102.11   01a6.fe78.aa8a.d2       Jul 24 2021 02:17 PM    Automatic  Active     Vlan102
10.100.102.12   b4e6.2dd2.7cc5          Jul 24 2021 02:22 PM    Automatic  Active     Vlan102
10.100.102.13   0100.11f6.f4c3.71       Jul 24 2021 03:15 PM    Automatic  Active     Vlan102
10.100.102.239  4491.602b.f6c5          Infinite                Manual     Active     Vlan102
10.100.102.240  01dc.a632.0451.8a       Infinite                Manual     Selecting  Unknown

What could be causing this situation? I tried the MAC address as above and deleted the first 01 - nothing changed - still not OK

 

Thanks in advance for further suggestions

 

Hello Robert,

 

looks like the second pool has the wrong syntax as well. Make sure it looks like below:

 

ip dhcp pool smart_home_controller
host 10.100.102.240 255.255.255.0
hardware-address dca6.3204.518a
client-name homeassistant_openhab

Robert_Gorajski
Beginner

Hello Georg

 

As I wrote above, I tried both entries, both:

 

hardware-address dca6.3204.518a

and

hardware-address 01dc.a632.0451.8a

 

If you look at my listing above, you will notice that the address added automatically is associated with the MAC 01dc.a632.0451.8a - that's why I tried both ways.

 

Unfortunately, it did not work

 

Hello Robert,

 

ass suggested by Paul in a previous post, try the below syntax:

 

ip dhcp pool smart_home_controller
host 10.100.102.240 255.255.255.0
client-identifier 01dc.a632.0451.8a
client-name homeassistant_openhab