cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1468
Views
10
Helpful
18
Replies
mrochac
Beginner

MPLS connection move from Switch to router

Here is the scenario - we have MPLS connected from ISP onto a switch, and this is due to not having the wic card in place day of delivery - no WIC is in place in the router (2901) and working - MPLS has been working perfect, i can ping the PE device ip address from my router so on and so forth - here is the problem, i need to move that MPLS connection to my router - and i thought i had this figured out but i guess not - not as easy as just moving cat cable from switch to router and keeping config the same - 

 

thoughts?

18 REPLIES 18

Hey Paul - i did test with xover cable and the same results.... there i 2 separate WIC cards on the router, one already in use, the new one i just installed....

 

So basically we are on about  interface Ge/0 thats all correct? correct

Which when working attaches to a switch which also has the PE rtr attached, but when you remove the switch and attach this rtr via it Ge/0 port  direct to the PE rtr connectivity fails correct? correct, when i move PE connection direct to CE rtr it doesnt like it...

 

- but so whats the additional WIC for, would this be for an additional peering or addition to a multipoint. The additional WIC is the one i just purchased for this connection.

 

Can you also post the config of your router please.

for this connection we're working on.

 

interface GigabitEthernet0/1.1
description DATA VLAN
encapsulation dot1Q 1 native
ip address 10.179.129.253 255.255.255.0
ip nat inside

 

Physical WIC port

!
interface GigabitEthernet0/1/0
no ip address
!
interface GigabitEthernet0/1/1
no ip address
!
interface GigabitEthernet0/1/2
no ip address
!
interface GigabitEthernet0/1/3
no ip address
duplex full
speed 100

 

router bgp 65057
bgp router-id 10.179.129.253
bgp log-neighbor-changes
bgp redistribute-internal
network 10.35.0.0 mask 255.255.0.0
network 10.45.0.0 mask 255.255.0.0
network 10.100.10.24 mask 255.255.255.252
network 10.182.15.0 mask 255.255.255.0
network 172.24.5.0 mask 255.255.255.0
network 192.168.5.0
neighbor 10.179.129.252 remote-as 65057
neighbor 10.179.129.252 next-hop-self
neighbor 10.179.129.252 send-community
neighbor 10.179.129.252 soft-reconfiguration inbound
ip virtual-reassembly in

 

 

Hope this helps clear things up....

Hi

Just a couple of questions, This configuration (blue) looks an iBGP to your internal network is that correct? and is it just for internal not to connect to the ISP?

 

interface GigabitEthernet0/1.1
description DATA VLAN
encapsulation dot1Q 1 native
ip address 10.179.129.253 255.255.255.0
ip nat inside

 

But you are now trying connecting to a Etherswitch module the ISP's router, is that correct?

 

Physical WIC port

!
interface GigabitEthernet0/1/0
no ip address
!
interface GigabitEthernet0/1/1
no ip address
!
interface GigabitEthernet0/1/2
no ip address
!
interface GigabitEthernet0/1/3
no ip address
duplex full
speed auto

 

So I would like to see the current configuration for the connection with the ISP. With Etherswich module you could configure:

 

Example:

vlan 100

name ISP

 

ip routing

 

interface vlan 100

ip address x.x.x.x y.y.y.y (P2P with provider)

no shutdown

 

interface g0/1/3

switchport access vlan 100

switchport mode access

no shutdown

 

ip route 0.0.0.0 0.0.0.0 x.x.x.x  (pointing to ISP router interface IP)

 

Could you please share a Low level topology?

Thank you in advance

 

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

View solution in original post

Hello

Then providing the wic is working you should obtain connectivity - Which makes me wonder if its the wic

 

Can you confirm its installed correctly ( in the correct slot)

Have you rebooted the rtr?
Can you ping the interface on the wic when its connected to your laptop?

 

res
Paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

View solution in original post

Thanks for everyone's assistance, solutions;
Example:

vlan 100

name ISP



ip routing



interface vlan 100

ip address x.x.x.x y.y.y.y (P2P with provider)

no shutdown



interface g0/1/3

switchport access vlan 100

switchport mode access

no shutdown
Thanks.