cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4261
Views
5
Helpful
7
Replies

Multiple concurrent PPPOE connections ?

HDBank Network
Level 1
Level 1

Hi

I'm configuring load balance over multiple pppoe connections. The pppoe connections're UP when I show pppoe session, here's pppoe configuration:

interface FastEthernet0/2/0
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface FastEthernet0/2/1
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 2


interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1000
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username ******** password *******
!
interface Dialer2
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1000
dialer pool 2
dialer-group 2
ppp authentication pap callin
ppp pap sent-username ******** password *******

then I config NAT & default route, PCs can connect to the Internet

ip route 0.0.0.0 0.0.0.0 Dialer1
ip nat inside source route-map CMC-NAT interface Dialer2 overload
ip nat inside source route-map VNPT-NAT interface Dialer1 overload

The problem is that I cannot ping from source interface Dialer2. Conversely, when I config default route over Dialer2, I cannot ping from source interface Dialer1. Therefore, I cannot monitor pppoe connections concurrently through IP SLAs.

Please help me

1 Accepted Solution

Accepted Solutions

can you try config below;

interface FastEthernet0/0
ip policy route-map LOADBALANCE

ip route 8.8.8.8 255.255.255.255 Dialer2
ip route 8.8.4.4 255.255.255.255 Dialer1

ip sla 1
icmp-echo 8.8.8.8 source-interface Dialer2
timeout 2000
threshold 1000
frequency 5
ip sla schedule 1 life forever start-time now

ip sla 2
icmp-echo 8.8.4.4 source-interface Dialer1
timeout 2000
threshold 1000
frequency 5
ip sla schedule 2 life forever start-time now

route-map CMC-NAT permit 10
match ip address wireless

route-map VNPT-NAT permit 10
match ip address wireless

no ip route 0.0.0.0 0.0.0.0 Dialer1
no ip route 0.0.0.0 0.0.0.0 Dialer2

hth

Muammer

View solution in original post

7 Replies 7

mrdogantr
Level 1
Level 1

Hi,

     Can you try double default route.

ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 0.0.0.0 0.0.0.0 Dialer2

hth

Muammer

I tried the double default route, but I always can ping only from source Dialer2.

     Did you try when dialer2 is shutdown. Can you share your config file.  

When I use double default routes, I can ping only from source Dialer2. When I shutdown Dialer2, I can ping from source Dialer1 (still using double default route). Then, when I up Dialer2, I can ping only from source Dialer1.

can you try config below;

interface FastEthernet0/0
ip policy route-map LOADBALANCE

ip route 8.8.8.8 255.255.255.255 Dialer2
ip route 8.8.4.4 255.255.255.255 Dialer1

ip sla 1
icmp-echo 8.8.8.8 source-interface Dialer2
timeout 2000
threshold 1000
frequency 5
ip sla schedule 1 life forever start-time now

ip sla 2
icmp-echo 8.8.4.4 source-interface Dialer1
timeout 2000
threshold 1000
frequency 5
ip sla schedule 2 life forever start-time now

route-map CMC-NAT permit 10
match ip address wireless

route-map VNPT-NAT permit 10
match ip address wireless

no ip route 0.0.0.0 0.0.0.0 Dialer1
no ip route 0.0.0.0 0.0.0.0 Dialer2

hth

Muammer

yeah, it works. Thank you very much, Muammer.

Nice weekend

Hi,

     Please rate the helpful posts.

Regards,

Muammer