cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
747
Views
0
Helpful
5
Replies
shine pothen
Participant

Need help in configuring both my MPLS link to be utilized

Hi Support Team

 I Have 2 Mpls provider with each 2MB connection, currently, i am able to use only one link at a time and once one link fails with preference weight in bgp it will fail over to the othMplspls link.

Need your help in getting my link load balanced or load sharing between two MPLS BGP provider terminating on the same router with different AS number

I have this setup in my branch office, I have two MPLS BGP provider terminating on the same router on two different interfaces.

and the third interface is for the local Lan.is there any way I can do load balancing or load sharing.

below is the config on the router.

 

 

interface FastEthernet0/0
description MPLS_1
bandwidth 2048
ip address 10.77.139.210 255.255.255.248
ip accounting output-packets
ip nbar protocol-discovery
ip flow ingress
ip route-cache flow
speed 100
full-duplex

 

interface FastEthernet0/1
description Local Lan
ip address 10.10.70.100 255.255.254.0
ip flow ingress
ip nat inside
no ip virtual-reassembly
ip route-cache flow
duplex auto
speed auto
keepalive 1000
!
interface Serial0/1/0
description MPLS_2
bandwidth 2048
ip address 192.168.213.201 255.255.255.252
encapsulation ppp

 

router bgp 65001
no synchronization
bgp log-neighbor-changes
bgp dampening
network 10.10.70.0 mask 255.255.254.0
neighbor 10.77.139.209 remote-as 4755
neighbor 10.77.139.209 soft-reconfiguration inbound
neighbor 10.77.139.209 weight 150
neighbor 10.77.139.209 route-map MPLS_1 out
neighbor 192.168.213.202 remote-as 9829
neighbor 192.168.213.202 soft-reconfiguration inbound
neighbor 192.168.213.202 weight 30000
neighbor 192.168.213.202 route-map MPLS_2 out

ip prefix-list MPLS_2_2 seq 20 permit 10.10.70.0/23
ip prefix-list MPLS_1_1 seq 20 permit 10.10.70.0/23

route-map MPLS_1_1 permit 10
match ip address prefix-list MPLS_1_1

route-map MPLS_2_2 permit 10
match ip address prefix-list MPLS_2_2

 Help me in getting the both the link utilized

5 REPLIES 5
Terence Payet
Beginner

Hi,

 

If the AS-PATH length is the same on both MPLS provider, you can use 'bgp bestpath as-path multipath-relax' command.

 

BGP config:

 

router bgp 65001
no synchronization
bgp log-neighbor-changes
bgp dampening
network 10.10.70.0 mask 255.255.254.0
neighbor 10.77.139.209 remote-as 4755
neighbor 10.77.139.209 soft-reconfiguration inbound
neighbor 10.77.139.209 route-map MPLS_1 out
neighbor 192.168.213.202 remote-as 9829
neighbor 192.168.213.202 soft-reconfiguration inbound
neighbor 192.168.213.202 route-map MPLS_2 out

bgp bestpath as-path multipath-relax

maximum-path 2

 

 

If the AS-PATH length are different, then you need to apply some inbound policing so that the AS-PATH length are the same and then you can use the above config.

 

Give it a try.

 

Please rate helpful posts.

Georg Pauwen
VIP Expert

Hello,

 

in addition to Terence's post, have a look at the link below (scroll down to BGP Topology 4), which gives various options and sample configurations for your setup:

 

http://showipbgp.com/bgp-configurations/cisco.html

paul driver
VIP Mentor

Hello

Can you elaborate a bit more as It all depends on what prefixes you receiving from each ISP?

Do you want equal load sharing or just prefer to use a certain ISP for certain host etc..

 

Also just like to add comment on a few points with your exsitng config:

1) at present you have weight PA preferring AS 9829 for egress traffic

2) reconfiguration inbound <-- BGP soft reset is built into newer ios so this isnt required as it can consume high memory processes)

3) I would also suggest apply a filter so to negate your branch rtr being a transit path for both ISP
ip as-path acess-list 10 permit ^$
neigbour 10.77.139.209 filter-list 10 out

neigbour 192.168.213.202  filter-list 10 out

 

4) What are the prefix-list doing?


res
Paul

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

can you elaborate a bit more as It all depends on what prefixes you receiving from each ISP?
I am receiving all the routes from MPLS provider which means all my other location

Do you want equal load sharing or just prefer to use a certain ISP for certain host etc..
we are looking for a solution to do load sharing.
if at all certain host for certain ISP, we need to make sure failover should work.otherwise few host will be isolation during outages.

Also just like to add comment on a few points with your exsitng config:

1) at present you have weight PA preferring AS 9829 for egress traffic

we are using weight perferance to make one MPLS as the primary and if it fails then the other MPLS takes over

2) reconfiguration inbound <-- BGP soft reset is built into newer ios so this isnt required as it can consume high memory processes)


3) I would also suggest apply a filter so to negate your branch rtr being a transit path for both ISP
ip as-path acess-list 10 permit ^$
neigbour 10.77.139.209 filter-list 10 out

neigbour 192.168.213.202 filter-list 10 out

 

4) What are the prefix-list doing?
using prefix list we are making sure only 10.10.70.0/23 subnet which is the local subnet is the router.

both the mpls service provider are throwing all routes from our other location.
we only communicate from our Headoffice to branch office, and the above config i shared is from one of my branch location.

 

Hello,

 

the BGP local preference must be equal for all inbound routes. Then you can achieve load sharing using the below configuration:

 

router bgp 65001
bgp bestpath as-path multipath-relax
address-family ipv4

no neighbor 10.77.139.209 weight 150
no neighbor 192.168.213.202 weight 30000
maximum-paths 2

 

Regards