cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
502
Views
0
Helpful
1
Replies

Nested QoS/HQoS/VLAN Tag-Based Help!

Hi all

I was wondering if someone could provide some light on the following configuration which I'm struggling to understand. It's regarding a QoS policy we have for a customer.

The config is here:

 

class-map match-any ce_mgmt_output
  match ip dscp cs7
class-map match-any ce_signalling_output
  match ip dscp cs3  af31
class-map match-any ce_hiprio_output
  match ip dscp 25
class-map match-any ce_loprio_output
  match ip dscp cs2  af21
class-map match-all vlan3797
  match vlan  3797                           <----Point of interest (see below)
class-map match-any ce_scavenger_output
  match ip dscp cs1  af11
class-map match-any ce_routing_output
  match ip dscp cs6
class-map match-any ce_video_output
  match ip dscp cs4  af41
class-map match-any ce_voice_output
  match ip dscp ef                              <----Point of interest (see below)
!
policy-map EVC-50M-out <----Child Policy
  class ce_voice_output
    priority 15851
class ce_mgmt_output
    bandwidth 557
class ce_routing_output
    bandwidth 557
class ce_video_output
    bandwidth 11443
class ce_signalling_output
    bandwidth 557
class ce_hiprio_output
    bandwidth 3906
class ce_loprio_output
    bandwidth 4465
class ce_scavenger_output
    bandwidth 1953
    police 1953000 conform-action transmit exceed-action drop
class class-default
    bandwidth 4471
!
policy-map parent-shaper-gi0/0/1  <---- Parent Policy
description Parent policy for Gi0/0/1
class vlan3797
    shape average 43760000
   service-policy EVC-50M-out
!
interface GigabitEthernet0/0/1
mtu 1534
bandwidth 1000000
no ip address
no ip redirects
no ip proxy-arp
ip flow ingress
load-interval 30
negotiation auto
service-policy output parent-shaper-gi0/0/1
hold-queue 1000 in

!

interface GigabitEthernet0/0/1.3797
bandwidth 43760
encapsulation dot1Q 3797 

ip address X.X.X.X 255.255.255.252

I guess my confusion lies in the order of things.


Let's say for example, a voice packet were to enter the router?  A voice packet enters the router (we're pretty congested right now). The router matches the DSCP value in the IP header and classifies this packet using the class map:


class-map match-any ce_voice_output
  match ip dscp ef


What next? Where for example, does the following class map come in:


class-map match-all vlan3797
  match vlan  3797

I understand the concept of parent and child policy maps but am just struggling to understand how this particular config works from packet entering router to packet being sent out of the WAN interface (sub-interface).

Can anyone shed some light on this?

Many thanks in advance for your help and advice.

1 Reply 1

Joseph W. Doherty
Hall of Fame
Hall of Fame

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

Your posting doesn't show any QoS treatment for such packets as they enter the device.

However, as they egress g0/0/1 the packet will be subjected to policy parent-shaper-gi0/0/1.  The policy will sequential compare packets to the match rules for each of its classes. Packets that came from vlan3797 will be processed by the vlan3787 class.  This class first shapes all its traffic to 43760000 bps.  If the traffic rate exceeds that value, it will queue the over-rate traffic and subject the queued packets to the subordinate policy EVC-50M-out.  That policy will again examine each packet, sequentially, for a match against one of its classes.  For packets market with a ToS value of DSCP EF it will place them in the LLQ with a rate-limit of 15851 bps.  Effectively, as the shaper releases packets that it has held, such packets will go 1st.  LLQ will drop its packets such that its class rate doesn't exceed 15851 bps.

If this doesn't fully clarify what you've posted does, please let me know.

Review Cisco Networking products for a $25 gift card