cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
8290
Views
0
Helpful
19
Replies
Highlighted
Beginner

OSPF mtu mismatch question

Hello,

I have following cisco catalyst switches and running OSPF.

3750G (C3750-ADVIPSERVICESK 12.2(25)SED1)

3750X (C3750E-UNIVERSALK9-M 15.0(1)SE3)

3850 (cat3k_caa-universalk9 03.02.01.SE)

They are all connected through L2 WAN (192.168.40.x/24 star topology)

The link between 3750X and 3850 doesn't reach FULL state.

I think this is because MTU mismatch.

3750G VLAN60 SVI mtu 1500

3750X VLAN60 SVI mtu 1500

3850 VLAN60 SVI mtu 9198

But 3750G doesn't complain anything and staying FULL state with 3750X and 3850.

The output of show ip ospf neigbors on each switch is like the following.

3750G (ID: 10.10.11.1 IP address:192.168.40.101)

Neighbor ID     Pri   State           Dead Time   Address         Interface

2.2.2.2           1   FULL/DROTHER    00:00:36    192.168.40.102  Vlan60

3.3.3.3           1   FULL/BDR        00:00:33    192.168.40.103  Vlan60

3750X (ID: 2.2.2.2 IP address:192.168.40.102)

Neighbor ID     Pri   State           Dead Time   Address         Interface

3.3.3.3           1   EXSTART/BDR     00:00:36    192.168.40.103  Vlan60 (repeat EXSTART > DOWN )

10.10.11.1        1   FULL/DR         00:00:30    192.168.40.101  Vlan60

3850 (ID:3.3.3.3 IP address: 192.168.40.103)

Neighbor ID     Pri   State           Dead Time   Address         Interface

2.2.2.2           1   EXSTART/DROTHER 00:00:38    192.168.40.102  Vlan60 (repeat EXSTART > DOWN )

10.10.11.1        1   FULL/DR         00:00:32    192.168.40.101  Vlan60

I think if I changed MTU on 3850 to 1500 (ip mtu 1500), all seem to get OK.

But the question is why 3750G doesn't complain now.

Thanks in advance,

Taro

19 REPLIES 19
Highlighted

try to ignore MTU on interface, like this cmd ip ospf mtu-ignore

Regards,

Habibi

Regards, Habibi
Highlighted

Ignoring MTU is not the right solution. This can cause problems related to DBD exchange. changing the MTU size to a correct number is better. However the query posted is  why 3750G doesn't complain about MTU mismatch !!

Can i get the network diagram to understand the connectivity better!!!

Refer while you debug ip ospf adj

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080093f0d.shtml

Regards,

Sathvik

View solution in original post

Highlighted

With OSPF the MTU is a field set in the DBD during neighbor establishement. We send small packets only indicating how big our interface MTU is. We can see this in the debugs between the 3750X and the 3850

===========================

Dec 27 09:42:04.033 JST: OSPF: Rcv DBD from 3.3.3.3 on Vlan60 seq 0x1ED6 opt 0x52 flag 0x7 len 32  mtu 9198 state EXSTART

Dec 27 09:42:04.033 JST: OSPF: Nbr 3.3.3.3 has larger interface MTU

!

!

Dec 27 09:52:01.538 JST: OSPF-1 ADJ   Vl60: Rcv DBD from 2.2.2.2 seq 0x230A opt 0x52 flag 0x7 len 32  mtu 1500 state EXSTART

Dec 27 09:52:01.538 JST: OSPF-1 ADJ   Vl60: Nbr 2.2.2.2 has smaller interface MTU

===========================

the debugs on the 3750G show the DR election on the segment, but is debug from a reset of all 3750G neighbors? The problem is clear, but the question is "why does it work when it shouldn't?"

My guess is that the 3750G is either lying about it's MTU or using MTU ignore without showing us. I'd want to see the adj debugs from both the 3750G and the 3850 with a full neighbor reset (clear ip ospf proc...), I think that seeing what advertised MTU is received on the remote end would be key to figuring out why it works when it shouldn't.

-Pete

View solution in original post

Highlighted

Thank you very much to all inputs!

I appreciate it.

I will lower the mtu on 3850 and post the result!

Highlighted

I have applied "ip mtu 1500" on all SVI at Cat3850.

Now output of "sh ip ospf neigbors" shows FULL state at all switches.

I was not able to address the original question why 3750G doesn't complain about MTU mismatch.

However it all works fine now, so i won't investigate it any more.

Thanks for all the inputs.