cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
410
Views
5
Helpful
16
Replies

OSPF on vlan interfaces

hmc250000
Beginner
Beginner

Will this configuration work for ospf routing on a vlan interface on a 3850 L3 switch? Never done it on a vlan interface before but having trouble getting it to work in GNS3.

 

interface Vlan100
ip address 192.168.100.1 255.255.255.0
ip ospf network broadcast




router ospf 100
router-id 192.168.100.1
redistribute connected metric 1 subnets
network 10.10.10.0 0.0.0.255 area 0
network 192.168.100.0 0.0.0.255 area 0
network 192.168.99.0 0.0.0.255 area 0

passive-interface default

no passive-interface vlan 100


16 Replies 16

Yes, I could have configured loopback interface but did it just to keep it simple. I understand that is best practise because it will never go down.

THe other networks (not 192.168.100.x/24) I redistributed in OSPF are static routes. 

paul driver
VIP Expert VIP Expert
VIP Expert

Hello
Yes it should work, forming an ospf adjecency over a L3 SVI is applicable.


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers