cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3220
Views
0
Helpful
2
Replies

QoS Configuration Help

ricardo.viteri
Level 1
Level 1

Hello and thanks for taking a look,

I am trying to achieve the following behavior through Cisco QoS.

The goal is that when rtp audio packets are flowing then VoIP Queue reserves 464kbps and the other queues have 64 kbps available to share.

Therefore, if I have an uplink of 512kbps and If there are rtp packets going through the interface, I want the Policy class to reserve 464kbps (regardless of how many actual kbps of rtp audio packets are flowing through).  If there are no rtp audio packets going through the interface then share the the 512kbps according to the other classes.

Another way to look at what I am trying to achieve is the following (maybe it will help to clarify):

If RTP Packets in class CCP-Voice-1 are present then shape all other traffic to 64kbps

This is my current config:

1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
46:
47:
48:
49:
50:
51:
52:
53:
54:
55:
56:
57:
58:
59:
60:
61:
62:
63:
64:
65:
66:
67:
68:
69:
70:
71:
72:
73:
74:
75:
76:
77:
78:
79:
80:
81:
82:
83:
84:
85:
86:
87:
88:
89:
90:
91:
92:
93:
94:
95:
96:
97:
98:
99:
100:
101:
102:
103:
104:
105:
106:
107:
108:
109:
110:
111:
112:
113:
114:
115:
116:
117:
118:
119:
120:
121:
122:
123:
124:
125:
126:
127:
128:
129:
130:
131:
132:
133:
134:
135:
136:
137:
138:
139:
140:
141:
142:
143:
144:
145:
146:
class-map match-any CCP-Transactional-1
match protocol citrix
match protocol finger
match protocol notes
match protocol novadigm
match protocol pcanywhere
match protocol sap
match protocol secure-telnet
match protocol sqlnet
match protocol sqlserver
match protocol ssh
match protocol telnet
match protocol xwindows
class-map match-any CCP-Voice-1
match protocol rtp audio
class-map match-any CCP-Routing-1
match protocol bgp
match protocol eigrp
match protocol ospf
match protocol rip
match protocol rsvp
class-map match-any CCP-Signaling-1
match protocol h323
match protocol rtcp
match protocol sip
class-map match-any CCP-Management-1
match protocol dhcp
match protocol dns
match protocol imap
match protocol kerberos
match protocol ldap
match protocol secure-imap
match protocol secure-ldap
match protocol snmp
match protocol socks
match protocol syslog
class-map match-any HTTP/S
match protocol http
match protocol secure-http
!
!
policy-map CCP-QoS-Policy-1
class CCP-Voice-1
  set dscp ef
    priority 464
class CCP-Signaling-1
  set dscp cs3
    bandwidth percent 1
class CCP-Routing-1
  set dscp cs6
    bandwidth percent 1
class CCP-Management-1
  set dscp cs2
    bandwidth percent 1
class CCP-Transactional-1
  set dscp af21
    bandwidth percent 1
class HTTP/S
    bandwidth percent 4
class class-default
    fair-queue
     random-detect
policy-map CCP-QoS-Policy-2
class class-default
    shape average 512000
  service-policy CCP-QoS-Policy-1

interface FastEthernet4
description $FW_OUTSIDE$$ES_WAN$
bandwidth 512
bandwidth receive 4096
ip address dhcp client-id FastEthernet4
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 576
ip nbar protocol-discovery
ip flow ingress
ip nat outside
ip virtual-reassembly
ip tcp adjust-mss 512
duplex auto
speed auto
!       
max-reserved-bandwidth 1
service-policy output CCP-QoS-Policy-2
!        
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
ip address 10.0.11.254 255.255.252.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!       
!        
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!        
!        
ip nat inside source list 1 interface FastEthernet4 overload
!        
logging trap debugging
access-list 1 remark CCP_ACL Category=2
access-list 1 permit 10.0.8.0 0.0.3.255
no cdp run





Cisco IOS Software, C880 Software (C880DATA-UNIVERSALK9-M), Version 15.0(1)M3, RELEASE SOFTWARE (fc2)


Cisco 881 (MPC8300) processor (revision 1.0) with 236544K/25600K bytes of memory.
Processor board ID FTX143200J6

5 FastEthernet interfaces
1 Virtual Private Network (VPN) Module
256K bytes of non-volatile configuration memory.
125440K bytes of ATA CompactFlash (Read/Write)


License Info:

License UDI:

-------------------------------------------------
Device#	  PID			SN
-------------------------------------------------
*0  	  CISCO881-SEC-K9          



License Information for 'c880-data'
    License Level: advipservices   Type: Permanent
    Next reboot license Level: advipservices



2 Replies 2

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello Ricardo,

two notes:

1)

>> Therefore, if I have an uplink of 512kbps and If there are rtp packets going through the interface, I want the Policy class to reserve 464kbps (regardless of how many actual kbps of rtp audio packets are flowing through).  If there are no rtp audio packets going through the interface then share the the 512kbps according to the other classes.

Class Based Weighted Fair Queueing has built in elasticity and resources unused by VOIP packets are available for other resources.

This is usually enough.

2)  about your configuration

there are some strange commands on WAN interface Fas4:

if you set bandwidth to 512 kbps the max-reserved-bandwidth should be set to 100 (100%) and not to 1.

The bandwidth command sets a new reference value for QoS.

ip mtu 576: this MTU is too small and it causes a lot of fragmentation of data traffic IP packets

I usually mark on LAN interfaces and then match on DSCP or IP precedence settings on exit interface this helps in troubleshooting as the command show policy-map interface provides counters for each traffic class and so you can compare traffic entering the router with traffic that is sent out the WAN interface.

Hope to help

Giuseppe

Hi Giuseppe,

You are correct I did notice I had 1% and not 100%, I fixed this soon after my post.  Still it did not fix my issue.

I have set MTU to 576 bytes and MSS to 536 bytes for the following reason:

Serialization Delay. ( http://www.cisco.com/en/US/tech/tk652/tk698/technologies_white_paper09186a00800a8993.shtml#serializationdelay )

I was hoping I could implement Link Fragmentation and Interleaving; unfortunately soon I discovered this only works for PPP connections so my FastEthernet connected to my Cable Modem would not support it.

Is it possible to allow the elasticity of bandwidth only when there are no VoIP packets present?

My goal is to achieve this behavior using just the router (perhaps with EEM TCLs - if someone out there could code it):

http://www.xmission.com/~hidden/aatqos/

Regards,

Ricardo

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card