07-25-2020 09:47 AM - edited 07-25-2020 11:17 AM
Hi Dears.
i have a P2P Wireless Link as WAN which has variable speed due to bad air condition( at offshore drilling rig). it's speed vary from 30mbps to 25 or maybe lower( it is not predictable). i have a Cisco router as gateway which uses this p2p wireless link to access internet. i want to configure 2 user group( in qos i mean class-maps) in this router to access the internet as follow: group A with higher speed and group B with lower speed. which is the best solution for such variable speed link for optimal use of wan link.
best regards,
Sina HR.
07-25-2020 01:24 PM
Hello,
not knowing which device this is on, and what IOS you are running, below is an example of what could work in your scenario (IP addressing is arbitrary, obviously):
access-list 101 permit ip 192.168.1.0 0.0.0 255 any
!
access-list 102 permit ip 192.168.2.0 0.0.0 255 any
!
class-map match-all GROUP_A
match access-group 101
!
class-map match-all GROUP_B
match access-group 102
!
policy-map BANDWIDTH_POLICY
class GROUP_A
bandwidth percent 70
class GROUP_B
bandwidth percent 30
!
interface GigabitEthernet0/0
description WAN Interface
service-policy output BANDWIDTH_POLICY
07-25-2020 01:39 PM
07-25-2020 02:36 PM
Hello,
you are running a rather old IOS version; the bandwidth percent is I think not available in your IOS. Check if you can configure the below:
access-list 101 permit ip 192.168.1.0 0.0.0 255 any
!
access-list 102 permit ip 192.168.2.0 0.0.0 255 any
!
class-map match-all GROUP_A
match access-group 101
!
class-map match-all GROUP_B
match access-group 102
!
policy-map PRIORITY_POLICY
class GROUP_A
priority percent 70
class GROUP_B
priority percent 30
!
interface GigabitEthernet0/0
description WAN Interface
service-policy output PRIORITY_POLICY
07-26-2020 09:47 PM
07-25-2020 05:36 PM - edited 07-25-2020 05:38 PM
Policy-map class bandwidth percentages will be based on the policy "believes" is the controlling bandwidth. For a physical interface, it would default to the physical bandwidth the interface is running at. This can be changed using an interface bandwidth statement.
For a child policy under a parent policy with a shaper, the child policy will base its bandwidth percentage on the shaper's bandwidth allocation.
Neither of which, is as optimal or precise as you're trying to achieve. Again, as noted in my first post, simple solution would be to use a typical/average "load water mark" for your shaper's bandwidth allocation. The optimal solution would use some kind of on-going SLA test to monitor available bandwidth and rewrite shaper's bandwidth allocation as needed. Oh, if you do try to roll your own Adaptive QoS, you'll want to "prioritize" your SLA test's traffic over all other traffic, and perhaps even bypass the shaper. E.g.:
policy-map Parent
class SLA
priority #
class class-default
bandwidth remaining percent 100
shape average # !this is the value your script will rewrite
service-policy Child
policy-map Child
class GroupA
bandwidth percent #
class GroupB
bandwidth percent #
!or just use
class class-default
fair-queue !unsure but FQ in parent's class-default might negate the need for a child policy if just using child with class-default using FQ
07-26-2020 10:20 PM
07-27-2020 07:15 AM
07-25-2020 05:23 PM
07-26-2020 10:40 PM
07-27-2020 07:17 AM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide