cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
615
Views
0
Helpful
3
Replies

Redundancy + Load Sharing Two ADSL

saquib.tandel
Level 1
Level 1

Hello

We got One ADSL 4MB Link terminated on 877, this router is the default Gateway for users. To have redundancy we plan to get another link 4MB ADSL link terminating on another 877 from a different provider. what config is needed to have auto switch-over if primary ADSL link is down.  Is load sharing on Two ADSL possible in my scenario.

thanks

Saquib

1 Accepted Solution

Accepted Solutions

You create an IP SLA, and link it to HSRP

Create IP SLA to ping your next-hop router or anything on the internet to verify connectivity:

877_1(config)#rtr 1
877_1(config-rtr)#type echo protocol ipIcmpEcho 1.1.1.1
877_1(config-rtr-echo)#frequency 10
877_1(config-rtr-echo)#exit

877_1(config)#rtr schedule 1 start-time now life forever

Link it to a Tracking object:

877_1(config)#track 1 rtr 1

Link the tracking object to HSRP

877_1(config)#interface fa0/1
877_1(config-if)#standby 1 ip 192.168.0.1
877_1(config-if)#standby 1 track 1 decrement 50

877_1(config-if)#standby 1 priority 110

NOTE: I am using an old-ish version of IOS to create this example. The syntax is slightly different for creating IP SLAs now. I believe it's "ip sla " instead of rtr. Just look for IP SLA on cisco's site and there are pleanty of config examples. There are many options you can tune such as time-out, frequency etc. You can also tune the track object. You can have the track object not report "Down" until there have been 3 pings missed for example. It would reduce flapping.

This config will ping 1.1.1.1 every 10 seconds. if the IP doens't respond, the track object goes into a "Down" state. HSRP sees that down state and decrements 877_1's priority by 50. 877_2 will see that, and since it's default priority (100) is higher than 877_1, it will take over for the virtual IP. Once 1.1.1.1 starts to respond to pings again, the opposite will happen.

If you want to do true load-balancing, you should look into GLBP. You could use MHSRP, but the config is rather clunky. The config for GLBP is very similar. You can learn about it here:

http://www.cisco.com/en/US/customer/docs/ios/12_2s/feature/guide/fs_glbp2.html

HTH

View solution in original post

3 Replies 3

rtjensen4
Level 4
Level 4

You can use HSRP for failover between the two 877s. Loadsharing would be a bit more complex.

Here's an example. This is configured on the LAN interface. The "Default Gateway" ip is configured as a virtual IP.

877 #1:

interface vlan1

ip address 192.168.0.2 255.255.255.0

standby 1 ip 192.168.0.1

standby 1 preempt

877 #2:

interface vlan2

ip address 192.168.0.3 255.255.255.0

standby 1 ip 192.168.0.1

standby 1 preempt

You can also use HSRP to track the state of your "primary" DSL interface and cause the HSRP to switch over in reaction to that.

This link will help you if you aren't familiar with HSRP:

http://www.cisco.com/en/US/customer/tech/tk648/tk362/technologies_tech_note09186a0080094a91.shtml

Hi

what condition needs to be applied on HSRP to ensure if reachability to internet is down then traffic is forwarded to 2nd ADSL Link. How do I configure this?

One link will be ideal all time so would be interested to see load Sharing scenario too.

thanks

Saquib

You create an IP SLA, and link it to HSRP

Create IP SLA to ping your next-hop router or anything on the internet to verify connectivity:

877_1(config)#rtr 1
877_1(config-rtr)#type echo protocol ipIcmpEcho 1.1.1.1
877_1(config-rtr-echo)#frequency 10
877_1(config-rtr-echo)#exit

877_1(config)#rtr schedule 1 start-time now life forever

Link it to a Tracking object:

877_1(config)#track 1 rtr 1

Link the tracking object to HSRP

877_1(config)#interface fa0/1
877_1(config-if)#standby 1 ip 192.168.0.1
877_1(config-if)#standby 1 track 1 decrement 50

877_1(config-if)#standby 1 priority 110

NOTE: I am using an old-ish version of IOS to create this example. The syntax is slightly different for creating IP SLAs now. I believe it's "ip sla " instead of rtr. Just look for IP SLA on cisco's site and there are pleanty of config examples. There are many options you can tune such as time-out, frequency etc. You can also tune the track object. You can have the track object not report "Down" until there have been 3 pings missed for example. It would reduce flapping.

This config will ping 1.1.1.1 every 10 seconds. if the IP doens't respond, the track object goes into a "Down" state. HSRP sees that down state and decrements 877_1's priority by 50. 877_2 will see that, and since it's default priority (100) is higher than 877_1, it will take over for the virtual IP. Once 1.1.1.1 starts to respond to pings again, the opposite will happen.

If you want to do true load-balancing, you should look into GLBP. You could use MHSRP, but the config is rather clunky. The config for GLBP is very similar. You can learn about it here:

http://www.cisco.com/en/US/customer/docs/ios/12_2s/feature/guide/fs_glbp2.html

HTH

Review Cisco Networking for a $25 gift card