cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2949
Views
30
Helpful
10
Replies

Routing Between Different VLANS and Subnets

thisishusamm
Level 1
Level 1

Hi,

Hope you are doing well.

I have the following devices in my network

- 2 * Cisco Switch 3560

- Cisco Switch 3750 MLS

every Cisco Switch 3560 have different Vlans and subnets, first Cisco Switch have:

GIS_SW

VLAN 30

Network: 30.1.1.0 255.255.255.0

VLAN 40

Network: 40.1.1.0 255.255.255.0

VLAN 50

Network: 50.1.1.0 255.255.255.0

Second Switch:

Al_Abass_1_SW

VLAN 60

Network: 60.1.1.0 255.255.255.0

VLAN 70

Network: 70.1.1.0 255.255.255.0

VLAN 80

Network: 80.1.1.0 255.255.255.0

 

I want to routing between VLANS in Middel switch MLS. How can I do that?

Capture.JPG

10 Replies 10

Hello,

 

all your SVI (Vlan interfaces) have to be configured on the middle switch. You cannot configure any other Vlan interfaces (other than the Vlan interface used for management) on the other switches.

 

Is this a Packet Tracer project ? If so, post the zipped Packet Tracer project (.pkt) file. If not, post the full running configs of all three switches.

thanks for your reply Dear,

No, it's just diagram by packet tracer. the main question is how can I do the routing in the middle switch?

 

Hello @thisishusamm ,

if you have real switches you can do the following :

enable ip routing on the two 3560 access switches.

Create a VLAN 90 for L3 communication between GIS_SW and C3750 using a new subnet like 10.10.90.0/24

vlan 90

exit

 

 

Configure SVI interface VLAN 90 on GIS_SW

interface vlan 90

desc to C3750 L3

ip address 10.10.90.2 255.255.255.0

no shut

 

interface between GIS_SW and C3750 can be in access mode vlan 90

 

interface gi1/0/x

desc to C3750:

switchport

switchport mode access

switchport access vlan 90

 

 

The same you do on C3750 switch

create vlan 90 at layer 2

vlan 90

exit

 

interface vlan 90

desc L3 to GIS_SW

ip address 10.10.90.1 255.255.255.0

 

on GIS_SW

ip route 0.0.0.0 0.0.0.0 10.10.90.1

 

on C3750

ip route 30.1.1.0 255.255.255.0 10.10.90.2

ip route 40.1.1.0 255.255.255.0 10.10.90.2

ip route 50.1.1.0 255.255.255.0 10.10.90.2

 

Create a VLAN like 100 for L3 communication between middle C3750 and right switch AI_Abass_1_SW

 

enable ip routing on AI_Abass_1_SW

create vlan 100 at layer 2

vlan 100

exit

configure vlan 100 SVI interface

interface vlan 100

desc L3 link to C3750

ip address 10.10.100.2 255.255.255.0

no shut

 

configure physical port to C3750 as access in vlan 100

 

int gi1/0/y

desc to C3750

switchport

switchport mode access

switchport access vlan 100

 

Do the same things on C3750

 

create vlan 100 at layr 2

vlan 100

exit

 

configure interface SVI vlan 100

interface vlan 100

desc link L3 to AI_Abass_1_SW

ip address 10.10.100.1 255.255.255.0

no shut

 

interface gi1/0/z

desc to AI_Abass_1_SW:gi1/0/y

switchport

switchport mode access

switchport access vlan 100

 

on AI_Abass_1_SW

 

ip routing

ip route 0.0.0.0 0.0.0.0 10.10.100.1

 

on C3750 side you add

ip route 60.1.1.0 255.255.255.0 10.10.100.2

ip route 70.1.1.0 255.255.255.0 10.10.100.2

ip route 80.1.1.0 255.255.255.0 10.10.100.2

 

There are many other ways to do the routing you can use a dynamic routing like OSPF. Here I have presented the simplest solution with static routes using default routes from acces layer switches to the C3750 (otherwise I should have configured specific static routes for remote subnets on access layer switches too)

 

Hope to help

Giuseppe

 

 

Thanks for your reply dear.

Be informed I want GRE_SW and Al_Abass_SW as L2 switches. I Don't want to do routing in that switches.

Hello,

 

--> I want to routing between VLANS in Middel switch MLS. How can I do that?

 

Do you want ONLY the middle switch to be a layer 3 switch (and do the inter-Vlan routing), or are all three switches supposed to be layer 3 switches (and do routing as well) ?

Hello Dear,

want ONLY the middle switch to be a layer 3 switch (and do the inter-Vlan routing).

Thanks in advanced.

Hello,

 

in that case, make sure only the middle switch has 'ip routing' enabled. Configure the links between all three switches as trunks, and configure the Vlan interfaces on the middle switch:

 

GIS_SW --> Trunk --> Al_Abass_2_SW --> Trunk Al_ABASS_1_SW

 

interface Vlan 30
ip address 30.1.1.1 255.255.255.0
!
interface Vlan 40
ip address 40.1.1.1 255.255.255.0
!
interface Vlan 50
ip address 50.1.1.1 255.255.255.0
!
interface Vlan 60
ip address 60.1.1.1 255.255.255.0
!
interface Vlan 70
ip address 70.1.1.1 255.255.255.0
!
interface Vlan 80
ip address 80.1.1.1 255.255.255.0

Thanks for your reply,

Without any routing command in the middle switch?

Hello,

 

as stated, the middle switch needs to have 'ip routing' enabled:

 

Al_Abass_2_SW#conf t

Al_Abass_2_SW(config)#ip routing

Hello
What you are showing is a routed access-layer network which is a valid design that wont require spanning- tree or trunks

To establish vlan connectivity between the two switches one possible approach would be you enable Ip routing on the two end switches using an igp such as ospf or eigrp (if they are both cisco)

connecting them via a shared routed subnet which will the  allow you to advertise each switch’s  vlans to each other

The middle switch will provide only layer 2 interconnection between the two routed switch’s in a non routable vlan of your choosing.

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul