Does the 3900 series router support static NAT on a sub interface ? I am trying to port forward RDP session from outside interface to the hosts on inside VLANs. Each VLAN is configured on a sub-interface as shown by the snippet below. Is this a supported config ?
===========================
interface GigabitEthernet0/0
ip address 172.16.16.41 255.255.255.0
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1.102
encapsulation dot1Q 102
ip address 192.168.2.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/1.103
encapsulation dot1Q 103
ip nat inside
ip address 192.168.3.254 255.255.255.0
!
interface GigabitEthernet0/1.104
encapsulation dot1Q 104
ip nat inside
ip address 192.168.4.254 255.255.255.0
!
======================
thanks
Chandra