cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1210
Views
0
Helpful
1
Replies
Highlighted
Beginner

Traffic Shaping AND QoS on multiple EVC's

I have a 3825 with a 1Gb fiber card at one of my sites.  Our ISP and MPLS provider hand off a single gigabit fiber to us that contains 2 50MB EVC's.

I need to apply QoS to one of the EVC's and shape them both to 50Mb to avoid upstream rate mismatch bottlenecks.  Both of the EVC's generally only push 10Mb during business hours.

Here are the relevant pieces of my current config:

class-map match-all video_class

match access-group name video_traffic

class-map match-all voice_class

match access-group name voice_traffic

class-map match-all control_class

match access-group name control_traffic

class-map match-all precedence_5

match ip precedence 5

class-map match-all precedence_4

match ip precedence 4

class-map match-all precedence_3

match ip precedence 3

!

!

policy-map Set_DSCP

class voice_class

  set ip dscp ef

class video_class

  set ip dscp af41

class control_class

  set ip dscp af31

policy-map Internet_Shaping

class class-default

    shape average 50000000

policy-map MPLS_QoS

class precedence_5

    priority 5000

class precedence_4

    bandwidth 20000

class precedence_3

    bandwidth 5000

class class-default

     random-detect dscp-based

    fair-queue

policy-map MPLS_QoS_Parent

class class-default

    shape average 50000000

  service-policy MPLS_QoS

!

!

!

!

!

!

!

!

interface GigabitEthernet0/0

description To Datacenter L3 PRIVATE Core Switch

ip address 10.9.0.1 255.255.255.252

ip policy route-map FromEPToWAN

duplex full

speed 1000

media-type rj45

!

service-policy input Set_DSCP

!

interface GigabitEthernet0/1

description *** RAW PUBLIC LINK to Firewalls ***

ip address X.X.X.X 255.255.255.0

ip policy route-map FromPUBToInternet

duplex auto

speed auto

media-type rj45

!

!

interface GigabitEthernet0/0/0

description Uplink to ISP (EVC's)

no ip address

negotiation auto

!

!

interface GigabitEthernet0/0/0.1

description Private WAN

encapsulation dot1Q 409

ip address X.X.X.X 255.255.255.252

ip policy route-map FromWANToEP

service-policy output MPLS_QoS_Parent

!

interface GigabitEthernet0/0/0.2

description Public

encapsulation dot1Q 684

ip address X.X.X.X 255.255.255.252

service-policy output Internet_Shaping

!

When I run UDP stream tests (various rates from 500k-6m that are marked as AF41) to one of my other sites I am consistently getting about 2% packet loss, despite the fact the circuit isn't even close to 50% saturation.  When I remove Shaping and QoS all together, the issue nearly clears itself up, except during peak hours and I get small bursts of packet loss, which is still unacceptable.

When the pipe is at near zero utilization (after hours) there also is no packet loss with or with out the shaping/qos applied.

Is there something I can alter in my config to correct the issue?  This was my first stab at heirarchal policies with traffic shaping with QoS, but something isn't working right. 

Many thanks in advance.

1 REPLY 1
Highlighted
Beginner

This packet loss is only seen in UDP traffic, not TCP.

The 3825 dscp marking policy-map shows plenty of matches and looks to be working as expected.

The 3825 shaping is showing 0 drops (like I said, we aren't really pushing these pipes at all) and the average rate out is in the 8-12Mbps range.

I am wondering if shaping queues are delaying UDP traffic enough that it's missing a de-jitter buffer on the far end and ending up being discarded.

I setup policing on the outbound interfaces of the downstream devices (a firewall and another router) to limit the output of the uplink ports into the 3825 to 50mb.  Thus far it appears to have completely stopped the UDP packet loss, but this is hardly a long term solution to the issue.