cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3121
Views
0
Helpful
6
Replies

VLAN with a Cisco 1721 router and HP Procurve 4000M switch

valleyvet
Level 1
Level 1

I have a Cisco 1721 router and a HP Procurve 4000M switch that I'm using to setup two VLANs.  I have configured the router as shown below and have one port on the Procure 4000m set as a trunk and others tagged for one or both vlans.  My problem is that I cannot ping the router or ping between two machines on the same subnet.  Have I set something wrong or are these two pieces of equipment not capable of VLANs.

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname vlan

!

boot-start-marker

boot-end-marker

!

no logging console

enable secret 5 $1$n8Uj$a3V1.e1IewoOCwFoUYON7/

enable password xyz

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

ip cef

!

!

no ftp-server write-enable

!

!

interface FastEthernet0

no ip address

no ip split-horizon

speed auto

full-duplex

!

interface FastEthernet0.1

encapsulation dot1Q 1 native

ip address 172.16.1.1 255.255.255.0

no ip redirects

!

interface FastEthernet0.5

encapsulation dot1Q 5

ip address 172.16.5.1 255.255.255.0

no ip redirects

!

interface FastEthernet0.10

encapsulation dot1Q 10

ip address 172.16.10.1 255.255.255.0

no ip redirects

!

interface Serial0

no ip address

ip broadcast-address 0.0.0.0

shutdown

no cdp enable

!

ip classless

!

no ip http server

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

password xyz

login

!

end

6 Replies 6

Reza Sharifi
Hall of Fame
Hall of Fame

Not familar with HP, but is it configured correctly?

also

encapsulation dot1Q 1 native

can you remove native and try again.

HTH

Hi Jeremy,

Can you post the configuration of the HP ProCurve as well? The router seems to be configured correctly.

Reza: you wrote:

encapsulation dot1Q 1 native

can you remove native and try again.

This will probably not be possible: the native keyword is added automatically to that command. The native keyword would be removed only if a different VLAN was designated as the native VLAN on this tagged routed port.

Best regards,

Peter

Hi Peter,

You are correct, when you create sub-interface with dot1.q 1, it will add the native to it.

But you can delete vlan 1 with sub-inter 1 and add a different one.  In that case it does not add the native to any of the other sub-interfaces.

here I have 3 sub-interface with no native:

interface Ethernet1/0.20

encapsulation dot1Q 20

ip address 20.20.20.1 255.255.255.0

no snmp trap link-status

!

interface Ethernet1/0.30

encapsulation dot1Q 30

ip address 30.30.30.1 255.255.255.0

no snmp trap link-status

!

interface Ethernet1/0.40

encapsulation dot1Q 40

ip address 40.40.40.1 255.255.255.0

no snmp trap link-status

HTH

You are correct that the native keyword is added automatically.  I have tried it without interface fa0.1, just 5 and 10, but still no luck. 

As far as the procurve config, I don't know of a good way to show the config.  I have tried tagging ports to just 1, 2, and all three VLANS with no change.  I have the option to set the trunk to the following types.

– Trunk (Source Address/Destination Address trunk; the default type if you do not select a type)

– SA-Trunk (Source-Address trunk)

– FEC (Fast EtherChannel

trunk)

I have tried all three options with no luck on any.

can you try testing without trunking it?  In this way you just need an IP an the main interface with no sub-interface and configure the HP port as an access port with one vlan..

Reza,

I removed the sub interfaces and gave an ip to the main interface and that allows me to see the router thru the HP switch.

Thanks,

Jeremy

Review Cisco Networking for a $25 gift card