What would be the proper way to do this for those smaller sites?
Config:
Here is the config.
hostname Site_A
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
no ipv6 cef
ip auth-proxy max-login-attempts 5
ip admission max-login-attempts 5
!
!
!
ip dhcp excluded-address 10.13.16.0 10.13.16.100
!
ip dhcp pool Site_A
network 10.13.16.0 255.255.255.0
domain-name
dns-server 10.13.5.35 10.13.5.32
default-router 10.13.16.1
lease 60
!
!
ip cef
!
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
!
license udi pid CISCO1921/K9 sn FGL154720V6
!
!
!
redundancy
!
!
!
!
!
!
class-map match-any COS3-NON_Critical_APPS
match access-group name COS3-Traffic
class-map match-any COS2-Critical
match access-group name COS2-Traffic
class-map match-any COS1
match ip dscp ef
match protocol rtp
!
!
policy-map COS
class COS1
priority percent 20
set ip dscp ef
class COS2-Critical
bandwidth remaining percent 80
set ip dscp af31
class COS3-NON_Critical_APPS
bandwidth remaining percent 10
set ip dscp af21
policy-map CE_EGRESS_SHAPING
class class-default
shape average 9856000 39424 0
service-policy COS
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
duplex full
speed 100
service-policy output CE_EGRESS_SHAPING
!
interface GigabitEthernet0/0.50
description .AT&T CIRCUIT ID
encapsulation dot1Q 50
ip address 172.16.1.230 255.255.255.252
ip flow ingress
ip flow egress
!
interface GigabitEthernet0/1
ip address 10.13.16.1 255.255.255.0
duplex auto
speed auto
!
router bgp 65007
no bgp log-neighbor-changes
network 10.13.16.0 mask 255.255.255.0
neighbor 172.16.1.229 remote-as 13979
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
ip flow-export source GigabitEthernet0/0
ip flow-export version 5
ip flow-export destination 10.13.5.169 2055
!
!
ip access-list extended COS2-Traffic
permit tcp any host 10.13.5.132
permit tcp any host 10.13.5.37
permit tcp any host 10.13.5.51
permit tcp any host 10.13.5.116
permit tcp any host 10.13.5.90
ip access-list extended COS3-Traffic
permit tcp any host 10.13.200.10
permit tcp any host 10.13.5.67
!
!
!
snmp-server community NxCP21ac RO
snmp-server location Anywhere, AL
snmp-server contact
snmp-server enable traps tty
snmp-server enable traps entity-sensor threshold
!
control-plane
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password 2ckaMp79
login
transport input all
!
scheduler allocate 20000 1000
ntp server 10.13.5.35
!
end
Site_As#