cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1071
Views
0
Helpful
1
Replies
Beginner

VRF receive and VRF forwarding

Hello,

I have come across a strange issue in my network.

-Firstly i am trying to understand the difference between ip vrf receive and ip vrf forwarding.

-Secondly, i have an interface(FastEthernet1/0.101) in the right vrf forwarding table but i don’t see its IP in the routing table. Weird.

-Thirdly whenever the link to 10.54.68.22 goes down the 'IP vrf receive curriculum' disappears from the interface and it needs to be reapplied.

I looked for bugs, etc but cant find any information.

Configs as bleow.

Router is Cisco 7206VXR , IOS: c7200-k91p-mz.122-25.S5.

Configs :

emnewol#sh run int f1/1.101
Building configuration...

Current configuration : 223 bytes
!
interface FastEthernet1/1.101
description CKT149
bandwidth 10000
encapsulation dot1Q 101
ip vrf receive curriculum
ip address 10.54.68.21 255.255.255.252
ip policy route-map Native
end

emnewol#sh run int f1/0.101
Building configuration...

Current configuration : 201 bytes
!
interface FastEthernet1/0.101
description Curriculum VPN
encapsulation dot1Q 101
ip vrf forwarding curriculum
ip address 10.54.69.230 255.255.255.248
end

emnewol#sh ip route vrf curriculum

Routing Table: curriculum
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.20.10 to network 0.0.0.0

     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.8 is directly connected, GigabitEthernet0/1.50
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.54.68.20/30 is directly connected, FastEthernet1/1.101
S       10.61.149.0/24 [1/0] via 10.54.68.22
S*   0.0.0.0/0 [1/0] via 192.168.20.10
emnewol#

Everyone's tags (4)
1 REPLY 1
Highlighted
Beginner

VRF receive and VRF forwarding

Please ignore point 2 as the mentioned interface is down and that explains why its not in the routing table.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here