Introduction
This is a basic configuration example of Transparent Mode configuration on an ASA 5505. This configuration is only valid in version 8.4 and later since it utilizes bridge-groups.
Configuration Example
interface Ethernet0/0
switchport access vlan 10
!
interface Ethernet0/1
switchport access vlan 20
!
interface Vlan10
nameif outside
bridge-group 1
security-level 0
!
interface Vlan20
nameif inside
bridge-group 1
security-level 100
!
interface BVI1
ip address 10.10.10.10 255.255.255.0
!
route outside 0.0.0.0 0.0.0.0 10.10.10.1
route inside 192.168.1.0 255.255.255.0 10.10.10.254
!
http 0.0.0.0 0.0.0.0 inside
Notes
In order to enable ASDM access, the http command must be configured for a named interface. In the example above, access has been enabled for all IP addresses on the inside interface.
Routing is important in transparent mode to ensure inspection functionality. Many of the ASA's inspections rely on the routing table. In this example, there is a default route configured outside and a route to the 192.168.1.0/24 subnet configured inside.