Showing results for 
Search instead for 
Did you mean: 

Error using PPTP passthrough in RV180W


I am having a problem connecting to my office VPN from home since I changed my (home) router to the RV180W.

I am not using pre-configured tunnels, I just connect to the office VPN using the built-in Windows PPTP client when necessary.  I have a small network at home using the router in a NAT configuration on my static IP fibre DSL connection.

I had previously been able to connect using PPTP from either XP or Windows 7. Now I get "Error 732: Your computer and the remote computer could not agree on PPP control protocols".  Unfortunately I don't know what hardware or PPTP server is used at the office.

(I don't know if it is relevant but I have also configured the RV180 PPTP server to allow incoming VPN connections - this works fine. It doesn't make any difference to my issue whether it is enabled or not.)

Are there any known problems using Windows PPTP client through the router in a NAT configuration.  Is there anything I need to configure apart from enabling PPTP passthrough?

Any suggestions?  I'll have to revert back to my old router if I can't get this fixed!

Many thanks!

Edit: Just to clarify, the problem is making PPTP VPN connections from XP/Win7 on my home network over the internet to my office VPN/PPTP server, via the RV180W as my home router (using NAT/PAT).

Edit: More info.  Looks like the office VPN is a Microsoft RAS server on Windows 2008 behind a cisco PIX firewall.

Edit: Just to be sure, I swapped out the cisco RV180W for my old netgear router and I was immediately able to VPN again with no issue from both XP and Win7.  When I swapped the RV180W back in again, I was able to VPN from XP but not Win 7 so it looks as though the PPTP passthrough works occasionally but is intermittent. Just to be clear, the VPN is only intermittent using the RV180, it has always worked flawlessly on the other router so I don't think there is a problem with the internet connection or client/server configuration.

32 Replies 32


I've still not been able to get this to work. I have tried the following:

  1. Upgraded firmware to
  2. Factory reset
  3. Configured the minimum settings necessary to connect to my PPPoE fibre box and provide NAT gateway (LAN IP Checked that PPTP passthrough was enabled by default.
  4. Disabled antivirus on LAN Windows XP and Windows 7 machines
  5. Tested internet connections on both machines
  6. Attempted VPN PPTP connection from both XP and Windows 7 machines to office VPN server over internet - both failed.
  7. Replaced RV180 with Netgear WMV1000v3 (IP
  8. Attempted VPN PPTP connection again from both XP and Windows 7 machines - both succeeded.

As a seperate issue I noticed the RV180 PPTP server does not allow incoming connections from my Windows XP (SP3) VPN client although Windows 7 works.

Is the PPTP implementation on the RV180 broken?  Does anyone have this configuration working?

Just a quick update on this for anyone interested.  RV180W is still not working with PPTP passthrough (from my LAN out to the internet).

I have obtained a Belkin router which I have substituted in place of the RV180W and the VPN works fine.  This is the second router (in addition to the Netgear) that I have checked that works fine with PPTP VPN out of the box.

Some more info:

I am using the RV180W as a NAT router, connecting to my fibre broadband via PPPoE to a Huawei EchoLife HG612 FTTC modem (BT Openreach branded).

I am in contact with tech support but no solution as yet.


Have you been able to get the problem resolved.  I purchased the same unit a few days ago and am having the same problem.

Hello Ross,

Yea I was going to suggest to contact Cisco tech support to see if they have every ran into this issue or were able to test from there lab. I have this router as well but haven't test the PPTP passthrough. I've never heard of Cisco's small business routers having any issues with VPN passthrough but the fact that you have already tried with two different routers and it has worked out of the box is troublesome. Were the WAN and LAN ip address you used in the RV180w the same you used on your Netgear and Belkin routers?

The best way I could see to troubleshoot this at this point would be to enable logging in the RV180w router and run packet captures on the WAN and LAN side of the RV180w and see what is happening with the traffic. Also check logs on the PPTP server to see if they are even seeing the connection coming from you public.

Hope that helps,


Clayton Sill

Hi Brandon, Clayton

I'm afraid this issue has not been resolved.  I have also tried a 3rd router (BT Home Hub) on someone elses internet connection using the same laptop I cannot make work with the RV180W and once again the VPN connected straight away with no problems at all.  I only ever experience problems through the RV180W.  I have used the same IP address for each router I have tried so as far as I know the only variable is the router itself. I think the laptop had a static IP though I don't remember.

I have been in contact with tech support and have sent them the packet capture from the RV180W. They are able to confirm that the RV180 sends a WAN-side connection request to the PPTP server which elicits no reponse. They have successfully connected to my remote PPTP server from their lab through an RV180W although their configuration is not identical (I'm using PPPoE via a fibre modem, they are not).

The ball is back in my court and tech support are waiting on me to provide them with some configuration and some wireshark captures but I have not yet found time to do this.



To expand on the above, I tried the following on a friends internet connection (BT provider as opposed to my PlusNET):

  1. Connected my laptop to BT Home Hub router and connected successfully to remote PPTP VPN server
  2. Replaced BT Home Hub with Cisco RV180W (and configured it with my friends ISP details), note router IP address was already the same.
  3. Connected laptop to RV180W and checked internet connectivity
  4. Attempted to connect to PPTP VPN but failed.
  5. Replaced RV180W with BT Home Hub again and successfully connected to VPN

So in the course of my testing I have tried 3 different routers and 2 different internet connections and the VPN connects first time when any router other than the RV180W is used.

My RV180W configuration is simple - I did a factory reset then configured the bare minimum details for PPPoE with NAT routing.

Hello Ross,

Thanks for the upate. So when you took the router to your friends place, was it PPPoE you used or was it DHCP/Static IP? This is just strange though. There is no configuration that need to be made for PPTP VPN passthrough. So either there is some bug in the firmware or something is wrong with just that unit. I wish I could test my RV180w with PPPoE connection but don't have that option.

What has Cisco said about this so fare or have you gotten a update from them recently?

The only thing I can think of at this point that will help figure out where the issue is at is to look at the packet captures and see what is going on with the traffic.

Will be looking forward to a update from Cisco to see what they say though.


Clayton Sill

Hi Clayton,

The RV180W was using a PPPoE fibre internet connection at my friends house also, I just needed to change the login details. Additionally, the connection to the laptop was via ethernet cable to keep things simple.

Cisco were able to connect OK to my VPN server from their lab via RV180W though they cannot test via PPPoE.  I have sent them packet captures from the RV180W which shows a failed PPTP connection attempt WAN-side.  I suggested that if I can get some captures of successful connection attempts by the other routers we may be able to determine the difference. Unfortunately none of the other routers support packet-capture so I would need to set up a WAN-side wireshark capture from a PC.

Cisco have closed the case on this one as I have taken too long to respond (I'm too busy!).  They will reopen as and when I get back to them with further information and/or wireshark captures.  I'm not sure if/when I will get time to do this.  I was hoping that in the meantime, Cisco may establish on their own if there is a firmware problem here.

It would be great to know if other people are successfully connecting to remote/office PPTP VPN server from home via the RV180W using a NAT PPPoE fibre internet connection.




I have the same problem with a RV180W behind PPPoE (PPPoE is used for the WAN connection). VPN Passthough (outgoing VPN from a Windows client within the LAN) does not work for connecting to a Windows server in the WAN (using PPTP over GRE). With my old router it works. Other VPN connections (Cisco client using IPSec over UDP) also work.

I have installed the new beta firmware which solves the problem with port forwarding behind PPPoE. I assume there is another firmware bug which affects VPN passthrough behind PPPoE with PPTP/GRE.

I tried to switch off VPN passthrough and forward GRE to a dedicated computer. But when I disable VPN passthrough in the RV180W, outgoing TCP connections to Port 1723 are blocked. This is another bug.

Seems like a few people have seen an issue with this now.  Have you opened a support case?

It is really time for Cisco to test PPTP Passthough over PPPoE themselves.  I don't think there is going to be any movement on this issue until Cisco at least try to replicate the problem scenario. Tech Support couldn't test this when I spoke to them. Can an engineer try one on a UK domestic fibre connection or some other PPPoE WAN?

My RV180W is currently gathering dust in a shoe cupboard where its most useful purpose is to prevent cans of polish from migrating too far towards the back (where they are hard to reach).

OK, I have now obtained WAN and LAN wireshark captures of successful attempts with Netgear and Belkin routers and the unsucessful RV180W attempts.  These have been sent to tech support.

From what I can see from them, there is a problem with PPP LCP negotiation that only occurs when using the RV180W.

Hello Ross,

Thank you for the update. Glad to hear that they seemed to have found something. Hopefully will be getting a new firmware soon here. Probably due for one soon I would hope.


Clayton Sill


I have been following this thread for a while.  I am having the same issue and currently have an open support case.  I am using PPPoE on a DSL line.  I have submitted packet captures and have been told that they are working to replicate the issue.  Apparently  they have 1 lab with a similar connection.  One interesting thing I have noticed is that not all PPTP connections fail.  I have another RV180 in the field and I can connect to it through the RV180 I have at home.  However, when I try to VPN to work, I cannot connect.  It is good to see others are having the same problem.  I am working off firmware  I was told that there is a, but that it is not considered to be stable.

I've heard nothing regarding my support case in weeks and having owned the router for 6 months without being able to use it I have now given up.

I have bought a DLINK DIR 615 with DD-WRT firmware. I can now add this to the list of routers that just worked with PPTP VPN passthrough straight out of the box in my network:

  • Netgear WNR100v3 (£4)
  • Belkin F5D7234 (£15)
  • BT Home Hub (Free from ISP)
  • DLINK DIR 615 with DD-WRT (£25)

In fact, every other router I have tried just works. The RV180W (£140) is the only one that doesn't but I'm not seeing much appetite from Cisco for exploring why this might be the case.

Since the DD-WRT firmware has all the features I wanted from the RV180W, I will stick with this and live without the gigabit interface. Maybe one day the RV180W will be fixed and I'll dig it out again.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers