cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1748
Views
0
Helpful
4
Replies

MTU 9126 removes qos group 1

NaelShahid_2
Beginner
Beginner

Wanting to enable MTU 9216 on a Nexus 5548UP (vPC enabled) which also has hosts / storage attached via native FCoE.

Following these guidelines we found that the NetApp UCNA FC interfaces dropped out of the fabric and would no longer login.

After some troubleshooting we noticed that when running the "show queuing interface e1/x" command that qos group 1 (FCoE) was no longer visible on any interface. Also, under "system qos" “service-policy type network-qos fcoe-default-nq-policy” was missing. Reading the Cisco documentation it is clear this is required for the some of DCB parameters (FCoE) sent to the CNA.

After re applying “service-policy type network-qos fcoe-default-nq-policy” under "system qos" we checked the flogi database and immediately the NetApp FC interfaces logged into the fabric.

It seems that when applying "service-policy type network-qos jumbo" under "system qos" as followed exactly within the Cisco guide the “service-policy type network-qos fcoe-default-nq-policy” is overwritten and we lose qos group 1 from all interfaces which prevents the vfc’s from coming up, probably due to the missing DCB parameters.

We have checked and double checked this configuration for any possible errors.

We have a requirement to enable jumbo frames within this vPC domain so we are looking for assistance / help with this.

1 Accepted Solution

Accepted Solutions

Hi Nael

When you want to enable jumbo mtu alongwith enabling for FCoE service policies, please configure the below network-qos policy and let us know if this works

policy-map type network-qos fcoejumbopolicy 

  class type network-qos class-fcoe
   pause no-drop
   mtu 2158
  class type network-qos class-default
   mtu 9216

system qos
  service-policy type network-qos fcoejumbopolicy

When explicit jumbo network-qos policy is applied under system qos, then it will
override the default fcoe service policy. Hence you saw the problem where fcoe interfaces
went down. But with the above policy you should have both jumbo mtu and fcoe interfaces
up without any problem.

Thanks, Vinayak

View solution in original post

4 Replies 4

NaelShahid_2
Beginner
Beginner

also, NX-OS 5.1(3)N1(1a)

Hi Nael

When you want to enable jumbo mtu alongwith enabling for FCoE service policies, please configure the below network-qos policy and let us know if this works

policy-map type network-qos fcoejumbopolicy 

  class type network-qos class-fcoe
   pause no-drop
   mtu 2158
  class type network-qos class-default
   mtu 9216

system qos
  service-policy type network-qos fcoejumbopolicy

When explicit jumbo network-qos policy is applied under system qos, then it will
override the default fcoe service policy. Hence you saw the problem where fcoe interfaces
went down. But with the above policy you should have both jumbo mtu and fcoe interfaces
up without any problem.

Thanks, Vinayak

Thanks Vinayak, I will test this tomorrow and report back.

Hi Vinayak. Tested and works.

Many Thanks

PS: How are you with N1K QoS?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers