cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2729
Views
0
Helpful
6
Replies

[ISSUE]DHCP Client isn't recieving an ip address with ip helper-address configured

Niels.Postma
Beginner
Beginner

Hello people,

I have a problem implementing ip helper-address, my DHCP client isn't recieving an ip address from the DHCP server. I use a Windows Server 2008 as DHCP server.

I've configured a 2811 router as inter vlan router and 2960 switch with a trunk interface to the router, and a access switchport to the 'S-EMINENT01' switch.

I created three subinterfaces (with dot1q encapsulation):  

                                             FA0/0.1 (VLAN1, NATIVE) 172.16.0.1/16

                                              FA0/0.10 (VLAN10) 192.168.10.1/24

                                              FA0/0.15(VLAN15) 192.168.15.1/24

Windows Server 2008 DHCP scope:

                                             VLAN10: 192.168.10.1 - 192.168.10.254, excluded range: 192.168.10.1 - 192.168.10.9 /24

                                             VLAN15: 192.168.15.1 - 192.168.15.254, excluded range: 192.168.10.1 - 192.168.10.9 /24

When I configure a static ip address (192.168.10.10) on my DHCP client, I'm able to ping until the FA0/0.1 (172.16.0.1) interface, but I'm still getting no DHCP ip address.

When I configure it within packet tracer, there are no problems at all and the DHCP client recieve the ip address properly. But when I use the same config on physical hardware, it won't work.

Topologie overview:

Note: the S-EMINENT01 is a non-configurable switch.

topologie.PNG

Config's:

Router:

Current configuration : 1237 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

!

ip cef

!

!

multilink bundle-name authenticated

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

interface FastEthernet0/0

no ip address

ip helper-address 172.16.2.10

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 172.16.0.1 255.255.0.0

ip access-group 1 in

ip helper-address 172.16.2.10

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 192.168.10.1 255.255.255.0

ip access-group 1 in

ip helper-address 172.16.2.10

!

interface FastEthernet0/0.15

encapsulation dot1Q 15

ip address 192.168.15.1 255.255.255.0

ip access-group 1 in

ip helper-address 172.16.2.10

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

shutdown

no fair-queue

clock rate 125000

!

interface Serial0/0/1

no ip address

shutdown

clock rate 125000

!

ip forward-protocol nd

!

!

ip http server

!

access-list 1 permit any

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

login

!

scheduler allocate 20000 1000

!

end

Switch:

Current configuration : 1770 bytes

!

version 12.2

service config

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Switch

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

system mtu routing 1500

ip subnet-zero

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

!

interface FastEthernet0/1

switchport access vlan 10

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/2

switchport access vlan 15

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/2

switchport trunk allowed vlan 1,10,15

switchport mode trunk

spanning-tree portfast trunk

!

interface Vlan1

ip address dhcp

ip helper-address 172.16.2.10

no ip route-cache

!

interface Vlan10

no ip address

ip helper-address 172.16.2.10

no ip route-cache

!

interface Vlan15

no ip address

ip helper-address 172.16.2.10

no ip route-cache

!

ip http server

ip http secure-server

!

control-plane

!

!

line con 0

line vty 5 15

!

end

Does anybody have any suggestions or tips? Maybe someone could upload an example configuration for my situation?

6 Replies 6

Antonio Knox
Rising star
Rising star

Is the DHCP server pingable from the physical router?

Yes, the DHCP server is pingable.

Does your interface have:

no ip directed-broadcast

If not, it should.

EDIT: DUH!  I see the config is right here, my bad.  Please add 'no ip directed broadcast' to your interfaces.

Message was edited by: Antonio Knox

Okay, I added 'no ip directed-broadcast' to my physical and all sub -interfaces on my router.

Requested an DHCP ip address on my DHCP client, but still no result.

Have you enabled portfast on the access layer switchport?

spanning-tree portfast enable

And ensured that the host was set to automatically pick up an address (I know, silly question, but I have to ask)?

Hi,

Can you  get rid of SVIs on the 2960 except VLAN1 but configure this SVI manually then put f0/0.1 in the same subnet as your DHCP server( 172.16.2.0/24 I presume) and exclude this address as well as VLAN1 address from one of your scope.

Regards.

Alain.

Don't forget to rate helpful posts.
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers