cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
9424
Views
11
Helpful
6
Replies

Remove "no logging event link-status" from interface config

Patrick81
Beginner
Beginner

Hi everyone,

I'm a bit helpless, but how do I remove the "no logging event link-status" from an interface config?! If I add a "logging event link-status" to the interface, the line is explicitly added to the interface. I thought the globally enabled "logging event link-status" would have catched this, and the line would be not explicitlly added, because it is enabled globally.

 

switchport access vlan 402
switchport mode access
switchport nonegotiate
no logging event link-status
no snmp trap link-status
auto qos trust
spanning-tree portfast
spanning-tree bpduguard enable
spanning-tree guard root
service-policy input AutoQos-4.0-Trust-Cos-Input-Policy
service-policy output AutoQos-4.0-Output-Policy

Thanks in advance. :)

1 Accepted Solution

Accepted Solutions

Mark Malone
VIP Alumni
VIP Alumni
Hi
default the interface all in one command and reapply in same syntax is one way, just copy and paste the lot , with your int number
Its actually disabled when its set to no anyway

conf t
default int g1/1/9
int g1/1/9
switchport access vlan 402
switchport mode access
switchport nonegotiate
no snmp trap link-status
auto qos trust
spanning-tree portfast
spanning-tree bpduguard enable
spanning-tree guard root

View solution in original post

6 Replies 6

Mark Malone
VIP Alumni
VIP Alumni
Hi
default the interface all in one command and reapply in same syntax is one way, just copy and paste the lot , with your int number
Its actually disabled when its set to no anyway

conf t
default int g1/1/9
int g1/1/9
switchport access vlan 402
switchport mode access
switchport nonegotiate
no snmp trap link-status
auto qos trust
spanning-tree portfast
spanning-tree bpduguard enable
spanning-tree guard root

Hi Mark,

 

mew, okay. I tried this and I know that this is working. But it's an outage for each interface. An outage, just to save 22 or 44 lines in the config file. :) But thank you for confirmation!

 

Best regards,

Patrick

Yes its an odd one , i see this in the docs no matter what its retaining the syntax once applied for some reason even with No statement


DOC
If you enter both the logging event link-status default and the no logging event link-status boot commands, the interface state-change events are logged after all modules in the Cisco series router come online after system initialization. The logging event link-status default and the no logging event link-status boot commands are saved and retained in the running configuration of the system.

you can try:

 

int g1/0/1

 default logging event link-status

 

it will revert the command on the interface, but I don't know if it will show up in the config or not. this way you don't have to reconfig each interface, you're only resetting the command on that interface.

Hello @cmarva,

 

The command default logging event link-status works. It removes no logging event link-status from a port configuration of a running-config.

 

Thank you!

 

Best regards,

Danila

marce1000
VIP
VIP

 

 - Could you try setting the interface to default values (default int x/y) ; then re-configure with the (only) parameters you need.

 M.



-- ' 'Good body every evening' ' this sentence was once spotted on a logo at the entrance of a Weight Watchers Club !
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: