はじめに
このドキュメントでは AnyConnectの接続/切断時、配布されたブラウザのプロキシが復元される事例について紹介いたします。
本ドキュメントは以下のバージョンを用いて確認、作成しております。
ASA 9.14(2)13
AnyConnect 4.10.01075 for Windows
事象
AnyConnect接続/切断後、配布されたプロキシ情報がブラウザに残らず、
元のプロキシ情報に戻ります。
発生原因
ASAのグループポリシー中のmsie-proxy lockdownがEnableになっているためです。
msie-proxy lockdownがEnableの場合は、
DARTログにメッセージ「Internet browser proxy settings have been successfully restored.」が出力され、
配布されたプロキシ情報が復元されます。
解決策
msie-proxy lockdownをDisableに変更することで、解決可能です。
詳細な変更手順は以下コマンドリファレンスをご参照ください。
[Cisco ASA シリーズ コマンド リファレンス、I ~ R コマンド]
https://www.cisco.com/c/ja_jp/td/docs/security/asa/asa-command-reference/I-R/cmdref2/m4.html
参考情報
AC caching and improperly modifying PAC URL on VPN connect or disconnect with proxy lockdown enabled
https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvi72927