cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
2437
Views
16
Helpful
7
Replies
nstrech
Beginner

Unity Connection 9 Slow to Import Users (LDAP)

A new Unity Connection (9.1.1.2) install has been pointed at LDAP (MS Server 2012) to Import Users.  Pulling up the Import User page takes about 2-3min. Searching for users takes a few more min. So it takes a good 6-7min of waiting to select a single user to import, but it works.

- Everything else in CUC runs fast and the resources are not stressed

- We can ping the Domain Controller by IP and the LDAP setup points to the Domain Conroller by IP (So no DNS issue)

- Services and servers have been rebooted

Any ideas why this would be so slow?

7 REPLIES 7
Jaime Valencia
Hall of Fame Cisco Employee

Probably because it's not supported and tested

Requirements for an LDAP Directory Integration

http://www.cisco.com/en/US/docs/voice_ip_comm/connection/9x/requirements/9xcucsysreqs.html

No way to tell you what might be wrong as the BU never tested such scenario.

Use a supported LDAP and it should work as expected.

HTH

java

if this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate

Solved…

Our intention was to sync CUC Users with LDAP, we had the correct settings under (System Settings > LDAP) but the Import User pagers were painfully slow to navigate.  It turns out another coworker had jumped in there and tried to configure the CUCM AXL integration.  Once I cleared out the unnecessary AXL configurations the LDAP Import User works as expected.

The unwanted AXL settings were found here:

(Telephony Integrations > Phone System > ‘YourPhoneSystem’ > Edit > Cisco Unified Communications Manager AXL Services)

CUCM and CUC 9.1.1 both seem to sync LDAP with Windows Server 2012 just fine.

Thanks,

Nate

thanks nate

that was my problem too!

christian

i fixed mine issue on CUC 9.1.2 by removed the invalid AXL servers. Also check to see if system is using the correct CUCM AXL port 8443 

Had same problem too.  Thank you.

 

 

Hey nstrech, exact same problem, so used your guide to diagnose what was going on, turns out in my case, couldn't send a test axl message to the subscriber only the publisher. Restarted TomCat on the subscriber and it came back to life.

 

Thanks!

I know it's been a while, so you may not remember, but where there any adverse effects to removing those AXL configurations?  I recently took over a system with this problem.  As far as I can tell, all users are LDAP synchronized, but the import users page does list the phone system, and it is configured for AXL with all users associated to it.  I obviously don't want to just delete it, because I don't know why it's there or what adverse effects it may have if I delete it.

Create
Recognize Your Peers
Content for Community-Ad