01-18-2005 11:53 AM
Anyone have a config on how to get this configured to work on a Qwest.Net business ADSL Line?
Qwest Tech support is not being very helpful...
01-18-2005 01:58 PM
Hello,
can you post what you have configured so far, if possible ? What is your specific problem ? Check this sample config for the 837:
version 12.3
!
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cisco837
!
boot-start-marker
!
boot-end-marker
logging buffered 51200 warnings
!
enable secret 5 xxxxxxxxxxx!
!
username admin privilege 15 password 0 XXXXXX
!
clock timezone PCTimeZone 11
!
ip subnet-zero
no ip source-route
no ip domain lookup
ip domain name xxxxx.nc
ip name-server X.X.X.X
ip name-server X.X.X.X
!
interface Ethernet0
ip address 192.168.10.254 255.255.255.0
ip nat inside
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
pvc 8/35
pppoe-client dial-pool-number 1
!
interface Dialer0
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname XXXX@yyyy,zz
ppp chap password 0 XXXXX
!
ip nat inside source list qinterface Dialer0 overload
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
access-list 1 permit 192.168.10.0
!
ip http server
ip http authentication local
ip http secure-server
!
dialer-list 1 protocol ip permit
!
line con 0
transport preferred all
transport output all
line aux 0
transport preferred all
transport output all
line vty 0 4
privilege level 15
login local
Regards,
GP
01-19-2005 06:24 AM
This is my first ADSL configuration. I have no idea if the ATM PVC is correct or not. I found some of this config off of DSL Reports.com...
Building configuration...
Current configuration : 3961 bytes
!
version 12.3
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug uptime
service timestamps log datetime localtime
service password-encryption
!
hostname xxx
!
logging buffered 16384 informational
enable password xxx
!
aaa new-model
!
!
aaa authentication login default group radius enable
aaa authentication login no_radius enable
aaa authorization exec default if-authenticated group radius
aaa authorization exec no_radius none
aaa accounting exec default start-stop group radius
aaa session-id common
ip subnet-zero
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool CLIENT
import all
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server xx xx
domain-name
lease 0 2
!
!
ip audit notify log
ip audit po max-events 100
no ftp-server write-enable
!
!
!
!
crypto isakmp policy 11
hash md5
authentication pre-share
group 2
crypto isakmp key 0 xxx address xxxx
!
!
crypto ipsec transform-set xxxx esp-des esp-md5-hmac
!
crypto map nolan 11 ipsec-isakmp
set peer xxx
set transform-set xxxx
match address 120
!
!
!
!
interface Null0
no ip unreachables
!
interface Ethernet0
description $ETH-LAN$Internal
ip address 10.10.10.1 255.255.255.0
crypto map nolan
hold-queue 100 out
!
interface ATM0
description DSL WAN
no ip address
atm ilmi-keepalive
pvc 0/32
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer1
ip address xx 255.255.255.248
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp chap hostname xx
ppp chap password 7 xx
ppp pap sent-username xx password 7 xx
!
ip default-gateway 10.10.10.1
ip nat inside source list 102 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
no ip http server
no ip http secure-server
!
logging trap errors
logging 10.200.103.212
access-list 102 deny tcp any any range 135 139
access-list 102 deny udp any any range 135 netbios-ss
access-list 102 deny tcp any range 135 139 any
access-list 102 deny udp any range 135 netbios-ss any
access-list 102 permit ip 10.10.10.0 0.0.0.255 any
access-list 102 deny ip any any
access-list 120 permit ip 10.10.10.0 0.0.0.255 host 10.200.103.212
access-list 120 permit ip 10.10.10.0 0.0.0.255 host 10.200.103.11
access-list 120 permit ip 10.10.10.0 0.0.0.255 host 10.200.103.22
access-list 120 permit ip 10.10.10.0 0.0.0.255 host 10.200.100.13
access-list 120 permit ip 10.10.10.0 0.0.0.255 host xx
radius-server host xx auth-port 1900 acct-port 1901
radius-server key xx
banner motd ^C
This system is for the use of authorized users only.
Individuals using this computer system without authority,
or in excess of their authority, are subject to having all
of their activities on this system monitored and recorded
by systems personnel. In the course of monitoring individuals
improperly using this system, or in the course of system
maintenance, the activities of authorized users may also be
monitored. Anyone using this system expressly consents to
such monitoring and is advised that if such monitoring reveals
possible criminal activity or policy violation, system personnel
may provide the evidence of such monitoring to law enforcement or
other officials.^C
!
line con 0
exec-timeout 120 0
no modem enable
stopbits 1
line aux 0
line vty 0 4
exec-timeout 120 0
password xxxx
length 0
!
scheduler max-task-time 5000
!
end
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide