cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1698
Views
5
Helpful
14
Replies

ASA-5525: command "migrate l2l" questions...

Hello.

In an ASA5525 there exist 2 IKEv1 tunnels that need migration to IKEv2. Some literature is below...

Swift Migration of IKEv1 to IKEv2 L2L Tunnel Configuration on ASA 8.4 Code - Cisco

Migration Overview
If your IKEv1, or even SSL, configuration already exists, the ASA makes the migration process simple. On the command line, enter the migrate command:

migrate {l2l | remote-access {ikev2 | ssl} | overwrite}

-----

QUESTIONS:

1. Will this single command change BOTH tunnels?

2. Doesn't the remote peer need to also do this or the tunnel will not work?

3. Is it possible to execute this on only 1 tunnel while leaving the others at IKEv1?

Thank you.

2 Accepted Solutions

Accepted Solutions

@jmaxwellUSAF IKEv2 must be enabled on the outside interface, if not already done so - crypto ikev2 enable <INTERFACE NAME>  

 DH group 5 is too weak and depreciated in new ASA versions, consider something stronger > 19, 20, 21.

View solution in original post

Sorry I was thinking that this postponed later.

Anyway 

Note:-

1- you can keep config if you need it later' 

How can i disable ikev1?

Disable ikev1 in outside interface BUT if you have other tunnel that run ikev1 then dont disable it instead go to

2- remove acl from crpyto map ikev1 for vp  you want to disable.

 

3- select group which match in both peer

4- that all I need for ikev2?

Yes that all commands needed except you missing enabe ikev2 in outside interface 

View solution in original post

14 Replies 14

as I mention before in your previous post, why you not config IKEv2 manually, 
I dont prefer migration process. 
and for one or two IKEv1 I think it will migration both since the command not give you option to select the IKEv1 peer. 

Ok, what is practical procedure to migrate manually in production environment?...

1. Can I maintain 1st tunnel while turning on second tunnel? If they both use same IP addresses, wont that be impossible?

2. Must I configure second outside interface?

(If 2nd tunnel doesn't succeed, that means I need troubleshoot in difficult limited maintenance window.)

What is practical procedure to migrate manually in production environment?

1. Can I maintain 1st tunnel while turning on second tunnel? If they both use same IP addresses, wont that be impossible?
Yes you can run both IKEv1 and IKEv2 in same ASA as soon as the Peer IP is different. 

2. Must I configure second outside interface?
No you can enable IKEv1 and IKEv2 in same OUTside interface  

OK, so I must add a second IP address on the same outside interface?

second IP for interface ?

First you say "as the peer IP is different", then you say "second IP for interface ?"

Where do we place these NEW DIFFERENT IP ADDRESSES?? On NEW INTERFACES?

All interfaces are in use.

 

 

crypto map l2lmap 10 set peer <Peer with IKEv1>
crypto map l2lmap 20 set peer <Peer with IKEv2>

 

this lab I run before take look how I config both IKEv1 and IKEv2 under same OUT interface 

Screenshot (365).png

ciscoasa# show running-config
: Saved

:
: Serial Number: 9AWQATWDSTJ
: Hardware: ASAv, 2048 MB RAM, CPU Pentium II 3699 MHz
:
ASA Version 9.8(1)
!
hostname ciscoasa
enable password $sha512$5000$6/mKa4M/vwJILrREaS24Xw==$4lnaR4TzHRY3fpycv2GF6g== pbkdf2
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
names

!
interface GigabitEthernet0/0
nameif OUT
security-level 0
ip address 100.0.0.1 255.255.255.0
!
interface GigabitEthernet0/1
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/4
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/5
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/6
nameif IN
security-level 100
ip address 10.0.0.1 255.255.255.0
!
interface Management0/0
shutdown
no nameif
no security-level
no ip address
!
ftp mode passive
access-list l2laclikev1 extended permit ip 10.0.0.0 255.255.255.0 30.0.0.0 255.255.255.0
access-list l2laclikev2 extended permit ip 10.0.0.0 255.255.255.0 20.0.0.0 255.255.255.0
pager lines 23
mtu OUT 1500
mtu IN 1500
no failover
no monitor-interface service-module
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
arp rate-limit 8192
route OUT 0.0.0.0 0.0.0.0 100.0.0.10 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 sctp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
timeout conn-holddown 0:00:15
timeout igp stale-route 0:01:10
user-identity default-domain LOCAL
aaa authentication telnet console LOCAL
aaa authentication login-history
no snmp-server location
no snmp-server contact
crypto ipsec ikev1 transform-set mhm esp-des esp-sha-hmac
crypto ipsec ikev2 ipsec-proposal mhm
protocol esp encryption des
protocol esp integrity md5
crypto ipsec security-association pmtu-aging infinite
crypto map l2lmap 10 match address l2laclikev2
crypto map l2lmap 10 set peer 200.0.0.3
crypto map l2lmap 10 set ikev2 ipsec-proposal mhm
crypto map l2lmap 20 match address l2laclikev1
crypto map l2lmap 20 set peer 150.0.0.2
crypto map l2lmap 20 set ikev1 transform-set mhm
crypto map l2lmap interface OUT
crypto ca trustpoint _SmartCallHome_ServerCA
no validation-usage
crl configure
crypto ca trustpool policy
auto-import
crypto ca certificate chain _SmartCallHome_ServerCA
certificate ca 18dad19e267de8bb4a2158cdcc6b3b4a
308204d3 308203bb a0030201 02021018 dad19e26 7de8bb4a 2158cdcc 6b3b4a30
0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d30
36313130 38303030 3030305a 170d3336 30373136 32333539 35395a30 81ca310b
30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
74776f72 6b313a30 38060355 040b1331 28632920 32303036 20566572 69536967
6e2c2049 6e632e20 2d20466f 72206175 74686f72 697a6564 20757365 206f6e6c
79314530 43060355 0403133c 56657269 5369676e 20436c61 73732033 20507562
6c696320 5072696d 61727920 43657274 69666963 6174696f 6e204175 74686f72
69747920 2d204735 30820122 300d0609 2a864886 f70d0101 01050003 82010f00
3082010a 02820101 00af2408 08297a35 9e600caa e74b3b4e dc7cbc3c 451cbb2b
e0fe2902 f95708a3 64851527 f5f1adc8 31895d22 e82aaaa6 42b38ff8 b955b7b1
b74bb3fe 8f7e0757 ecef43db 66621561 cf600da4 d8def8e0 c362083d 5413eb49
ca595485 26e52b8f 1b9febf5 a191c233 49d84363 6a524bd2 8fe87051 4dd18969
7bc770f6 b3dc1274 db7b5d4b 56d396bf 1577a1b0 f4a225f2 af1c9267 18e5f406
04ef90b9 e400e4dd 3ab519ff 02baf43c eee08beb 378becf4 d7acf2f6 f03dafdd
75913319 1d1c40cb 74241921 93d914fe ac2a52c7 8fd50449 e48d6347 883c6983
cbfe47bd 2b7e4fc5 95ae0e9d d4d143c0 6773e314 087ee53f 9f73b833 0acf5d3f
3487968a ee53e825 15020301 0001a381 b23081af 300f0603 551d1301 01ff0405
30030101 ff300e06 03551d0f 0101ff04 04030201 06306d06 082b0601 05050701
0c046130 5fa15da0 5b305930 57305516 09696d61 67652f67 69663021 301f3007
06052b0e 03021a04 148fe5d3 1a86ac8d 8e6bc3cf 806ad448 182c7b19 2e302516
23687474 703a2f2f 6c6f676f 2e766572 69736967 6e2e636f 6d2f7673 6c6f676f
2e676966 301d0603 551d0e04 1604147f d365a7c2 ddecbbf0 3009f343 39fa02af
33313330 0d06092a 864886f7 0d010105 05000382 01010093 244a305f 62cfd81a
982f3dea dc992dbd 77f6a579 2238ecc4 a7a07812 ad620e45 7064c5e7 97662d98
097e5faf d6cc2865 f201aa08 1a47def9 f97c925a 0869200d d93e6d6e 3c0d6ed8
e6069140 18b9f8c1 eddfdb41 aae09620 c9cd6415 3881c994 eea28429 0b136f8e
db0cdd25 02dba48b 1944d241 7a05694a 584f60ca 7e826a0b 02aa2517 39b5db7f
e784652a 958abd86 de5e8116 832d10cc defda882 2a6d281f 0d0bc4e5 e71a2619
e1f4116f 10b595fc e7420532 dbce9d51 5e28b69e 85d35bef a57d4540 728eb70e
6b0e06fb 33354871 b89d278b c4655f0d 86769c44 7af6955c f65d3208 33a454b6
183f685c f2424a85 3854835f d1e82cf2 ac11d6a8 ed636a
quit
crypto ikev2 policy 10
encryption des
integrity md5
group 5
prf sha
lifetime seconds 86400
crypto ikev2 enable OUT
crypto ikev1 enable OUT
crypto ikev1 policy 10
authentication pre-share
encryption des
hash md5
group 2
lifetime 86400
telnet 0.0.0.0 0.0.0.0 IN
telnet timeout 5
ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
group-policy ikev1 internal
group-policy ikev1 attributes
vpn-tunnel-protocol ikev1
group-policy ikev2 internal
group-policy ikev2 attributes
vpn-tunnel-protocol ikev2
dynamic-access-policy-record DfltAccessPolicy
username mhm password $sha512$5000$M/caEYbOVkTHPKKokqDqog==$a/pEf3/pj4IjsN8KBIOW0g== pbkdf2
tunnel-group 200.0.0.3 type ipsec-l2l
tunnel-group 200.0.0.3 general-attributes
default-group-policy ikev2
tunnel-group 200.0.0.3 ipsec-attributes
ikev2 remote-authentication pre-shared-key *****
ikev2 local-authentication pre-shared-key *****
tunnel-group 150.0.0.2 type ipsec-l2l
tunnel-group 150.0.0.2 general-attributes
default-group-policy ikev1
tunnel-group 150.0.0.2 ipsec-attributes
ikev1 pre-shared-key *****
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
no tcp-inspection
policy-map global_policy
class inspection_default
inspect ip-options
inspect netbios
inspect rtsp
inspect sunrpc
inspect tftp
inspect xdmcp
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect esmtp
inspect sqlnet
inspect sip
inspect skinny
inspect icmp
policy-map type inspect dns migrated_dns_map_2
parameters
message-length maximum client auto
message-length maximum 512
no tcp-inspection
policy-map type inspect dns migrated_dns_map_1
parameters
message-length maximum client auto
message-length maximum 512
no tcp-inspection
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
call-home
profile CiscoTAC-1
no active
destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
destination address email callhome@cisco.com
destination transport-method http
subscribe-to-alert-group diagnostic
subscribe-to-alert-group environment
subscribe-to-alert-group inventory periodic monthly
subscribe-to-alert-group configuration periodic monthly
subscribe-to-alert-group telemetry periodic daily
profile License
destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
destination transport-method http
Cryptochecksum:991cb91e165bc65e09d5d9b3e4a7c27b

Hi MHM.

1. May you please confirm that the below added config is all I need to erect the new IKEv2 tunnel? 

2. Once this tunnel is tested successful, may I remove the other IKEv1 specific config?

Thank you.

-----

-Create the ISAKMP policy
!!! add #crypto ikev2 policy
!!! add #encryption aes-256
!!! add #integrity sha-256
!!! add #group 5
!!! add #prf sha-256
!!! add #lifetime seconds 86400

-Set tunnel group and tunnel type
#tunnel-group 15.0.0.8 type ipsec-l2l
#tunnel-group 15.0.0.8 ipsec-attributes
!!! add #ikev2 local-authentication pre-shared-key mYkEy%$
!!! add #ikev2 remote-authentication pre-shared-key mYkEy%$

-Define the IPsec policy
!!! add #crypto ipsec ikev2 ipsec-proposal VENDOR1-PROPOSAL-2
!!! add #protocol esp encryption aes-256
!!! add #protocol esp integrity sha-512

-Configure the crypto map.
#crypto map VENDOR1-cryptomap-1 interface outside1
#crypto map VENDOR1-cryptomap-1 1 match address VENDOR1-Cryptomap-ACL
#crypto map VENDOR1-cryptomap-1 1 set peer 15.0.0.8
#crypto map VENDOR1-cryptomap-1 1 set ikev1 ipsec-proposal VENDOR1-PROPOSAL-1
!!! add #crypto map VENDOR1-cryptomap-1 2 set IKEv2 ipsec-proposal VENDOR1-PROPOSAL-2

Configure Internal Group Policy & attributes.
!!! add #group-policy IKEv2-15.0.0.8 internal
!!! add #group-policy IKEv2-15.0.0.8 internal
!!! add #vpn-tunnel-protocol ikev2
!!! add #pfs enable

Hi MHM.

1. May you please confirm that the below added config is all I need to erect the new IKEv2 tunnel? 

2. Once this tunnel is tested successful, may I remove the other IKEv1 specific config?

Thank you.

-----

-Create the ISAKMP policy
!!! add #crypto ikev2 policy
!!! add #encryption aes-256
!!! add #integrity sha-256
!!! add #group 5
!!! add #prf sha-256
!!! add #lifetime seconds 86400

-Set tunnel group and tunnel type
#tunnel-group 15.0.0.8 type ipsec-l2l
#tunnel-group 15.0.0.8 ipsec-attributes
!!! add #ikev2 local-authentication pre-shared-key mYkEy%$
!!! add #ikev2 remote-authentication pre-shared-key mYkEy%$

-Define the IPsec policy
!!! add #crypto ipsec ikev2 ipsec-proposal VENDOR1-PROPOSAL-2
!!! add #protocol esp encryption aes-256
!!! add #protocol esp integrity sha-512

-Configure the crypto map.
#crypto map VENDOR1-cryptomap-1 interface outside1
#crypto map VENDOR1-cryptomap-1 1 match address VENDOR1-Cryptomap-ACL
#crypto map VENDOR1-cryptomap-1 1 set peer 15.0.0.8
#crypto map VENDOR1-cryptomap-1 1 set ikev1 ipsec-proposal VENDOR1-PROPOSAL-1
!!! add #crypto map VENDOR1-cryptomap-1 2 set IKEv2 ipsec-proposal VENDOR1-PROPOSAL-2

Configure Internal Group Policy & attributes.
!!! add #group-policy IKEv2-15.0.0.8 internal
!!! add #group-policy IKEv2-15.0.0.8 internal
!!! add #vpn-tunnel-protocol ikev2
!!! add #pfs enable

@jmaxwellUSAF IKEv2 must be enabled on the outside interface, if not already done so - crypto ikev2 enable <INTERFACE NAME>  

 DH group 5 is too weak and depreciated in new ASA versions, consider something stronger > 19, 20, 21.

Sorry I was thinking that this postponed later.

Anyway 

Note:-

1- you can keep config if you need it later' 

How can i disable ikev1?

Disable ikev1 in outside interface BUT if you have other tunnel that run ikev1 then dont disable it instead go to

2- remove acl from crpyto map ikev1 for vp  you want to disable.

 

3- select group which match in both peer

4- that all I need for ikev2?

Yes that all commands needed except you missing enabe ikev2 in outside interface 

Technically speaking, is this actually the same tunnel?

When both IKEv1 and IKEv2 are configured, what traffic is using which cryptomap? 

How do i confirm that traffic is using IKEv2?

Thank you.

Ok I will try all same IP addresses with this 2 different commands...

crypto map l2lmap 10 set peer <Peer with IKEv1>
crypto map l2lmap 20 set peer <Peer with IKEv2>

I will confirm solution if tunnel is up. This will not execute for a few days.

Thank you.