cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
788
Views
12
Helpful
14
Replies

configuring multiple VPN peers on a pix 501 6.3 (4)

killroy
Level 1
Level 1

Hi

Im new in the pix 501 configing in the cli.

How do I config more then one VPN peer.

Can anybody help me with a blueprint or a link??

14 Replies 14

jmia
Level 7
Level 7

Bertil,

Basically all you need to do to add a new peer (tunnel) is to setup the relevant crypto ACL's and the corresponding crypto map, like below.

You can do all this on a notepad first and then just paste back in to the PIX in config mode. The reason I have added two crypto ACL's for the same LAN and peer is so that if you run PDM then the PDM will not function properly, PDM does not like same statements in two diffrent places so you need to seprate then out (as below).

Ofcourse make sure that the remote peer PIX has the similar setup.

Save with: write mem

Example:

access-list nonat permit ip 255.255.255.0 255.255.255.0

access-list nonat permit ip 255.255.255.0 255.255.255.0

access-list 100 permit ip 255.255.255.0 255.255.255.0

access-list 200 permit ip 255.255.255.0 255.255.255.0

nat (inside) 0 access-list nonat

sysopt connection permit-ipsec

crypto ipsec transform-set esp-3des esp-md5-hmac

crypto map 10 ipsec-isakmp

crypto map 10 match address 100

crypto map 10 set peer

crypto map 10 set transform-set

crypto map 20 ipsec-isakmp

crypto map 20 match address 200

crypto map 20 set peer

crypto map 20 set transform-set

crypto map interface outside

isakmp enable outside

isakmp key address netmask 255.255.255.255

isakmp key address netmask 255.255.255.255

isakmp identity address

isakmp policy 1 authentication pre-share

isakmp policy 1 encryption 3des

isakmp policy 1 hash md5

isakmp policy 1 group 2

isakmp policy 1 lifetime 86400

If you are not experienced to use the CLI then I would suggest that you setup you VPN tunnels using the Pix Device Manager (PDM) VPN wizard.

Hope this helps and let me know how you get on - please remember to rate post as others might be looking for similar answer.

Jay

Thanks Jay

My config was cloes (I think)

What if there is peers whith different isakmp:s

My config. Any improvments???

PIX Version 6.3(4)

...

names

access-list nonat permit ip x.x.x.x 255.255.255.x x.x.x.x 255.255.255.x

access-list nonat permit ip x.x.x.x 255.255.255.x x.x.x.x 255.255.255.x

access-list nonat permit ip x.x.x.x 255.255.255.x x.x.x.x 255.255.255.x

access-list nonat permit ip x.x.x.x 255.255.255.x x.x.x.x 255.255.255.x

access-list IPSEC-abc permit ip x.x.x.x 255.255.255.x x.x.x.x 255.255.255.x

access-list IPSEC-abc permit ip x.x.x.x 255.255.255.x x.x.x.x 255.255.255.x

access-list IPSEC-abc permit ip x.x.x.x 255.255.255.x x.x.x.x 255.255.255.x

access-list IPSEC-def permit ip x.x.x.x 255.255.255.x x.x.x.x 255.255.255.x

!

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside x.x.x.x 255.255.255.255 pppoe setroute

ip address inside x.x.x.x 255.255.255.x

ip audit info action alarm

ip audit attack action alarm

pdm location x.x.x.x x.x.x.x inside

pdm location x.x.x.x x.x.x.x inside

pdm history enable

arp timeout 14400

!

global (outside) 10 interface

nat (inside) 0 access-list nonat

nat (inside) 10 0.0.0.0 0.0.0.0 0 0

!

!conduit permit icmp any any

!

route outside 0.0.0.0 0.0.0.0 x.x.x.x 1

!

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server RADIUS protocol radius

aaa-server LOCAL protocol local

ntp server 62.119.40.98 source outside prefer

ntp server 62.119.40.99 source outside

http server enable

http x.x.x.x x.x.x.x inside

http x.x.x.x x.x.x.x inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

username xx password xx

username xx privilege 15

!

!

sysopt connection permit-ipsec

crypto ipsec transform-set proposal1 esp-3des esp-sha-hmac

crypto ipsec transform-set proposal2 esp-des esp-md5

!

crypto map abc 10 ipsec-isakmp

crypto map abc 10 match address IPSEC-abc

crypto map abc 10 set peer x.x.x.x

crypto map abc 10 set transform-set proposal1

crypto map abc interface outside

!

crypto map def 20 ipsec-isakmp

crypto map def 20 match address IPSEC-def

crypto map def 20 set peer x.x.x.x

crypto map def 20 set transform-set proposal2

crypto map def interface outside

!

isakmp enable outside

isakmp key **sa address x.x.x.x netmask 255.255.255.255

isakmp key **sa address x.x.x.x netmask 255.255.255.255

isakmp identity address

isakmp policy 5 authentication pre-share

isakmp policy 5 encryption 3des

isakmp policy 5 hash md5

isakmp policy 5 group 2

isakmp policy 5 lifetime 86400

console timeout 5

!

dhcpd address x.x.x.x-x.x.x.x inside

dhcpd dns X.X.X.X x.x.x.x

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd domain xx

dhcpd enable inside

username xx password xx privilege 15

vpdn group pppoe_group request dialout pppoe

vpdn group pppoe_group localname xx

vpdn group pppoe_group ppp authentication chap

vpdn username xxx password xxx

!

Hi,

As long as your peer firewalls have the corresponding statement applied then you should be good to go.

Is your peer firewalls also PIX box?

You can check if the tunnels have come up by issuing : sho isakmp sa

Also, it's not a good idea to use 'conduit statements' as these are now phased out! also do you need to use des? why not 3des for your 2nd propsal? If you have all PIX boxes as peers and running code 6.3(4) then just use the example I've given you and you should be OK.

Let me know how you get on, and please rate post.

Hi Jay

My peer is a 2611 mmm very nice to work with.

Yes you´re right "conduit" does´nt work.

I´ve put up my pix in a lab envirement.

Ive tried to ping the ISP from the pix. but nothing happends. I can see the isp in the "arp".

Putted in

icmp permit x.x.x.x 255.255.255.248 outside

icmp permit x.x.x.x 255.255.0.0 inside

but nnoooo nothing.

Seems like there is no contection

There is no negotiation.

Hmmmmm.

If you have ide´s

Im trubleshooting away.

Ah,ha so your peer is a router - am I correct and your trying to setup VPN tunnel between router and PIX, if so take a read of the following document:

http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a0080094498.shtml

And please rate post if it helps and this gives me an indication that I'm providing the correct information and that others might be looking for similar feedback.

Thanks,

Jay

Thanks for all help so far.

But.......... it won`t play

If you can find anything missing in my labconfig.

Please feel free.

PIX Version 6.3(4)

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password x encrypted

passwd x encrypted

hostname x

domain-name x

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol ils 389

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list nonat permit ip x.x.x.x 255.255.255.224 x.x.x.x 255.255.252.0

access-list IPSEC-abc permit ip x.x.x.x 255.255.255.224 x.x.x.x 255.255.252.0

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside x.x.x.x 255.255.255.248

ip address inside x.x.x.x 255.255.255.224

ip audit info action alarm

ip audit attack action alarm

pdm location x.x.x.x 255.255.255.224 inside

pdm location x.x.x.x 255.255.240.0 inside

pdm location x.x.x.x 255.255.255.0 outside

pdm history enable

arp timeout 14400

global (outside) 10 interface

nat (inside) 0 access-list nonat

nat (inside) 10 0.0.0.0 0.0.0.0 0 0

conduit permit icmp any any

route outside 0.0.0.0 0.0.0.0 x.x.x.x 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

ntp server 62.119.40.98 source outside prefer

ntp server 62.119.40.99 source outside

http server enable

http x.x.x.x 255.255.255.255 outside

http x.x.x.x 255.255.255.240 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set proposal1 esp-3des esp-sha-hmac

crypto map wer 10 ipsec-isakmp

! Incomplete

crypto map wer 10 ipsec-isakmp

crypto map wer 10 match address IPSEC-abc

crypto map wer 10 set peer x.x.x.x

crypto map wer 10 set transform-set proposal1

crypto map wer interface outside

isakmp enable outside

isakmp key ************ address x.x.x.x netmask 255.255.255.255

isakmp identity address

isakmp policy 5 authentication pre-share

isakmp policy 5 encryption 3des

isakmp policy 5 hash md5

isakmp policy 5 group 2

isakmp policy 5 lifetime 86400

telnet timeout 5

ssh timeout 5

console timeout 5

crypto map wer 10 ipsec-isakmp

! Incomplete

crypto map wer 10 ipsec-isakmp

crypto map wer 10 match address IPSEC-abc

crypto map wer 10 set peer x.x.x.x

crypto map wer 10 set transform-set proposal1

crypto map wer 10 is duplicated.

Yep

They looked the same?!?!??

The tunnel is up but I cant get any traffic going thrue.................Is there anything missing in the config or

Time for debuging is ip en

The tunnel is up but no traffic is going thrue

Message from the pix

ISADB: reaper checking SA 0xa17e5c, conn_id = 0

ISADB: reaper checking SA 0xa17e5c, conn_id = 0

ISADB: reaper checking SA 0xa17e5c, conn_id = 0

ISADB: reaper checking SA 0xa17e5c, conn_id = 0

ISADB: reaper checking SA 0xa17e5c, conn_id = 0

ISADB: reaper checking SA 0xa17e5c, conn_id = 0

ISADB: reaper checking SA 0xa17e5c, conn_id = 0

ISADB: reaper checking SA 0xa17e5c, conn_id = 0

What have I missed!??!?!?

Post your current IOS and PIX configurations. That error there might be just a failed negotiation.

use debug crypto ipsec and debug crypto isakmp if you have not already.

What does a show crypto ipsec sa look like? show isakmp sa?

You have the pix config in this tree. I dont think its the 2600. I tried with a 1700 insted of the pic and it worked.

Here is the debug befor it "goes to lunch"

ISAKMP: transform 1, ESP_3DES

ISAKMP: attributes in transform:

ISAKMP: encaps is 1

ISAKMP: SA life type in seconds

ISAKMP: SA life duration (basic) of 28800

ISAKMP: SA life type in kilobytes

ISAKMP: SA life duration (VPI) of 0x0 0x46 0x50 0x0

ISAKMP: authenticator is HMAC-SHA

ISAKMP (0): atts are acceptable.IPSEC(validate_proposal_request): proposal part

#1,

(key eng. msg.) dest= x.x.x.x, src= x.x.x.x,

dest_proxy= x.x.x.0/255.255.255.224/0/0 (type=4),

src_proxy= x.x.x.x/255.255.240.0/0/0 (type=4)

crypto_isakmp_process_block:src:x.x.x.x, dest:x.x.x.x spt:500 dpt:50

0

OAK_QM exchange

oakley_process_quick_mode:

OAK_QM_AUTH_AWAITmap_alloc_entry: allocating entry 1

map_alloc_entry: allocating entry 2

ISAKMP (0): Creating IPSec SAs

inbound SA from x.x.x.x to x.x.x.x(proxy x.x.x.x to x.x.x.x)

has spi 2165352131 and conn_id 1 and flags 4

lifetime of 28800 seconds

lifetime of 4608000 kilobytes

outbound SA from x.x.x.x to x.x.x.x (proxy x.x.x.x to x.x.x.x)

has spi 842434996 and conn_id 2 and flags 4

ISADB: reaper checking SA 0xa19f34, conn_id = 0

ISADB: reaper checking SA 0xa19f34, conn_id = 0

ISADB: reaper checking SA 0xa19f34, conn_id = 0

Found the problem!!!!!!!!!!

This works

global (outside) 10 interface

nat (inside) 0 access-list nonat

nat (inside) 10 0.0.0.0 0.0.0.0 0 0

This doesnt.....Why???

global (outside) 20 interface

nat (inside) 10 access-list nonat 0 0

nat (inside) 20 0.0.0.0 0.0.0.0 0 0

Isnt the mumber just a nat-id ???

nat 0 access-list nonat means to disable nat for the ip blocks specified in that access list. any nat X value where x does not equal 0 means to perform nat, using the global pool statement included value X

Also, forgot to add the following URL, if you need to troubleshoot:

http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a0080094761.shtml

Jay