cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
34766
Views
25
Helpful
4
Replies

Fatal error during installation. A VPN connection cannot be established

dgaikwad
Level 5
Level 5

Today while installing AnyConnect from wireless network via CPP page, this error was repeatedly thrown at me.

I tried to install it by

  1. Running as admin
  2. Using version 4.7 and 4.8
  3. Install from wired network

Still the error was the same, it just changed to version 4.8 when tried to install using version 4.8

Failed to install AnyConnect Secure Mobility Client 4.7.04056 with installer error: Fatal error during installation. A VPN connection cannot be established.

Failed to install AnyConnect Secure Mobility Client 4.8.03043 with installer error: Fatal error during installation. A VPN connection cannot be established.

The Windows Events indicated the following errors, indicating that the installation as failed as it failed to move some files:

Function: CManifestMgr::ProcessManifests File: ManifestMgr.cpp Line: 852 Invoked Function: CManifest::ProcessFiles Return Code: -25690103 (0xFE780009) Description: MANIFESTMGR_ERROR_UNEXPECTED Failed to install required software
Also the installation log file indicated that, the installation failed due to error: Installation success or error status: 1603.

I am pretty sure that this is not an issue from ISE perspective, but totally issue with the endpoint that I am using for testing.
I am trying to get another test endpoint to verify, but as off now could anyone provide me pointers if what is causing this issue?

 

1 Accepted Solution

Accepted Solutions

dgaikwad
Level 5
Level 5

Was able to resolve the issue, after taking a look at the AnyConnect installation logs.
The logs that I capture indicated these following errors messages:

Installation success or error status: 1603. And Error 1316. The specified account already exists. Were blocking AnyConnect installation.
The second PC, that i was trying to install, its installation log file indicated this message, which was pretty straight forward:
Windows Installer reconfigured the product. Product Name: Cisco AnyConnect Secure Mobility Client. Product Version: 4.7.04056. Product Language: 1033. Manufacturer: Cisco Systems, Inc.. Reconfiguration success or error status: 1638.

But in both the cases, I was not able to find them installed on the endpoints, nor were listed in Add-Remove programs.
All the files and folder pertaining to AnyConnect were removed and endpoint was restarted as well.

Then the search for these error took me to the following Microsoft tool here

After downloading and running it on the affected endpoints was again able to install AnyConnect from the CPP page without any errors.

Thus I can conclude that the install was not working as the residual files were or state of AnyConnect was left behind thus causing it not to work as required.

View solution in original post

4 Replies 4

dgaikwad
Level 5
Level 5

Was able to resolve the issue, after taking a look at the AnyConnect installation logs.
The logs that I capture indicated these following errors messages:

Installation success or error status: 1603. And Error 1316. The specified account already exists. Were blocking AnyConnect installation.
The second PC, that i was trying to install, its installation log file indicated this message, which was pretty straight forward:
Windows Installer reconfigured the product. Product Name: Cisco AnyConnect Secure Mobility Client. Product Version: 4.7.04056. Product Language: 1033. Manufacturer: Cisco Systems, Inc.. Reconfiguration success or error status: 1638.

But in both the cases, I was not able to find them installed on the endpoints, nor were listed in Add-Remove programs.
All the files and folder pertaining to AnyConnect were removed and endpoint was restarted as well.

Then the search for these error took me to the following Microsoft tool here

After downloading and running it on the affected endpoints was again able to install AnyConnect from the CPP page without any errors.

Thus I can conclude that the install was not working as the residual files were or state of AnyConnect was left behind thus causing it not to work as required.

Hi @dgaikwad 

 

This solved my issue also!

 

I tried the Registry delete, folder delete, manual install, uninstall, and none worked. But when I tried to install via this tool. It fixed the issue. 

 

Thank you for the contribution and sharing the solution. 

 

Best regards,

Laura 

Yes: 

 

The AC install typically fails with this REG FIX: 

 

“Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DeviceInstall\Parameters\DeviceInstallDisabled” : If you ensure this registry key is set to 0 it will solve. 

Running the microsoft tool will check for any corrupt or busted up registries and will also solve this issue: 

RodKDDIA
Level 1
Level 1

This fix is not working for me 

I have version 4.9

It has worked for other people I see.

But I'm the unlucky one

The uninstall and install doesn't work

Event Viewer says 1316 error

I have ran the MSIEXEC /unregister followed by MSIEXEC /regserver..failed

Went services.msc to verify WindowsInstaller is is on and it is

Went to Regedit to removed all Cisco apps from HKEY_Current_USER > Software also checked the Wow6432Node ..failed. Checked the HKEY_Current_Machine > Software and Wow6432Node

Shutdown multiple times

This program just won't install

MS windows Home edition