cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
484
Views
0
Helpful
2
Replies

multiple instances of same username

jforst
Level 1
Level 1

I have a customer that insists on using the same username for upwards of 80

users that will be dialing into an AS5350. When the first instance of 'user1' connects the first

time, he gets an IP address. When the second instance connects (from a different PC and

different ISDN modem) to the same PRI phone number the second instance user1 gets

the same IP address as the first user1. I suspected something like MLPPP was on

by default, but apparently not the case as I did 'no ppp multilink' on the

dialer and group-async interfaces to no effect.

So, the question, how to have multiple instances of the same username dial in to

the same PRI and yet get different IP addresses?

TIA,

Jason

Config:

!

hostname 5350

!

username cisco privilege 15 secret 5 somepassword

username user1 password 0 someotherpassword

username user2 password 0 yetanotherpassword

!

!

resource-pool disable

aaa new-model

!

!

aaa authentication login default local

aaa authentication ppp default local

aaa authorization network default local

aaa session-id common

ip subnet-zero

!

no ip domain lookup

!

no ip bootp server

isdn switch-type primary-dms100

!

controller E1 3/0

pri-group timeslots 1-31

!

controller E1 3/1

!

interface Loopback0

ip address 10.252.254.1 255.255.255.255

!

interface Loopback1

ip address 10.254.1.1 255.255.255.192

!

interface FastEthernet0/0

ip address 10.99.10.201 255.255.255.0

ip ospf hello-interval 5

ip ospf dead-interval 10

ip ospf priority 0

duplex full

speed 100

!

interface FastEthernet0/1

no ip address

shutdown

!

interface Serial0/0

no ip address

clockrate 2000000

!

interface Serial0/1

no ip address

clockrate 2000000

!

interface Serial3/0:15

no ip address

encapsulation ppp

dialer rotary-group 0

dialer-group 1

isdn switch-type primary-dms100

isdn incoming-voice modem

no cdp enable

!

interface Async1/30

no ip address

!

!<SNIP><<<all the other (as yet) unassigned async interfaces>>>

!

interface Async1/59

no ip address

!

interface Group-Async0

ip unnumbered Loopback1

encapsulation ppp

async mode dedicated

peer default ip address pool pool0

ppp authentication pap callin

group-range 1/00 1/29

!

interface Dialer0

ip unnumbered Loopback1

encapsulation ppp

dialer in-band

dialer idle-timeout 360

dialer-group 1

peer default ip address pool pool0

no cdp enable

ppp authentication pap callin

!

router ospf 1

log-adjacency-changes

redistribute connected subnets

passive-interface Serial0/0

passive-interface Serial0/1

network 10.0.0.0 0.255.255.255 area 0

!

ip local pool pool0 10.254.1.2 10.254.1.62

ip classless

ip http server

ip http authentication local

!

!

access-list 187 permit icmp any any log

dialer-list 1 protocol ip permit

!

!

!

voice-port 3/0:D

!

!

!

!

alias exec deb187 debug ip packet detail 187

!

line con 0

exec-timeout 0 0

privilege level 15

password cisco

length 35

width 132

history size 256

line aux 0

exec-timeout 0 0

privilege level 15

password cisco

modem InOut

length 35

width 132

history size 256

transport input all

flowcontrol hardware

line vty 0 4

exec-timeout 0 0

privilege level 15

password cisco

length 35

width 132

history size 256

transport input telnet

line vty 5 15

exec-timeout 0 0

privilege level 15

password cisco

length 35

width 132

history size 256

transport input telnet

line 1/00 1/29

no flush-at-activation

modem InOut

transport input all

autoselect during-login

line 1/30 1/59

modem InOut

!

end

2 Replies 2

lgijssel
Level 9
Level 9

That is a cute one! The problem arises because you are using authentication to identify the user. Using the same userID for different callers will make the router confused as it has no means to distinguish between them. Therefore I suppose this will not work, you MUST use different ppp usernames for different callers.

Regards,

Leo

Yes, I suspect you are right. May be able to do this by using Caller ID, not sure yet. I've opened a case w/ TAC, no resolution yet.

tnx,

Jason