cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
404
Views
0
Helpful
1
Replies

PPP stuck in IPCP

mahditalebi
Level 1
Level 1

Hi Guys,

We are using cisco 1841 router as a L2TP VPN client to connect to a VPN server. Our configuration is mentioned bellow:

crypto ipsec transform-set ESP-AES256-SHA1 esp-aes 256 esp-sha-hmac
mode transport
!

ip access-list extended ACL1
permit udp host 2.3.4.5 eq 1701 host 1.2.3.4 eq 1701

!

crypto map L2TP_VPN 10 ipsec-isakmp
set peer 1.2.3.4
set transform-set ESP-AES256-SHA1
match address ACL1

!

crypto isakmp policy 10
encr 3des
authentication pre-share
group 2

!
crypto isakmp key 6 PrEsHaReD-kEy address 1.2.3.4

!

interface FastEthernet0/0
ip address 2.3.4.5 255.255.255.0
ip virtual-reassembly in
duplex auto
speed auto
crypto map L2TP_VPN

!

pseudowire-class L2TP_PW1
encapsulation l2tpv2
ip local interface FastEthernet0/0

!

interface Virtual-PPP1
description L2TP-Tunnel
ip address negotiated
ip virtual-reassembly in
ppp authentication ms-chap-v2 optional
ppp eap refuse
ppp chap hostname USER1
ppp chap password 0 P@SS
ppp ipcp dns accept
ppp ipcp address accept
no cdp enable
pseudowire 1.2.3.4 1 pw-class L2TP_PW1

Here is relevent debug log:

Nov 11 12:25:38.871: Vp1 PPP: Phase is UP
Nov 11 12:25:38.871: Vp1 IPCP: Protocol configured, start CP. state[Initial]
Nov 11 12:25:38.871: Vp1 IPCP: Event[OPEN] State[Initial to Starting]
Nov 11 12:25:38.871: Vp1 IPCP: O CONFREQ [Starting] id 1 len 10
Nov 11 12:25:38.871: Vp1 IPCP: Address 0.0.0.0 (0x030600000000)
Nov 11 12:25:38.871: Vp1 IPCP: Event[UP] State[Starting to REQsent]
Nov 11 12:25:38.871: Vp1 IPCP: Event[DOWN] State[REQsent to Starting]
Nov 11 12:25:38.871: Vp1 IPCP: Event[CLOSE] State[Starting to Initial]
Nov 11 12:25:38.871: Vp1 LCP: Event[CLOSE] State[Open to Closing]
Nov 11 12:25:38.871: Vp1 PPP: Phase is TERMINATING

We can create SA, but PPP get stucked in IPCP phase without any answer from VPN Server.

1 Reply 1

Philip D'Ath
VIP Alumni
VIP Alumni

Can you get a debug from the server to find why it is not responding?