cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
869
Views
0
Helpful
3
Replies

ACE Source NAT

shahkamrah
Level 1
Level 1

Hi Team,

I have ACE implemented in the routed mode.We have 2 servers and 2 users in the same vlan.

2 of the servers are getting loadbalanced.Now the other 2(users) which are not getting load balanced want to access the severs using in VIP for the load balanced servers.

Now the issue is all the servers are having the same subnet, How should i proceed in this can i have the sample configuration regarding this.

3 Replies 3

aslamta123
Level 1
Level 1

Hi,

For source nating you can try as follows ..

-- define a class --

class-map match-all NAT

2 match source-address " subnet "

-- in policy map multimatch --

class NAT

nat dynamic 9 vlan "server vlan "

--create a nat pool in server interface --

nat-pool 9 "IP pool" netmask 255.255.255.255 pat

Regards

Aslam..

Thanks for solution.

But the main question is why there is a problem in ACE when we are trying to achieve load balancing in the same subnet ?

Hi,

configuration example that may be helpful for u.

class-map match-all SNAT

2 match source-address 10.10.10.0 255.255.255.0

policy-map multi-match L4

class HTTP-SFARM

loadbalance vip inservice

loadbalance policy WEB-PM

loadbalance vip icmp-reply

class SNAT

nat dynamic 100 vlan 31

interface vlan 31(Server Vlan)

ip address 10.10.10.2 255.255.255.0

alias 10.10.10.1 255.255.255.0

peer ip address 10.10.10.4 255.255.255.0

mac-sticky enable

access-group input 1

nat-pool 100 1.1.1.100 1.1.1.100 netmask 255.255.255.255 pat

service-policy input L4

no shutdown

ACE1/SP1# sh xlate

TCP PAT from vlan31:10.10.10.10/1149 to vlan31:1.1.1.100/1025

Regards,

Rajesh