Showing results for 
Search instead for 
Did you mean: 


WAAS Filesystem_size_mismatch alarm

We have 5 waas appliances including the CM (4 wae-512, 1 wae-674.)  Starting with the CM, I upgraded all devices to SW version 4.3.1.  After the upgrade and the devices came back online, one of the wae-512s reports an alarm  "filesystem_size_mismatch, one or more filesystems have got invalid size."

The alarm book codes indicate possible causes as recent memory change or wrong manufacturing procedure.  No hardware changes have happened on any of the devices so I'm curious if anyone else has run into this message or what may be causing it?

I tried reloading the SW image once more (No effect) and the show hardware statement from the command line seems to indicate all hardware is ok.  Device seems to be functioning other than the alarm that keeps showing up.  Any ideas would be greatly appreciated.  Thank you.


Accepted Solutions

Cool. Please mark this as Answered as this addresses your issue.


View solution in original post

Bhavin Yadav
Cisco Employee


Please try following option and let us know how it goes.

wae# disk delete-data-partitions

wae# reload

Please note that this will clear the cache and rebuild the file system and might take longer than average time to relaod the box.

Please let us know how it goes.


Awesome!  That fixed it.  I tried clearing the cache in the device gui but wasn't familiar with the disk delete commands.  Thanks for your help.


Cool. Please mark this as Answered as this addresses your issue.


View solution in original post

Is there a known cause for this error and the need to clear the cache?  I have upgraded 3 of our devices and ran into this error on 1 of the 3.  I have a large number of other devices to upgrade and would rather not have to clear the cache.

We added more memory, and now we are seeing that error.

Besides running that command and doing a reboot would we need to do a re-install ?

man oh man, what would I do without NetPro?!

thanks! | ieMentor | CEO & Founder | 8xCCIE#7927



Does the WAE rebuilds it self OR I must reinstall the WAAS software through DVD or any other way?

Please help.






This command - disk delete-data-partitions, does not affect the WAAS software only the DRE cache.  It will reload with the current WAAS version.



Thanks Burt,


This resolved our issue and now the WAE is working fine.


Anand :)

Cisco Employee

For the benefit of others facing this, please know that there is another situation when the filesystem_size_mismatch alarm can be raised after upgrade from 4.1.X or 4.2.X to 4.3.1

Use the command "show disk details" and check if the /swstore partition size is equal to 495MB or 991MB. If it shows as close to 500MB it means that the device was once running ACNS. In the WAAS software this partition size should be close to 1GB. In this situation it is necessary to delete all partitions (not only the data partitions), and since this will remove the software it has to be reinstalled. The command to delete all partitions is "delete-partitions". I hope this helps.

Fabio Bergamo

Cisco TAC


Hi All

I experienced the same issue as above, I took Fabio's advice of doing 'sh disk details' and saw the /swstore was indeed 991MB, so then I ran the command Bhavin recommended of 'disk delete-data-partitions' and it worked 100% after a reload.

A note though, once reloaded give the WAE some time to rebuild the disks etc before running any checks.

Thanks all.



Content for Community-Ad
This widget could not be displayed.