Showing results for 
Search instead for 
Did you mean: 

Cisco MPP Dialpad issue


Hey all,


Checking out the Cisco mpp api and am able to run all other commands except ones that involve a dialpad. Im using the correct call because when I enter a button besides the dialpad it is reflected on the phone such as.

{"Request-URI": "/api/Ui/v1/SendKey","action":1, "key":"Speaker"}
However when using a call such as 
{"Request-URI": "/api/Ui/v1/SendKey","action":1, "key":"Dialpad_8"}
A 200 success is returned however no changes are reflected on the phone. Dialpad_8 appears to be the correct button as when I enter a purposely wrong string such as just "8" an error is generated. 
Let me know if anyone has seen this issue or has been able to use the Dialpad api successfully.
2 Replies 2

Cisco Employee
Cisco Employee

Just guessing, but have you tried other values for "Action", i.e. 0?  The docs don't seem to detail what that parameter is precisely, but I'm assuming its something like 0=press+release, 1=press, 2=release...perhaps only a 'press' without a release is happening?

The support options seem to suggest you can open a TAC case for this API...might be worth a try:!support

Thanks for the reply!


Yes I have tried actions 0,1,2 as well as different names for the dialpad buttons such as Dialpad_eight. Will try and open a tac case as well thanks. 

As well, tried pressing the line key call button first then entering digits with sleeps in-between calls. Pressing the line key works then entering digits is unsuccessful. 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: