cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
2799
Views
9
Helpful
13
Replies

Debbuging PnP process

Hi All,

I can't find any information about how to debug failed PnP proccess, where is log files stored and so on .

I'm trying to deploy config on ISR router and getting:

Received response from pnp agent for message correlatorId: CiscoPnP-1.0-16-320-7FA078EAB2A8-14 but with error code : ZTD_CMD_ERROR Response String: ERROR:PnP Service Error 1410:Invalid config found

service log:

I understand that  there is mistake in config file, but maybe there is a way to find out where exactly this mistake is  ?

1 ACCEPTED SOLUTION

Accepted Solutions

I found workaround.

I've used Denali-16.3.4(ED) image on router and my config failed to install, but today I tried to change it to 3.16.5S and config deployed successfully.

View solution in original post

13 REPLIES 13
aradford
Cisco Employee

I usually just cut/paste the config into the console to test.

Do you have a  "service log" command in the configuration?

Adam

No, I don't have this command. The problem is that I created config on router and then  I just uploaded it to Apic-em and now trying to deploy it via Pnp

ok.  To access log files:

ssh to the console of the APIC-EM

# find the IP address of the pnp service

$ grape instance status | grep pnp

pnp-service                          5.17.31.211  running      59621988-fdc9-4788-957c-7bdbb7de0922  169.254.0.184  9:32:39

$ ssh 169.254.0.184

# the number for you will be different.

$ cd /var/log/grapevine/services/pnp-service/5.17.31.211/

# pnp-service.log has all of the logging.

$ ls

pnp-service.log

I found it. However there is no useful information, just same message that I posted in my question.

I got info from router:

show pnp task

------------------ show pnp tasks ---------------------

Certificate-Install Task - Last Run ID:2, ST:7201, Result:Success, LT:94182, ET:3338 ms

        Src:[http://pnpserver.domain.com:80/ca/pem], Dst:[pnplabel]

Device-Auth Task - Never Run

Device-Info Task - Never Run

Image-Install Task - Never Run

SMU Task - Never Run

Config-Upgrade Task - Last Run ID:5, ST:5202, Result:Failed, LT:545313, ET:6806 ms

        Src:[https://pnpserver.domain.com:443/api/v1/file/onetimedownload/7efee699-39bf-47bb-af21-9202921cbe], Dst:[running]

        Error Code:1410, Msg:[Invalid config found]

CLI-Config Task - Last Run ID:3, ST:5201, Result:Success, LT:156998, ET:84 ms

        Src:[cli-config request], Dst:[running-config]

Licensing Task - Never Run

File-Transfer Task - Never Run

Redirection Task - Never Run

CLI-Exec Task - Last Run ID:1, ST:5401, Result:Success, LT:80463, ET:3 ms

        Src:[cli-exec request], Dst:[running-exec]

Script Task - Never Run

As i understand this error tells that it trying to get config from apic-em but failed. It is not my config problem.

Am I correct ?

What version of APIC-EM is this?  We now check for "special characters" but may not catch all of them.

Do you accidentally have special characters in your config file?

Were you using a windows device to edit the config file?

APIC-EM Version 1.5.0.1368.

PnP 1.5.0.211

Config has special chars in commands:

enable secret 5 hashed secret   

username admin secret 5 hashed secret

those are ok.. You probably should delete that information.

you can edit your post and remove it.

By special characters, I mean things like windows smart quotes or '\r' type sequences.

What did you use to edit the configuration file?

I found workaround.

I've used Denali-16.3.4(ED) image on router and my config failed to install, but today I tried to change it to 3.16.5S and config deployed successfully.

View solution in original post

interesting.. let me chat to engineering about that.

What device were you running this on?

cisco ISR4321/K9

Suite License Information for Module:'esg'

--------------------------------------------------------------------------------

Suite                 Suite Current         Type           Suite Next reboot

--------------------------------------------------------------------------------

FoundationSuiteK9     FoundationSuiteK9     Permanent      FoundationSuiteK9

securityk9

appxk9

For example with this command

mpls ldp tcp pak-priority it fails on Denali software.

Thanks.

Just to clarify are you saying the configuration file has differences between 16.3.4 and 3.16.5S?

e.g. mpls ldp pak-priority is in your config file and the does not work on 16.3.4.

Or that the PnP process does not work correctly in 16.3.4?

Adam

No, I was using same config with these two versions.

When I was trying to find problem  I started to remove some configuration lines.

Manually pasting this line mpls ldp pak-priority is showing Notice message so I decided to remove it first.

But this line pasted on 3.16.5S showing the same message, but pnp process is not stopping on it.