Showing results for 
Search instead for 
Did you mean: 

CSR1000V on AWS - Cannot access after applying license


I am trying to create an instance on AWS for the CSR1000v using the BYOL in the AWS Marketplace: .

Once the instance comes online, I'm able to SSH into it using the keys associated. Then, following the instructions here, I try to apply a license to the Cisco instance.

Once I get to the reload step, the router reboots, but I'm never able to access the router again. I cannot ssh in using the key or username/password. I tried creating user-keys within AWS to create a user with a valid username password to no avail. My only recourse is to kill the instance and start a new one. Unfortunately, the new one will not have any of my settings.

Is there a way for me to persist the settings, or better yet, get back into the instance I've already created?

Any help would be appreciated.

3 Replies 3

Cisco Employee
Cisco Employee

Hello k.sadowski

Were you able to get CSR working on AWS after licensing it?

We can help if you are still having issues

After many hours of much frustration. I managed to figure it out. In the end it was the name of the ssh keys used. It was due to a space in the name of the key itself on AWS. Once I created a new key without a space, I was able to create a new instance and reboot at will. So now I have to keep track of another key pair.

This was particularly frustrating because it worked for the first boot, but I connect back in on the second boot. It was completely repeatable in my environment, but not for anyone else.

Anyway, in the end it was due to a space in the name of the AWS Key Pair. Thanks for checking in.