Showing results for 
Search instead for 
Did you mean: 

not able to activate CSR 1000v

I deployed a CSR 1000v - Cisco Cloud Services Router (CSR) 1000V - Advanced Technology Package

When I logged in using my key and user ec2-user, I tried to activate it as per the documentation. 

However, it does not work. The cli -
 license boot level { standard advanced | premium } 

errors out with an error of unrecognized command. 

Also, is there a way to drop into the shell ? 


Everyone's tags (1)

Hello Shankar,Are you sure

Hello Shankar,

Are you sure you are putting this command in config mode?

Can you drop here log from the console when you are doing that?


As for the shell access , you need for it special license that you can't buy, you can only get it for limited time from Cisco TAC. It is only for troubleshooting purposes when Cisco TAC is involved.

Best Regards,





I have this very same issue

I have this very same issue after launching (and after reboot) my Cisco Cloud Services Router (CSR) 1000V - Advanced Technology Package via AWS.  The "Free Trial" does not allow us to work with the system or perform very basic commands, which has led us to believe the system is not licensed.  Following the limited documentation found for this device has not netted any results in getting to a usable state.

Show Version:

Cisco IOS XE Software, Version 03.12.00.S - Standard Support Release
Cisco IOS Software, CSR1000V Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 15.4(2)S, RELEASE SOFTWARE (fc2)

License Level: advanced
License Type: Default. No valid license found.
Next reload license Level: advanced



config t

license boot level advanced
% Invalid input detected at '^' marker.

We need to ensure this will work to resolve the issue we are facing, however, if it is not further configurable without a full license, we will be unable to use this solution.



Could you please just try to

Could you please just try to reload the router ?

from the output you have provided :

"Next reload license Level: advanced"




Thanks, I had tried this

Thanks, I had tried this multiple times to no avail.





Could you please check if SL

Could you please check if SL enabled? With this "license boot level"  should not be visible. Please test after :

no license smart enable

We were finally able to start

We were finally able to start working with it.  The network engineer started using completely different commands from other Cisco documentation in order to configure it.  I am curious if anyone else had had this issue with the documentation not aligning with the product.




Hi Dave,I am glad that this

Hi Dave,

I am glad that this is resolved. Could you please let us know which commands were used at the end ( that worked )?

If there is something wrong or even unclear in documentation we can fix it. Just let me know.




I will gather what

I will gather what information I can when my network engineer returns on the 15th.  He said he had to use different commands from other Cisco documentation from other products.


In this document I have found

In this document I have found that :

"In the case of an evaluation license, a EULA is presented during an SSL VPN policy configuration or an SSL VPN profile configuration."

Is that what happened in your scenario?

As a person who configures it first time, what information you believe is missing?

I am asking because I can request it to be changed to be more clear.



What happened in our scenario

What happened in our scenario is the commands simply did not work.

e.g.  license boot level { standard | advanced | premium } 

No matter what commands were run in config it was unrecognized, including the license agreement commands.  As seen in my original post.

It appears more resources have come available on that page since my original post.  I cannot verify at this time if they correct or not as I have passed this system to the Network Engineer to configure.  He used the doc I posted previously.  






Using the following document:

Using the following document:

I configured the CSR1000v accordingly. There were some differences in the doc, however that I had to work around as best I could. For example, the document says to do the following to configure an IP address to the ssl crypto policy:

ip address local port 446


This isn't possible on the AWS version of the CSR1000v. I can only specify an interface -- and can only use port 443 for some reason...but the port thing is not a big deal. This is what I configured instead of the command listed in the documentation:

ip interface GigabitEthernet1 port 443

Where interface Gig 1 is configured with my internal DMZ ip address.

After following the documentation, When I point my browser to


I hit the self-signed cert warning. Once I accept it, It loads a plain white page.

Alternatively, When I point my anyconnect to that IP, it again gives me a warning about the cert being self-signed, then when I say "connect anyway" It immediately gives me a "Connection attempt has failed." message.

So it seems like the CSR1000v correctly has the cert configured...and is listening on 443 as it should. But the actual VPN part is missing something. Any ideas?


He was able to begin


This is happening to me too.

This is happening to me too.  How do I get this to work?


I've tried to do the same but

I've tried to do the same but have the same issue so followed the following URL and it also failed:


tunnelbox(config)#license boot level premium
% Invalid input detected at '^' marker.



What gives, I've tried deploying 03.14.01.S and 03.13.01.S and they all fail.

Please help!!!


tunnelbox#license install bootflash:cisco2.lic
Installing licenses from "bootflash:cisco2.lic"

Expiring licenses are being installed in the device with
UDI "CSR1000V:9ZAUYRV1STH" for the following features:

        Feature Name: ipb_10G
        Start Date:         N/A, End Date: Dec 08 2015


Activation  of the  software command line interface will be evidence of
your acceptance of this agreement.

ACCEPT? (yes/[no]): yes
Installing...Feature:ipb_10G...Successful:Not Supported
1/1 licenses were successfully installed
0/1 licenses were existing licenses
0/1 licenses were failed to install

tunnelbox#show license detail
Index: 1        Feature: ipb_10G                           Version: 1.0
        License Type: Paid Subscription
        Start Date:         N/A, End Date: Dec 08 2015
        License State: Active, Not in Use
        License Count: Non-Counted
        License Priority: Medium
        Store Index: 0
        Store Name: Primary License Storage

tunnelbox#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
tunnelbox(config)#license boot level ax
% Invalid input detected at '^' marker.


This widget could not be displayed.