cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
976
Views
0
Helpful
1
Replies

CML is driving me nuts :-)

pgaltieri
Level 1
Level 1

I have 2 systems, one at 192.168.10.5 runs a dhcp server, one at 192.168.10.66 runs the CML ova and the UI.  I create a topology under CML which consists of a ext-conn device, an un-managed switch, and iosv device and an iosvl2 device.  All devices are connected to the un-managed switch.  I configure the iosv device to get it's address via dhcp.  I also configured the iosvl2 device to get it's address via dhcp.  When I start the simulation the iosv device get's its address from dhcp and all is fine.  The iosvl2 device nothing.  Now to configure the iosvl2 switch I did as follows:

conf t

vlan 10

name 192Subnet10VLAN

int vlan 10

ip addr dhcp

ip dhcp client request dns-nameserver

ip dhcp client request domain-name

ip dhcp client request router

shut

no shut

end

I also did the following:

 

truckin-iosvl2(config)#vrf definition Mgmt-intf
truckin-iosvl2(config-vrf)#address-family ipv4
truckin-iosvl2(config-vrf-af)#int vlan 10

truckin-iosvl2(config-if)#ip address dhcp
truckin-iosvl2(config-if)#
truckin-iosvl2(config-if)#ip dhcp client request dns-nameserver
truckin-iosvl2(config-if)#ip dhcp client request domain-name
truckin-iosvl2(config-if)#ip dhcp client request router
truckin-iosvl2(config-if)#shut
truckin-iosvl2(config-if)#no shut
truckin-iosvl2(config-if)#exit
truckin-iosvl2(config)#ip route vrf Mgmt-intf 0.0.0.0 0.0.0.0 192.168.10.65
truckin-iosvl2(config)#end

 

when I do sh run to look at the config I see:

interface Vlan10
ip address dhcp
!

None of the other dhcp commands are shown.  Also as soon as I created vlan 10 I get a console message:

*Jun 10 21:29:54.826: %LINK-3-UPDOWN: Interface Vlan10, changed state to down

 

No matter how many times I try to do a no shut on vlan 10 it never changes state from down.

truckin-iosvl2#sh ip int br
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 unassigned YES unset up up
GigabitEthernet0/1 unassigned YES unset up up
GigabitEthernet0/2 unassigned YES unset up up
GigabitEthernet0/3 unassigned YES unset up up
Vlan10 unassigned YES manual down down

 

It doesn't even show vlan 10 as having method dhcp.

 

The main thing that is driving me nuts is why can't I ping devices outside the topology?  The iosv device gets its address from a system outside the topology why can't I then ping that device?  I have attached the iosvl2 config

 

truckin-iosvl2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

 

Any help is appreciated.

I tried to add the configuration by click on "Choose Files" and chose the configuration file, but I got an error saying "The contents of the attachment doesn't match its file type."  So here is the config:

Current configuration : 2908 bytes
!
! Last configuration change at 21:31:03 UTC Wed Jun 10 2020
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname truckin-iosvl2
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
!
no aaa new-model
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
negotiation auto
!
interface GigabitEthernet0/1
negotiation auto
!
interface GigabitEthernet0/2
negotiation auto
!
interface GigabitEthernet0/3
negotiation auto
!
interface Vlan10
ip address dhcp
!
ip forward-protocol nd
!
ip http server
ip http secure-server
!
ip route vrf Mgmt-intf 0.0.0.0 0.0.0.0 192.168.10.65
ip ssh server algorithm encryption aes128-ctr aes192-ctr aes256-ctr
ip ssh client algorithm encryption aes128-ctr aes192-ctr aes256-ctr
!
!
!
!
!
!
control-plane
!
banner exec ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS *
* education. IOSv is provided as-is and is not supported by Cisco's *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any *
* purposes is expressly prohibited except as otherwise authorized by *
* Cisco in writing. *
**************************************************************************^C
banner incoming ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS *
* education. IOSv is provided as-is and is not supported by Cisco's *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any *
* purposes is expressly prohibited except as otherwise authorized by *
* Cisco in writing. *
**************************************************************************^C
banner login ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS *
* education. IOSv is provided as-is and is not supported by Cisco's *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any *
* purposes is expressly prohibited except as otherwise authorized by *
* Cisco in writing. *
**************************************************************************^C
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

 

Paolo

1 Reply 1

Ollie Y
Level 1
Level 1
None of your ports are in vlan 10. You'll need to setup "switchport access vlan 10" on the port you are connecting to the unmanaged switch. By default they are only in vlan 1.