cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
193
Views
0
Helpful
5
Replies
Highlighted
Beginner

Port stays in err-disable state

I have two cisco catalyst 9300 series switches which are connected to each other over te1/1/1.
The problem is that when I e.g. perform a reload on one switch (switch-01) I get an err-disable on (switch-02)
ERR_DISABLE udld error detected on Te1/1/1, putting Te1/1/1 in err-disable state
And this port stays in this state until I perform a shutdown and no shutdown.
Is there any comfiguration Point to blame this symptom?

 

Everyone's tags (4)
5 REPLIES 5
VIP Advisor

Re: Port stays in err-disable state

Can you post below information from both the switch.

 

show version

show run interface ten 1/1/1

show udld

 

 

post complete log when it generated Log with error disable to understand.

 

 

BB
*** Rate All Helpful Responses ***
Beginner

Re: Port stays in err-disable state

Switch-01   Version

switch-01# sh ver

Cisco IOS XE Software, Version 16.06.06
Cisco IOS Software [Everest], Catalyst L3 Switch Software (CAT9K_IOSXE), Version 16.6.6, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2019 by Cisco Systems, Inc.
Compiled Thu 11-Apr-19 03:51 by mcpre


Cisco IOS-XE software, Copyright (c) 2005-2019 by cisco Systems, Inc.
All rights reserved.  Certain components of Cisco IOS-XE software are
licensed under the GNU General Public License ("GPL") Version 2.0.  The
software code licensed under GPL Version 2.0 is free software that comes
with ABSOLUTELY NO WARRANTY.  You can redistribute and/or modify such
GPL code under the terms of GPL Version 2.0.  For more details, see the
documentation or "License Notice" file accompanying the IOS-XE software,
or the applicable URL provided on the flyer accompanying the IOS-XE
software.


ROM: IOS-XE ROMMON
BOOTLDR: System Bootstrap, Version 16.8.1r [FC4], RELEASE SOFTWARE (P)

switch-01 uptime is 20 hours, 24 minutes
Uptime for this control processor is 20 hours, 30 minutes
System returned to ROM by Reload Command at 13:16:38 MEST Tue Jun 4 2019
System restarted at 13:24:19 MEST Tue Jun 4 2019
System image file is "flash:packages.conf"
Last reload reason: Reload Command



This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.


Technology Package License Information:

-----------------------------------------------------------------
Technology-package                   Technology-package
Current             Type             Next reboot
------------------------------------------------------------------
network-advantage   Permanent        network-advantage
dna-advantage       Subscription     dna-advantage

cisco C9300-24T (X86) processor with 1392597K/6147K bytes of memory.
Processor board ID CENSORED
4 Virtual Ethernet interfaces
28 Gigabit Ethernet interfaces
8 Ten Gigabit Ethernet interfaces
2 Forty Gigabit Ethernet interfaces
2048K bytes of non-volatile configuration memory.
8388608K bytes of physical memory.
1638400K bytes of Crash Files at crashinfo:.
11264000K bytes of Flash at flash:.
0K bytes of WebUI ODM Files at webui:.

Base Ethernet MAC Address          : CENSORED
Motherboard Assembly Number        : CENSORED
Motherboard Serial Number          : CENSORED
Model Revision Number              : E0
Motherboard Revision Number        : B0
Model Number                       : C9300-24T
System Serial Number               : CENSORED


Switch Ports Model              SW Version        SW Image              Mode
------ ----- -----              ----------        ----------            ----
*    1 38    C9300-24T          16.6.6            CAT9K_IOSXE           INSTALL


Configuration register is 0x102





Switch-02   Version

switch-02>sh ver
Cisco IOS XE Software, Version 16.08.01a
Cisco IOS Software [Fuji], Catalyst L3 Switch Software (CAT9K_IOSXE), Version 16.8.1a, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2018 by Cisco Systems, Inc.
Compiled Tue 03-Apr-18 18:49 by mcpre


Cisco IOS-XE software, Copyright (c) 2005-2018 by cisco Systems, Inc.
All rights reserved.  Certain components of Cisco IOS-XE software are
licensed under the GNU General Public License ("GPL") Version 2.0.  The
software code licensed under GPL Version 2.0 is free software that comes
with ABSOLUTELY NO WARRANTY.  You can redistribute and/or modify such
GPL code under the terms of GPL Version 2.0.  For more details, see the
documentation or "License Notice" file accompanying the IOS-XE software,
or the applicable URL provided on the flyer accompanying the IOS-XE
software.


ROM: IOS-XE ROMMON
BOOTLDR: System Bootstrap, Version 16.8.1r [FC4], RELEASE SOFTWARE (P)

switch-02 uptime is 16 weeks, 2 days, 12 hours, 4 minutes
Uptime for this control processor is 16 weeks, 2 days, 12 hours, 6 minutes
System returned to ROM by PowerOn at 07:30:42 MEST Wed Sep 26 2018
System restarted at 21:49:22 MET Sun Feb 10 2019
System image file is "flash:packages.conf"
Last reload reason: PowerOn



This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.


Technology Package License Information:

------------------------------------------------------------------------------
Technology-package                                     Technology-package
Current                        Type                       Next reboot
------------------------------------------------------------------------------
network-advantage             Permanent           network-advantage
dna-advantage                 Subscription        dna-advantage

cisco C9300-48T (X86) processor with 898220K/6147K bytes of memory.
Processor board ID CENSORED
6 Virtual Ethernet interfaces
80 Gigabit Ethernet interfaces
16 Ten Gigabit Ethernet interfaces
4 TwentyFive Gigabit Ethernet interfaces
4 Forty Gigabit Ethernet interfaces
2048K bytes of non-volatile configuration memory.
8388608K bytes of physical memory.
1638400K bytes of Crash Files at crashinfo:.
1638400K bytes of Crash Files at crashinfo-2:.
11264000K bytes of Flash at flash:.
11264000K bytes of Flash at flash-2:.
0K bytes of WebUI ODM Files at webui:.

Base Ethernet MAC Address          : CENSORED
Motherboard Assembly Number        : CENSORED
Motherboard Serial Number          : CENSORED
Model Revision Number              : A0
Motherboard Revision Number        : A0
Model Number                       : C9300-48T
System Serial Number               : CENSORED


Switch Ports Model              SW Version        SW Image              Mode
------ ----- -----              ----------        ----------            ----
*    1 64    C9300-48T          16.8.1a           CAT9K_IOSXE           INSTALL
     2 40    C9300-24T          16.8.1a           CAT9K_IOSXE           INSTALL


Switch 02
---------
Switch uptime                      : 16 weeks, 2 days, 12 hours, 5 minutes

Base Ethernet MAC Address          : CENSORED
Motherboard Assembly Number        : CENSORED
Motherboard Serial Number          : CENSORED
Model Revision Number              : A0
Motherboard Revision Number        : A0
Model Number                       : C9300-24T
System Serial Number               : CENSORED

Configuration register is 0x102

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Beginner

Re: Port stays in err-disable state

Switch 1 INT

switch-01# show run interface ten 1/1/1

Building configuration...

Current configuration : 299 bytes
!
interface TenGigabitEthernet1/1/1
 description -> switch-02 XX
 no switchport
 vrf forwarding XX
 ip address 192.168.1.2 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip mtu 1500
 ip ospf priority 10
 ip ospf 1 area 100
 service-policy input pm_input
 service-policy output pm_output
end

Switch 2 int

switch-02# show run interface ten 1/1/1

Building configuration...

Current configuration : 193 bytes
!
interface TenGigabitEthernet1/1/1
 description switch-01
 no switchport
 ip address 192.168.1.1 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip ospf priority 5
 ip ospf 1 area 100
end

Beginner

Re: Port stays in err-disable state

Switch 1 udld int

switch-01# show udld ten 1/1/1

Interface Te1/1/1
---
Port enable administrative configuration setting: Follows device default
Port enable operational state: Enabled / in aggressive mode
Current bidirectional state: Unknown
Current operational state: Advertisement
Message interval: 7000 ms
Time out interval: 5000 ms

Port fast-hello configuration setting: Disabled
Port fast-hello interval: 0 ms
Port fast-hello operational state: Disabled
Neighbor fast-hello configuration setting: Disabled
Neighbor fast-hello interval: Unknown

No neighbor cache information stored

Switch 2 udld int

switch-02#sh udld ten 1/1/1

Interface Te1/1/1
---
Port enable administrative configuration setting: Follows device default
Port enable operational state: Disabled
Current bidirectional state: Unknown

 

 

 

VIP Advisor

Re: Port stays in err-disable state

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards